RTL8822CE Instability even with newest kernel

5G Wifi keeps being stopped or disconnected after around 10 minutes or when more than 70 mbps is used

You can try two workarounds. Turn off wifi power save first. Create .conf file:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

And copy these two lines inside it:

wifi.powersave = 2

If the issue remains, turn off Mac Randomization. Create .conf file:

sudo nano /etc/NetworkManager/conf.d/disable-random-mac.conf

Copy these two lines inside:


Hope this can solve your problem.