RTL8822BE Wi-Fi not showing

I have Asus X411UF laptop and I have problem with Wi-Fi… I’m trying to use Manjaro KDE 20.3 downloaded from Manjaro Website. But when I booted it. My Wi-Fi doesn’t show up. I mean it got Wi-Fi logo at the bottom but when I click it, its blank and doesn’t show any networks… Any solution please? I wanna get rid of Windows completely and as long as my Wi-Fi doesn’t work fully in Manjaro. I can’t switch… By the way I noticed that when I restart from Windows to USB of Manjaro KDE 20.3… My Wi-Fi shows up. But after restart. Nothing… It seems like I need to go to Windows first then to Manjaro again to have my Wi-Fi working.

Hello LightCalvary,
please do inxi -n in Manjaro and write the output here.
This is to see whether a network card is recognized.
Best Regards, Julius

1 Like

I found this …


There are two ways to build:

sudo pacman -S dkms
git clone https://aur.archlinux.org/packages/rtw88-dkms-git/
cd rtw88-dkms-git
makepkg -si


sudo pacman -S dkms
pamac build rtw88-dkms-git
1 Like

First, make sure system is updated:

sudo pacman-mirrors -f && sudo pacman -Syyu


For dkms you need the kernel headers. So the following command (credit to @dalto) can be used to install the headers upfront:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

should be replaced by

sudo pacman -S dkms git base-devel --needed


Then you can install the driver

git clone https://aur.archlinux.org/rtw88-dkms-git.git
cd rtw88-dkms-git
makepkg -si

here’s the result of inxi -n…

This worked for me. Thank you so much. I have been searching for a solution to this problem for a long time :slight_smile:

1 Like

This solution didn’t worked for me. I have laptop Asus X412F. I am using GNOME MANJARO dual booted with WINDOWS 10 HOME. I am having the same problem. I guess the person starting this thread have laptop with similar configuration. I need to restart my laptop for several times and for wifi to work.

following is the output of inxi -Fazy
Kernel: 5.10.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
root=UUID=b461a617-e282-4829-bafc-c6bcb48e1909 ro quiet splash apparmor=1
security=apparmor udev.log_priority=3
Desktop: GNOME 3.38.3 tk: GTK 3.24.26 wm: gnome-shell dm: GDM
Distro: Manjaro Linux
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X412FJ_X412FJ
v: 1.0 serial:
Mobo: ASUSTeK model: X412FJ v: 1.0 serial:
UEFI: American Megatrends v: X412FJ.302 date: 03/27/2019
ID-1: BAT0 charge: 15.9 Wh condition: 31.6/37.1 Wh (85%) volts: 7.8/7.8
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging
cycles: 336
Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP
arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: B (11)
microcode: DE L2 cache: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 28808
Speed: 1000 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 1000 2: 1000
3: 1000 4: 1000 5: 1001 6: 1000 7: 1000 8: 1000
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3ea0 class ID: 0300
Device-2: NVIDIA GP108M [GeForce MX230] vendor: ASUSTeK driver: nouveau
v: kernel bus ID: 02:00.0 chip ID: 10de:1d11 class ID: 0302
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus ID: 1-5:3 chip ID: 13d3:56dc class ID: 0e02 serial:
Display: wayland server: X.org 1.20.10 compositor: gnome-shell driver:
loaded: nouveau note: n/a (using device driver) - try sudo/root
display ID: 0 resolution: <missing: xdpyinfo>
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.3.4
direct render: Yes
Device-1: Intel Cannon Point-LP High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
bus ID: 00:1f.3 chip ID: 8086:9dc8 class ID: 0403
Sound Server: ALSA v: k5.10.18-1-MANJARO
Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: rtw_8822be
v: N/A modules: rtw88_8822be port: 4000 bus ID: 04:00.0 chip ID: 10ec:b822
class ID: 0280
IF: wlo1 state: down mac:
IF-ID-1: enp0s20f0u2 state: unknown speed: N/A duplex: N/A mac:
Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus ID: 1-8:4 chip ID: 13d3:3526 class ID: e001 serial:
Message: Required tool hciconfig not installed. Check --recommends
Local Storage: total: 476.94 GiB used: 37.51 GiB (7.9%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8
size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 rotation: SSD serial: rev: 002C temp: 29.9 C scheme: GPT
ID-1: / raw size: 199.74 GiB size: 195.6 GiB (97.93%)
used: 37.49 GiB (19.2%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%)
used: 25.2 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Alert: No Swap data was found.
System Temperatures: cpu: 46.0 C mobo: N/A gpu: nouveau temp: 40.0 C
Fan Speeds (RPM): cpu: 1900
Processes: 253 Uptime: 6m wakeups: 9 Memory: 7.63 GiB used: 1.74 GiB (22.8%)
Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 1341 pacman: 1332
lib: 390 flatpak: 0 snap: 9 Shell: Zsh v: 5.8 running in: gnome-terminal
inxi: 3.3.01

following is the output of inxi -N
Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
driver: rtw_8822be

please help me with this issue.