RTL8192EE keeps stopping working

My Internet keeps getting cut off,
I can still see other Wi-Fi networks, signal supposedly is strong, but I get a question mark over the Wi-Fi symbol, and no pages seem to load.
If that ever happened on Windows, I used to just run the troubleshooter which reset the driver and things worked again; here I am lost, I pressed F1 which i hoped would guide me through troubleshooting but I had no luck, so I thought maybe re-installing the driver would help?

Continuing the discussion from RTL8192EE (Realtek RTL8192EE PCIe Wireless Network Adapter):

I tried to go on GitHub & attempted following the instructions, but I have honestly no idea what the important bits mean.

  1. I have the Linux Kernel 5.15.81-1, what header does this mean I’m supposed to have installed? because there are over 18 sub-variants of Linux515 on pamac.
  2. How am I supposed to run/download those files if not through the big green button saying “Code>” ?
  3. Under “Compiling”, it says to run make all in terminal, but that just gives me
    make: *** No rule to make target 'all'. Stop.
    I am sure I am making a silly mistake, (am I supposed to paste the GitHub page’s link after make?) but I am also afraid I might brake things beyond a point of non-return if I carry on poking in the dark.

Just my .02 cents but why not go to settings panel and click on Manjaro Settings Manager and dbl click on Kernel and install the 6.0 kernel.
Couldn’t hurt.

1 Like

My understanding was that kernels which are not LTS tend to be more unstable & could break more easily; I assume you nonetheless think it’s worth a try, so sure, I’ll give it a go :smile:
6.0.5_rt14-2 (tagged Real-Time)?

I assume you didn’t mean 6.1.0rc7-1 :sweat_smile:

I only see one - linux515-headers.

Generally, if you want or need to compile stuff,
you need certain programs to do it.
To get all of those you install all the programs in the package group “base-devel”
sudo pacman -S base-devel

I do not know - you are not supposed to use the zip file but I don’t know how to get the archive by other means. :man_shrugging:

It’s a bit odd, seems like a trade secret.
If you are on github, you are expected to just know certain things.

search for git checkout or something like that …

You somehow download.
You then change into the directory where to you unpacked whatever you downloaded.
From there you issue your “make” command

If you do:
in that directory
you see, among others, a file named “Makefile”
If you don’t see that, you are in the wrong place.

1 Like

Sidenote: Why is this thread tagged nvidia when it is not related to it, someone re-tag to networking or similar :wink:

1 Like



1 Like

Someone suggested deleting manjaro-firmware and so I did.
In the moment it didn’t seem to do much, but after a reboot, the connection seems to be more stable.

I will keep the thread updated, but if no further replies appear, assume I indeed have no issues anymore.


It seemed to be fine for a while but then it randomly started not-working again.
Weirdly enough, I have a USB network adapter that’s really bad but I keep for emergencies; When connecting to my Hot-Spot, Realtek RTL8192EE does not work. but when connecting through the USB it does (which I expected to be fine), but when I tried to connect to the Wi-Fi with the USB, it didn’t work, in a similar way which RTL8192EE doesn’t work. ping: google.com: Temporary failure in name resolution

Anyway, I searched on Reddit and apparently RTL8192EE is known to be a big problem on Windows and it’s worse on Linux, so they suggest just getting another card altogether.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.