RStudio failed to invoke pdf viewer

Hi Manjaro community,

I found an issue with rstudio-desktop-bin installed by pacman. When I tried to open a pdf file in RStudio by double click it, no pdf viewer was invoked. I installed rstudio-desktop-bin 1.2.5042-1 on latest Manjaro xfce. I changed the options in Options-Sweave-PDF Preview, but they didn't work. The default pdf viewer was pre-installed qpdfview.

Do anyone has idea on this issue? Thanks.

Hi,
It works for me... I am on manjaro i3 and my pdf viewer is evince.
Did you check you preferred application setting? There is a setting for this in xfce. You can also right click any pdf and set the default application to open this type of file.
Maybe qpdf and Rstudio don't play well togeteher...

1 Like

I confirm it doesn't work for me either, with okular or qpdfview. The built-in viewer works for previewing files compiled by Sweave, but not for opening other pdfs. Only evince (which seems to be the recommended viewer) works for both . Perhaps a bug?

1 Like

Thanks for your hint. Evince seems to be compatible with rstudio-desktop-bin. Strangely, qpdfview used to work together with the old rstudio-desktop-bin. Latest update breaks the compatibility. BTW, can one suggest the developers/maintainers of Manjaro repository fix the minor issues to make it work with many other pdf viewers?

I guess this is more about letting the developers of these concerned packages know. Maintaining the Manjaro repo has no power on this IMO.
Was the built from aur fine? any warning, error?
Can it be a optional dependency missing? You wrote that it used to work, hope you will get some hints in the aur discussion.

I installed it from pacman and the installation was just fine. I installed it long ago, and keep it updated all the time. It seemed it's initially stored in AUR and transferred to manjaro repository. How do I contact the developer?

If it is a regression bug in RStudio, perhaps reporting it here would be the way? https://github.com/rstudio/rstudio/issues

You could also try to install one of the more recent development builds available in AUR, like rstudio-desktop-preview-bin or rstudio-desktop-daily-bin, to see if the problem is still there.

1 Like

Nope. You installed from AUR, it is not in Manjaro repository.

So pacman can access AUR, I didn't know that.

pacman can't but you most likely enabled the AUR in pamac GUI

sudo pacman -S rstudio-desktop-bin
error: target not found: rstudio-desktop-bin
 yay -S rstudio-desktop-bin
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  rstudio-desktop-bin-1.2.5042-1

  1 rstudio-desktop-bin                      (Installed) (Build Files Exist)

Alright. But why is pacman modified to be able to access AUR? This may cause confusion. I hardly remember I changed the setting of pacman in relation to AUR.

Thanks. Did you confirm this bug was originated in the official rstudio package? Some bugs were reported for rstudio-desktop-preview-bin. Maybe I'll try the next version.

pacman is not modified. pamac give the option, it is a different thing.
In pamac, this is disabled by default. Using Aur package is the user's choice and pamac try to make it convenient. There is a warning about this when you decide to activate and I can't tell you more than you should read a bit about that.
Rstudio is not in the official repositories of all Linux distro I use/used, as far as I know. For Debian-based, Fedora you have to download an installer or build it yourself. On Arch-based, you can use Aur or build it yourself.

This is most likely where your problem can be addressed...

You can also start the application from the terminal and try to get the output when you try to open a pdf.

Hi, Julien, I checked it just now. Did you mean the 'enable AUR support' checkbox in the pamac GUI? It was disabled as default, but I was able to install rstudio-desktop-bin with pacman. I'm on Manjaro XFCE 20.0.1.

sudo pacman -Syu rstudio-desktop-bin
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlinuxcn is up to date
warning: rstudio-desktop-bin-1.2.5042-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) rstudio-desktop-bin-1.2.5042-1

Total Installed Size:  581.54 MiB
Net Upgrade Size:        0.00 MiB

:: Proceed with installation? [Y/n] n

What is archlinuxcn? This is where you got the Aur package and I doubt you did not change something here...

Here is the output for me

sudo pacman -Syu rstudio-desktop-bin
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
error: target not found: rstudio-desktop-bin

Did you add it yourself? Do you really need this repo?

Anyway, it won't solve your problem. Building from Aur result in the same problem that okular is not used by rstudio.

Thanks. I was just curious even though it won't fix the issue. Indeed someone added archlinuxcn repo for me long ago. Also I reported the bug at GitHub, waiting to see how it ends up.

2 Likes

Forum kindly sponsored by