Rock 3A not booting from SD card

I have a problem updating my Rock 3a.
I start with a fresh installation from “Manjaro-ARM-minimal-rock3a-22.12” and after updating with “pacman -Syu” I get following warning (after the new kernel installs):
WARNING: Possibly missing firmware for module: rockchipdrm

After rebooting, the board doesn’t start up and I get dropped to an emergency shell, where I can’t do anything.

Here’s the full minicom capture from the process:
[ARM Stable Update 2023-01-24] starting from Manjaro-ARM-minimal-rock3a-22.12 (

I also tried installing linux-firmware after “pacman -Syu” (before rebooting) but got the same result. This also happened before with kernel 6.0 (back in December 2022) every time I tried switching to linux-rc 6.1.

I can’t replicate this on linux 6.1 and linux-rc 6.2. I get the same warning about missing firmware for rockchipdrm. My guess is that it’s only needed for non-HDMI displays.

You using SD or eMMC?

Sorry, I forgot to say…I use a microSD from SanDisk. I’ve tried 3 with the same result (Ultra and Extreme Pro).
The next release will come in February, right?

Thanks. This seems to be related to high speed sd cards. I’m gonna test out a patch.

Thanks for reporting.

@elpatax I did some tests. First I tried the default kernel, like the one you had. Works on eMMC (which is usually where there are issues) which worked. But after your report I tried it on an SD card. Did not boot, just like in your case.

So I tried a kernel fix, which works for me, so I have uploaded that to all branches.

Try doing your test again, making sure the updated kernel is linux-6.1.8-2. 6.1.7 would have the issue.

If it works for you too, I will submit the fix upstream.

EDIT: Submitted upstream, as it’s a fix that has been done for other rockchip devices in the past, so it makes sense that the Rock 3A also needs it.

Awesome! That was quick, thanks.
I can confirm the patch in linux-6.1.8-2 works for the rock 3a with an SD (minimal release).

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.