Restore windows bootloader

I have installed Manjaro recently. I did a mistake during installation. I reset /boot/efi fat32 data.
I had windows bootloader before that moment. But now I have only Manjaro bootloader.
How can I restore the windows bootloader?

I tried to find the solution on the internet and found some variants:

  1. download ubuntu live cd and use ubuntu utilities
  2. use lilo utility. I found this utility in AUR, but I can’t install it. I get errors during building this package.
  3. use syslinux utility. I have installed it. But command

sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sda

Returns me an error:

dd: failed to open ‘/usr/lib/syslinux/mbr.bin’: No such file or directory
There is no mbr package in AUR and official repositories.

I don’t want to download ubuntu, so, can I restore the windows bootloader from Manjaro? How?
Thanks in advance!

lilo is a boot loader, but it only works for legacy BIOS boot, not for UEFI boot.

See if this helps… :arrow_down:

As far as I understand, this post about restoring the Manjaro boot menu where you can select the Linux version to boot from. I have used commands from the answer to that post. No errors occurred. I have rebooted my PC, but nothing has changed. No boot menu yet.
Even if I restore the Manjaro boot menu I need to restore the Windows boot loader because now I can’t boot Windows even if I try to change the boot priority in BIOS because I have only one boot entry - Manjaro. I had 2 boot entries before I reinstalled Manjaro.

If you don’t see the boot menu, then edit /etc/default/grub and change the line… :arrow_down:


… into… :arrow_down:


Then, run… :arrow_down:

sudo update-grub

The boot menu should now be visible.

Yeah, that helped, now the Manjaro boot menu is visible when the computer starts. But there is no Windows Boot Manager list entry like before. I still need to restore the Windows boot loader.

From what I understand, the only way to restore windows boot loader is from windows recovery disc. Even if you restore the data from data recovery software, usually there are some small changes that makes the boot loader corrupt.
There may be packages that have some small chance of fixing it but fixing proprietary software can be done only by the same proprietary software. Linux can only recover previously existing sectors but not create new ones, which, as already said, is a very unreliable process.

Your best bet is to use windows recovery options.

I tried it. I used bcdedit command and it executed successfully, but bootloader haven’t fixed. There are still no boot Windows in BIOS boot priority tab. Why? I tried to format and write bootloader files to NTFS volume(500 MB) and FAT32 volume(100 MB), none worked.

As I already said, I have formatted FAT32 volume accidentally which contained /boot/efi data. Now I can’t boot Manjaro too :smile:

First I formatted FAT32 volume, after I checked that bootloader didn’t fixed I formatted NTFS volume because I saw on the internet that this volume I should format if I system had installed in BIOS and MBR, or FAT32 if system had installed on GPT disk.

I used command:
bcdboot E:\Windows /s D: /f ALL
It returned success message, but problem doesn’t solved.

If I understand correctly, you deleted the EFI partition.
But even if you still have the EFI partition, given the numerous attempts you have made on that partition, I think you should delete it and recreate it with the procedure that I post to you later.

Ok, one year ago I helped a friend to restore it and copy the Windows EFI files.
We followed several guides on the Internet, but the only one worked was
:fast_forward: this guide.

You must have an Win install disk (or usb).
If you see the Microsoft Reserved Partition (usually 128 MB) you should delete it and then recreate it follow the guide.
This partiton is not strictly needed, but Win10 (and some applications) uses it to perform some recovery actions, so I recommend it.

After that, you will be able to restore the grub too.

Please pay attention to follow the tutorial carefully and don’t delete/touch your manjaro or data partitions.
Make a backup of your Manjaro partition(s).
Good luck! :four_leaf_clover:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.