Replacing older nvidia with new

I also have a gtx 960 could you tell me what kernel and Nvidia driver you used as I can’t boot after latest update?


Just checked the nvidia Website and it says your card is still supported by the latest drivers. I have the 970m and that works fine with latest Nvidia. I’d hazard a guess something hasn’t updated properly

1 Like

Not OP - but I have gtx970 which is same generation. Kernel 5.10.7-3, and driver is video-nvidia, both installed from Manjaro settings.

If you want to install nvidia driver from the terminal you should probably do something like:

  • mhwd -li (see what drivers are installed)
  • sudo mhwd -r pci xxxxxxxxx (uninstall your drivers)
  • sudo mhwd -a pci nonfree 0300 (install nvidia drivers)

Thanks but I can’t boot at all
I get a failed to load kernel modules error

Then failed to start light display manager

I dropped to tty f3 and did mhwd -li

It says
Video-Linux version 2018 05 04 freedriver true type PCI

I’ve been trying to fix this for ages but I’m a noob to this so totally confused

Warning no installed usb configs

This happened after the last big update

The 5.4.89 kernel with Nvidia drivers had been working

I tried other guides i found on here but I think I’ve made a mess of it!

Thanks yes it happened after the last big update I did in Pacman & kernel 5.4.89 & Nvidia drivers had been working fine then no boot
Failed to load kernel modules
Failed to load light display manager

Can you use a live usb and then chroot into your system? You can then use the method above to update your drivers

Tried this

sudo mhwd -a pci nonfree 0300 (install nvidia drivers)

It says Nvidia-utils & Nvidia 430xx are in conflict nvidia-libgl
Revive nvidia-430xx error unresolvable conflicts detected
Error failed to prepare transaction conflicting dependencies

Yes I’ll have a go

It’s not showing nvidia installed but there’s a conflict between 430xx & Nvidia utils ?

You’ll need to uninstall the 430 drivers first and then install the latest drivers.

1 Like

Won’t let me says 430xx & nvidia-utils in conflict?
How do you remove them?

Not showing any nvidia drivers installed but the utils are in conflict when I try to remove as breaks dependent with my 4.19 kernel also installed

I had been running the 5.4.89 with Nvidia before update which worked fine seems to be something to do with the Manjaro update changing nvidia utils?

run this command

$ pacman -Qq | grep -e 'nvidia'

uninstall the packages not labeled mhwd

Then - if your graphics card supports the latest driver you install it

$ sudo mhwd -i pci video-nvidia

And if your card don’t you install the opensource drivers

$ sudo mhwd -i pci video-linux
1 Like

I am determined to learn Linux better. It took me the longest time to figure this out, but this:

Can be done with one line:

$ sudo pacman -R $(pacman -Qq | grep -i 'nvidia' | grep -v mhwd)

No, I don’t recommend it! Nor have I done it and don’t laugh.

I’m rather proud of myself!

(Except if I’m wrong, but then I’m humbled and stand to be corrected, while still proud to have gotten this far.)

1 Like


All I have that’s not mhwd is


I tried
sudo mhwd -r pci nvidia-430xx-utils

It returned
Error config nvidia-430xx-utils is not installed

I’m new to this so please bear with me!

sudo pacman -R nvidia-430xx-utils

Then install the drivers using mhwd

sudo mhwd -i pci video-nvidia

Hi @x9x,

Don’t worry we’ve all been there. Try,

$ sudo mhwd -i pci nonfree 0300

(If I remember correctly.)

I’m not at my PC the rest of the night. (Almost bed time here.) But i’ll check in again tomorrow and help is and where I can.

1 Like

Tried that

Thanks for replying

Yes it’s infuriating

I was loving Manjaro upto now

That’s great cheers mate!

Thank you I’m so grateful it worked !

I never thought I’d see this install again

I even installed Debian thinking I wasn’t upto keeping up with Manjaro updates etc

As I installed Debian on the same SSD now I’ve lost my Manjaro grub menu I can only access it through my hackintosh on another disk thru the Clover bootloader is there a way to get it back?

I did update-grub but still boots to Debian grub maybe as it’s before my 2 Manjaro installed on the disk?


And won’t boot from Debian grub either