Dropping all legacy and older Nvidia drivers ?!?

Maybe I’m misunderstanding your point, but the GTX 1070 is supported by the latest NVIDIA driver.

As I had been using the 340.xx drivers, I bit the bullet and switched to Nouveau. I am quite pleased with the result. No issues! The video display is just as snappy as before. Note, I only use office type apps. I am not a gamer and have no need for 3D acceleration, so Nouveau is a good solution for me.

1 Like

While I understand that progress results in causalities I was unprepared for the total graphics failure of my venerable server. Being a server it can still partially function but several important tasks remain undone.
Because graphics UI use (vice terminal emulation) is slight this is not a show stopper.
It has run successfully since 2016 using a GeForce 210. When I switched to nouveau per the unwelcome announcements is when the problem started, apparently a mhwd bug (report was to be submitted).
Several years ago I switched from archlinux to manjaro to ease the maintenance but this may have been an error for the server. I have three other manjaro systems that survived the NVIDIA debacle. My main workstation runs archlinux and several other operating systems on a not yet unsupported NVIDIA graphic adapter.
A little help to revive the graphics until hardware can be replaced (on order) would be greatly appreciated, details posted Jan 19 at (Fails to run graphics after latest update (19·01·2021) on Geforce 210)
Pardon the whiny mood of this post, I am used to better outcomes with manjaro.


User wntr provided very useful suggestions on how to rid the system of NVIDIA :blush:
and with a few extra steps I now have recovered graphics, details at (Fails to run graphics after latest update (19·01·2021) on Geforce 210)

PC with Manjaro 20.1 installed
I was using the 340xx drivers so switched to nouveau but am having issues with frequent screen freezes so I followed the instructions above and re-built the 340xx drivers manually.
So far no more screen freezes.
I am using kernels 5.4 and 5.10.


I’m now using Manjaro Nibia 20.2.1
My graphics card is GT215 ( with GeForce GT 240 gpu)

Thanks for the info. Yesterday night I updated to kernel 5.10 and compiled nvida 340xx from the AUR.
So far so good. I have couple of errors, but I haven’t seen any down side, for now.

The only thing that annoys me is that I cannot find nvidia-drm. I thought if I switch from k.5.4 to 5.10 and recompile the drivers for k.5.10 that the nvidia-drm module will magically appear :slight_smile:

Hello @lappetspm, do have nvidia-drm module ?? :slight_smile:

Keep us posted. I am successfully running Nouveau. It fits my office needs perfectly. Back in the day when I ordered a laptop with the 8400GS card, 3D graphics was no concern at all. The state of embedded graphics was poor back then so a dedicated video card.

12 posts were split to a new topic: Replacing older nvidia with new

4 posts were merged into an existing topic: Replacing older nvidia with new

3 posts were merged into an existing topic: Replacing older nvidia with new

Well I built new ryzen 5800x system ~ Xmas w / a 10+ yr old nvid card. Both Manjaro and Debian LX’s froze non stop. tried all fixes and ran across where I too couldn’t get compatible NVID drivers. Nor std Lin drvrs worked either. Researched for modern GPU, bought a Nvid 1650 based bd, loaded modern nvid lin drvrs and no more freezes in Arch or Debian based OS’s. So my case I had to upgrade to run Lx anyway since my Nvid card was a dinosaur.

It feels like nbidia is trying to force you to buy a new gpu or laptop or switch to windows(which is still shit).

I just let them keep trying :smiley:
Here, I have an old GeForce GTX 550 Ti card happily running with the nVidia driver 390 on Linux kernel 5.12 rc3 - courtesy of https://forum.manjaro.org/u/schinfo :+1:

1 Like

Honestly I have no idea what’s going on.
The latest Manjaro update broke my system completely so I swapped to another disk (with an older version) updated that and it also broke. THREE complete live-usb installs later, I have managed to get everything working. I had to install the Kernels manually, install the Nvidia drivers manually, and now it’s all working except XFCE-Panel gives errors, keeps moving itself around the screen (currently at the top!), and right click, Panel Preferences, just flashes, crashes it and it reloads. I can’t even set Firefox to stop grouping, because the panel just crashes.
I’m out of ideas and I’m wondering if it’s due to these latest proprietry nvidia drivers. Yet without them installed I had to do startx at tty2 manually each time I booted.
Honestly thinking of just going to Ubuntu now.

Edit: Even Deluge doesn’t work

[john@john-pc ~]$ deluge

(deluge:4535): dbind-WARNING **: 17:40:22.199: Couldn’t register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(deluge:4535): GLib-GIO-ERROR **: 17:40:22.965: Settings schema ‘org.x.apps.favorites’ is not installed
Trace/breakpoint trap (core dumped)
[john@john-pc ~]$

edit3: I finally fixed it, it seems huge updates (1000+) are a no no and I needed to grab the latest ISO from the site to successfully get to the latest kernel and nvidia drivers.
I’m not sure why Firefox was so sluggish before because it’s great again now.
I think I will switch to a LTS version and update every few years.

It would be interesting to know what exactly “broke”. For the older Nvidia drivers, there is a bug in the linux***-nvidia-***xx packages that messes up some of the extended driver features, such as OpenGL.
The packages create a file /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf with a missing entry to extend the X modules path.
This file has to include the following line

ModulePath "/usr/lib/nvidia/xorg"

as otherwise, there will be a lot of errors that might also explain the behavior observed by you.
The complete contents of the file /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf has to be as follows:

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "PrimaryGPU" "yes"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"

As I said above, at first you will have to fix the Nvidia driver configuration. For the XFCE related errors, it makes sense to delete some folders:

rm -rf $HOME/.cache/xfce4
rm -rf $HOME/.config/xfce*

After that, reboot and check for errors in at least the following places:

journalctl --no-hostname -b -p3

After taking care of all errors found there, it is time to check firefox. A good starting point might be an empty profile.

@DAC324 Did you read latest update #announcements for your branch before updating?

1 Like

4 posts were split to a new topic: After kernel 5.10 my home PC with Quadro 600 have stopped to work