Remote Desktop Server: Best choice from official repo or AUR on Raspberry Pi 4 (4 GB RAM)?

Upfront Note: I intend to run X11 forwarding eventually, but the software I need for my Mac is in alpha stage right now.

I’d like to set up a Remote Desktop server for my 4GB Raspberry Pi 4B, running the latest Manjaro ARM.

I don’t need it to be terribly fancy: I just want to be able to use some GUI config tools without having to turn on the TV my Pi is hooked up to.

It looks like my choices in AUR are AnyDesk and TeamViewer? Any thoughts?

NoMachine is in the AUR. Works with Windows, Mac and Linux.

1 Like


For the desktop sharing I use krfb
For the desktop control I use krdc
Both simple to use.

No problems with the linux computers remote with ultra vnc viewer (windows)


I’ve been using Realvnc server and viewer from aur, works flawlessly between Linux/Linux and Linux/Windows. In fact this is the only solution I’ve managed to get working reliably.

Thanks for the replies, everyone. Re: nomachine, I’m not really sure where to start with installing that.

~]$ pamac search nomachine
opennx AUR
A GPL replacement for the NoMachine client
nx-common 3.5.0-8 AUR
NoMachine NX common package for client and server
nx3-all 3.5.0-4 AUR
NoMachine nxclient, nxnode, and nxserver in one package (version 3.x which includes virtual desktop support)
nomachine-enterprise-client 7.0.211-4 AUR
Remote desktop application
nomachine 7.0.211-1 AUR
Remote desktop application

I’d assume I want the latest version of the server, which would just be nomachine (version 7). Is there some reason I should use version 3 instead?

@CGA I’ve used RealVNC before on Raspian and liked it a lot. Like you said, it’s extremely reliable. Nomachine is supposed to be technologically superior and perform a bit better, but I have issues with it’ll be headed back to RealVNC. I didn’t realize it was in the AUR. Thanks for letting me know. :slight_smile:

I believe the NX 3 version is from the days before it became the commercial entity NoMachine. It is rather old, I think the newer version will be more to your liking. It is not difficult software but can be a bit overwhelming since there are so many options. You will just have to mess around with it to figure out what you prefer. Screen size/resolution, sound, printing, session status on disconnect, all kinds of options. All settings are configured with the software, so no hand editing of config files. You will get both the nxclient and nxserver on the install. If I recall properly, nxnode is not something you will need to interact with. It has the ability to have a proxy server to a host of backend machines (nxnodes) for large site installs.

1 Like

Thanks for the info. I got the sever running last night. It was completely painless. I think it helps that this isn’t a headless install anymore.

I’m going to get the client going today. I’ll let you know how it goes. :slight_smile:

It’s up and running. Thanks again for your help.

It’s perfectly usable, but a bit choppier than I expected it to be.

What settings are you using? I’m sure I need to optimize it somewhat, but so far the only instructions I’ve found are outdated.


Choppy? I have not yet used it on my RPi4 but I would not expect it to be choppy. It performs very well on x86, even across slow internet connections. In fact, it is known for how well it performs with less than ideal connectivity. But maybe the same code on a RPi4 is not so good. I’ll see about testing it on my RPi4 sometime this weekend.

1 Like

I installed nomachine on my RPi4 and connected to a remote server across my less than great internet connection, works great. Seems to run equally as well as on x86. However, the remote desktop does not use a compositing desktop (openbox), so that could be a difference.

Yes. After a bit of experimentation, it’s clear my user’s XFCE settings are screwed up somehow.

I had to log into the root user’s GUI to set up system-level backups, and it both looks entirely different and is much more responsive. (It’s not just that compositing is not enabled for the root user, either. The entire UI is arranged differently.

I wonder if there’s a way I can completely reset XFCE for a specific user…

As they say, where there is a will, there is a way.

As root/sudo:

cd /home
mv {user} {user}.bak
mkdir {user}
rsync /etc/skel/ /home/{user}/
chown -R {user}:{user} ./{user}

This will reset the user’s home to the state of a newly created user.

Then when logged in as the {user}, move/copy the files you wish to keep from /home/{user}.bak/ to /home/{user}/
This step can get complicated.

Alternately, you can delete all of the xfce related files and directories in:


This can be complicated too.

  • Note: The user must be logged out before performing these steps. Do not perform these for your own account while logged in. Login as root or use sudo while logged into another account.

Thanks. This was exactly what I needed. I just deleted the XFCE config stuff. I didn’t want to have to recreate my entire user at 930pm on a Saturday night.

My user’s XFCE now looks exactly like root’s. I’m curious when the default changed so much. Even before I activated the compositor, it wasn’t so simple and clean. I’m really liking it, though I’m going to need to go back through the XFCE settings tomorrow…

For LAN connections I use VNC, as others have stated it’s a great, cross-platform solution to remote into your desktop. In case it matters, I am using XFCE for Arm.

For internet remote connection, I use a service that is hardly known but should be promoted more often. The service is called DWService (

Download the Linux client, make the file executable. Then shift to command line and navigate to where you saved the file, and issue:

sudo ./

Walk through the installer and select the option to activate the client on an existing account. It will provide to you 9 digits to connect to your account that you can setup on their website.

Also, you can use 2FA on the account as well for added security. DWService is free to use, as far as I know there are no limits to the number of clients you can have on your account. The author simply asks for donations to help support the project, which we should do.

If you need help please ask, happy to do so.

I tried to use pamac to update nomachine today, and something went spectacularly wrong. I ended up losing the X Server entirely. Even the direct HDMI connection to my TV stopped working.

I’m trying to reinstall nomachine with pamac now. It threw an error when I info’d the package. I have no idea what this means.

Any thoughts?

~]$ pamac info nomachine
Name                  : nomachine
Version               : 7.1.3-1
Description           : Remote desktop application
URL                   :
Licenses              : custom:"NoMachine EULA"
Repository            : AUR

** (pamac:1872): CRITICAL **: 14:22:49.043: pamac_aur_package_linked_populate_array: assertion '*array != NULL' failed**
Depends On            : bash openssh nawk
Optional Dependencies : xorg-xauth [Installed]
Conflicts With        : nxmanager nxwebplayer nxserver nxnode nxclient
Maintainer            : runnytu
First Submitted       : 07/24/2014
Last Modified         : 02/06/2021
Votes                 : 77

What does pacman do?

$ pacman -Qi nomachine

Name            : nomachine
Version         : 7.0.211-1
Description     : Remote desktop application
Architecture    : aarch64
URL             :
Licenses        : custom:"NoMachine EULA"
Groups          : network
Provides        : None
Depends On      : bash  openssh  nawk
Optional Deps   : xorg-xauth: allows logging into a headless machine [installed]
Required By     : None
Optional For    : None
Conflicts With  : nxmanager  nxwebplayer  nxserver  nxnode  nxclient
Replaces        : None
Installed Size  : 42.84 MiB
Packager        : Unknown Packager
Build Date      : Sat 23 Jan 2021 12:34:21 PM CST
Install Date    : Sat 23 Jan 2021 12:38:16 PM CST
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : None

I have not attempted to perform the upgrade.

~]$ pacman -Qi nomachine
error: package 'nomachine' was not found

It’s an AUR package. How are you getting it to show up in pacman?

I believe pacman recognizes all packages that are installed, I can query all of the AUR packages I have installed. But it does not update them, for that, I use the pamac-manager.


I uninstalled the package, as I believed I may have damaged it when I tried to update it. (It’s possible the Pi lost power during the build). So it’s not installed at all right now.

I just get that ominous message from pamac when I try to install it.

Is pamac-manager the same thing as pamac?

pamac-manager is the GUI interface to the pamac CLI.

I am not sure about your error message. It could just be a pamac bug, or possibly something wrong with the info data pamac is reading. But good that pacman is not throwing an error too.