Realtek Wifi not working rtw_8822ce

I have ASUS FX505DT and after new update my wifi driver seems to be not working.

This output comes sometimes when wifi driver is working after few restarts:

❯ inxi -Nazy          
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: d000 
  bus-ID: 04:00.0 chip-ID: 10ec:c822 class-ID: 0280

otherwise this comes:

❯ inxi -Nazy          
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
System:    Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 root=UUID=3ce01a3b-83f7-4801-8527-2e7c9847b9fb rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <filter> UEFI: American Megatrends v: FX505DT.316 date: 01/28/2021 
Battery:   ID-1: BAT0 charge: 12.9 Wh (33.4%) condition: 38.6/48.1 Wh (80.2%) volts: 12.2 min: 11.7 model: FX50442 
           type: Li-ion serial: N/A status: Charging 
CPU:       Info: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen/Zen+ 
           note: check family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102 cache: L2: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33552 
           Speed: 1373 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1373 2: 1560 3: 1349 4: 1330 5: 1265 
           6: 1227 7: 1671 8: 1476 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 460.73.01 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f91 class-ID: 0300 
           Device-2: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 04:00.0 
           chip-ID: 1002:15d8 class-ID: 0300 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-1:2 chip-ID: 13d3:56a2 
           class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati,nvidia 
           unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 5.12.1-2-MANJARO LLVM 11.1.0) v: 4.6 Mesa 21.0.3 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.26 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000 
           bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0 state: down mac: <filter> 
           IF-ID-1: enp4s0f3u2 state: unknown speed: N/A duplex: N/A mac: <filter> 
Bluetooth: Device-1: OPPO SDM710-MTP _SN:76C74055 type: USB driver: rndis_host v: kernel bus-ID: 1-2:5 chip-ID: 22d9:276a 
           class-ID: 0a00 serial: <filter> 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
           Device-2: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 13d3:3548 
           class-ID: e001 serial: <filter> 
           Report: ID: hci0 rfk-id: 0 state: up address: N/A 
Drives:    Local Storage: total: 476.94 GiB used: 60.34 GiB (12.7%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200V MTFDHBA512TCK size: 476.94 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: P1MA0V4 scheme: GPT 
Partition: ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 60.34 GiB (12.9%) fs: ext4 dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 57.4 C mobo: 57.0 C gpu: amdgpu temp: 57.0 C 
           Fan Speeds (RPM): cpu: 2700 
Info:      Processes: 263 Uptime: 3m wakeups: 1 Memory: 7.28 GiB used: 1.53 GiB (21.0%) Init: systemd v: 247 tool: systemctl 
           Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1315 pacman: 1312 lib: 363 flatpak: 0 snap: 3 Shell: Zsh v: 5.8 
           running-in: yakuake inxi: 3.3.04 

Hi @garvitjoshi9 ,
Could you post the output of the following terminal command, in order to see what is happening:
```rfkill list all``

You could also read this post in order to find the solution:
NetworkManager: WiFi is delayed to reconnect after resume from standby (suspend to ram) - #6 by allexj

Hope this help, regards

1 Like

Sorry for the late reply,
I had to reinstall Manjaro, and now the problem is fixed …

➜  ~ rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

but i when i rran this when my wifi was not working it would give something like this

0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Hi @garvitjoshi9 ,
I am glad to see that the problem was solved, although you have installed Manjaro again.
Of course, when wifi it is not running the terminal command will not show the phy0 output.

Good job! :grinning:

1 Like

Thanks for the help! :grinning:

The same problem is happening now again.

As you seem to be on 5.12 stable: have you tried 5.10 LTS or 5.4 LTS already? (I would try them out in that order)

If you don’t know how to do that, shout out!


tried 5.10 still no progress

1 Like

Hi @garvitjoshi9 ,
Could you try to disable mac randomization and power save option, which is suggested by @D.Dave at the end of the post I mentioned above?

You could also run the following terminal command, in order to verify the drivers installed for the wifi card:
lsmod | grep rtw
I thing the output should be equal as in the above post.


1 Like
> lsmod | grep rtw
rtw88_8822ce           16384  0
rtw88_8822c           471040  1 rtw88_8822ce
rtw88_pci              28672  1 rtw88_8822ce
rtw88_core            217088  2 rtw88_pci,rtw88_8822c
mac80211             1167360  2 rtw88_pci,rtw88_core
cfg80211             1036288  2 rtw88_core,mac80211

The above output comes when my Wifi is Working Fine, when the wifi is not working it shows blank.

Hi @garvitjoshi9 ,
Then, follow my suggestion about disable mac randomization first. Then, if the problem is not solved try with the power saving option.

1 Like