Realtek TP link wn-722n

Hi, here my first post on new forum.
I have installed successfully the driver rtl8188eus from ( for a Tp link wn722n wifi adapter.

lsusb recognize the adapter the I’ve tried to use for connecting to internet but
sudo iw dev wlan1 scan
gives me
command failed: No such device (-19)

Some months ago I used successfully on the the same system and I remember there was some kind of gui appearing when the wifi adapter was connected and I could use it to connect to internet via the adapter, the I had to format the system and now I have no idea how to use it again. Hope somebody can help. Thanks a lot

iwconfig output where wlan0 is my internal wifi card and wlan1 is the adapter:

wlan0     IEEE 802.11  ESSID:"portobello"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:37:B7:0A:26:EE   
          Bit Rate=130 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=49/70  Signal level=-61 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2  Invalid misc:98   Missed beacon:0

wlan1     unassociated  ESSID:""  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

inxi -Fxxxza --no-host :

System:    Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=25cd00b7-5e78-4989-a540-b52f6235b902 rw quiet 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Latitude E5450 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 0MVKK7 v: A00 serial: <filter> UEFI: Dell v: A10 date: 09/01/2015 
Battery:   ID-1: BAT0 charge: 15.1 Wh condition: 27.9/51.7 Wh (54%) volts: 7.5/7.6 model: Samsung SDI DELL 1KY05D9 
           type: Li-poly serial: <filter> status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i7-5600U bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 3D (61) 
           stepping: 4 microcode: 2F L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20760 
           Speed: 1875 MHz min/max: 500/3200 MHz Core speeds (MHz): 1: 2594 2: 2596 3: 2594 4: 2594 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
           Device-2: NVIDIA GM108M [GeForce 840M] vendor: Dell driver: N/A alternate: nouveau bus ID: 03:00.0 
           chip ID: 10de:1341 
           Device-3: Sunplus Innovation type: USB driver: uvcvideo bus ID: 1-1.6:4 chip ID: 1bcf:2b8d 
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: intel alternate: fbdev,vesa display ID: :0.0 
           screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9") diag: 355mm (14") 
           OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:9ca0 
           Sound Server: ALSA v: k5.9.1-1-MANJARO 
Network:   Device-1: Intel Ethernet I218-LM vendor: Dell driver: e1000e v: kernel port: f080 bus ID: 00:19.0 
           chip ID: 8086:15a2 
           IF: eth0 state: down mac: <filter> 
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 chip ID: 8086:095a 
           IF: wlan0 state: up mac: <filter> 
           Device-3: TP-Link TL-WN722N v2/v3 [Realtek RTL8188EUS] type: USB driver: r8188eu bus ID: 2-2:2 chip ID: 2357:010c 
           serial: <filter> 
           IF: wlan1 state: down mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 196.27 GiB (82.3%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda vendor: Samsung model: SSD PM851 2.5 7mm 256GB size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 8D0Q scheme: GPT 
Partition: ID-1: / raw size: 238.18 GiB size: 233.44 GiB (98.01%) used: 196.27 GiB (84.1%) fs: ext4 dev: /dev/sda2 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: file size: 4.00 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 52.0 C mobo: 40.0 C sodimm: 39.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 212 Uptime: 34m Memory: 7.67 GiB used: 2.68 GiB (34.9%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           clang: 10.0.1 Packages: pacman: 1364 lib: 363 flatpak: 0 Shell: fish v: 3.1.2 running in: server inxi: 3.1.05 

For one you probably want to use the packages in the AUR as opposed to manually building.
For another … 5.9 is a pretty new kernel … unless you have a specific reason to chase it you might want something else … for example nvidia doesnt really work on 5.9.

Actually I change my kernel just because the system suggests me to do it, every time there is a new kernel, so I imagined it was a good choice to do so. I’ll stick to a older one something and check it again.

1 Like

I’ve changed kernel for 4.19
but still iw dev wlan1 scan gives me No such device.

Have you tried 5.4 LTS already?

So it seems everything is working now.
Yes I changed to kernel 5.4 but I think the problem wasthat I was not using the right command!
Thanks to some tutorial (I cant’ post link, why?)
I’ve found my way on connecting through my wifi adapter to a wpa protocol.
Thanks for your help, but I think the solution was not exactly just changing the kernel.

I post here for future references the commands I used for getting my connection works, assuming that I’ve installed the drivers on the best kernel I can use.

lsusb will tell if the wifi adapter is connected and recognized;

ifconfig will tell the name of device, it is wlan1 in my case;

sudo ip link set wlan1 up will bring the interface up;

sudo iwlist wlan1 scan will use the interface for available network;

in my case i’m connecting to a wpa protected connection, so I will need:
`wpa_passphrase ‘ESSID’ ‘password’ > wpa_supplicant.conf’ will crate a configuration file with ESSID name (it will be shown with the precedent command) and the password of the connection;

‘wpa_supplicant -i wlan1 -c wpa_supplicant.conf -D wext’ where -i is the interface name (wlan1 in this case), -c the file where I’ve saved connection name and password, -D is the driver I’m using (try wpa_supplicant for a complete list).

Last step: ‘sudo dhclient wlan1’ for obtaining an ip address.

Read this:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.