Razer Lancehead Tournament Edition mouse not working after updating

I updated my plasma version after a long time and now my mouse just, doesnt work.
i went through a lot of things and everything that i thought that i could do to fix. whats left is the main suspect which is the libinput as i found something in the debbugging and in USB viewer that is very likely the issue. that is the driver is not connected to the device (razer lancehead turnement edition mouse).


this is the image i got thought it doesnt have the error as i dont know how to recreate the log but it said something like this: mouse took longer than 22ms to respond. ??? event 9 ???
thats all i remember from that sorry

ty if anyone decides to help me <3

Are you using any of the razer packages?

pacman -Qs razer

If you were using one from the AUR you should rebuild it.
But please report if/what packages are in use.

Also … is everything up to date? Fully?

Do you have any skipped pacnews?

pacdiff -o

And of course theres always system info … like running kernel, etc.

here is the output of that command and im pretty sure these are the ones in used, i tried removing them, trying without them, reinstalling, trying with them reinstalled. Nothing

here is my neofetch too

and yes everything should be fully up to date. If you want i can go check again and send you a screenshot of your prefered way to check if its updated

‘reinstalling’ doesnt necessarilly rebuild … you may just be reinstalling from the cache.

But yes, those packages are all AUR.

I dont know what AUR helper you use … supposedly pamac will search for aur updates with the -a flag.

pamac update -a

But regardless of the package version itself … they may need to be rebuilt against currently installed libraries et al. So you may need to rebuild each package. Again I dont know your aur helper, but I assume passing build to pamac again would do the trick. Ex:

pamac build openrazer-meta

Its also worth noting you have at least one DKMS package.
Note that it may require special attention. One example would be if you dont have the headers for your kernel installed then the modules wont be rebuilt with kernel upgrades. See more here:
Dynamic Kernel Module Support - ArchWiki

It may be useful to also post the wiki link for the AUR here
Arch User Repository - Manjaro

I did not ask for neofetch … or screenshots, which are generally discouraged unless specifically required. Text is more search-friendly and helpful.
Please refer back to the following links if need be.
[HowTo] Request support
[HowTo] Provide System Information

i tried the things you sent and nothing worked, i sent my neofetch because its by far the most efficient way to do it. also the only thing i need i really to re attatch my driver to my mouse i just dont know how to do that. im asuming thats what i need at least.

No, it’s not.