Raspberry Pi 4 wont boot

I have tried flashing both of the images for the pi 4 to both hard drives and to sd cards but they all either boot then setup and then get stuck at reached bluetooth something and i cant get it to boot into desktop. i recently started using Manjaro on my laptop and really wanna get it on my pi.

The links where i got the images for the pi are:

There has been some posts here saying the same thing and I am not sure yet why as I have not had the issue. Most are saying to wait and it will finally go into the login screen. The ones that finally get to the desktop are saying if they do a sudo pacman -Syu and reboot the problem goes away. I would try to ssh to it if it does not go to the login screen and update with pacman -Syu and reboot to see if that helps.

I am beginning to believe we need to upload a new image with the latest program versions in it.

Yes. There’s neads a newer version of the image with the fix.

Don’t worry, this will take a long time, wait for 10 to 30 minutes to start.

This situation will only occur once, wait for about 30 minutes, it will boot normally, and this situation will not occur afterwards.

i will see if i can ssh in but i dont know

not possible because you cant login even if you used wired connection

I’ve got two serial cables, but I don’t know if it’s enabled by default.

honestly i dont know what a serial cable is but I suspect its either something to do with gpio or ethernet

@noxxtech If you have a Ras Pi 4Mb or 8Mb and it is standalone ( No Arduiono’s, Hats etc ).
Then KDE or Plasma will load eventually. The key here is a bit of patience.
It will probably hang at Bluetooth ( Wait for 10 to maybe 30 minutes).
Then when it reboots it MIGHT hang at Login Home or somewhere near there. ( but not always ).
Eventually you will get there.
I that does not work, I suggest you try to load Raspbian or Noobs from the Raspberry Pi Offical site just to check if your Ras Pi is working correctly.
But the key here is a little patience.
Hope this helps.

Everything else like twister rpi os and my friends apple pi os runs perfectly

As for hat no, but would the argon1 case cause problems?

Read this thread to get it working.

How to install ArgonOne

Hi @noxxtech.
Ok so not the HW then.
Have to tried re-installing and doing the waiting a while for things to finish. ??

Perhaps it is hardware, I just looked at @Darksky’s post.

Would I neccesarilly need to reinstall or could I just plug the ass with Monjaro back in and wait

Can you tell me where you are in the process?
Have you tried the things in the post that @Darksky pointed to?

I haven’t managed at all any boot

I will message you on discord hit me up


Update if I could get it to go back to the setup screen agian I would

Looking at the evidence so far, it looks like the fan is the cause of the problems.
I would be inclined to unplug the fan from the board and try to install Manjaro without it.
I have a Ras Pi 3 with no cooling at all, it’s in a cardboard case, It’s been on constantly for 3+ years so don’t worry about overheating.

If you can boot without the fan at least you will have a running system and then you can try with the fan again and see what the system tells you about the fan.

It’s an option for you to try but you don’t have to if you prefer not to.

Thinking back also there used to be an issue with ipv6 about a year ago. Try turning off ipv6 dhcp in you router if it is turned on and reboot your pi. My router is old and does not have ipv6 dhcp.

I can’t even connect to internet because it won’t boot