Raspberry Pi 4 Manjaro Sway boot problem after update

Greetings everyone. I decided to use raspberry pi 4 for my cyberdeck project. I wanted to install the bspwm+polybar (that I am used to on my desktop) to pi 4. Seeing that Manjaro already has an iso with sway, I thought I’d give sway a chance.

When I finish the initial setup and turn on the system, I encounter any problems. Moreover, when I reboot, there is no problem.

However, when I update the system via pamac or terminal, it asks me to reboot. When I restart, after the manjaro boot animation, a flashing underscore appears on the black screen, in the left corner of the screen, and the system does not boot.

What I’ve Tried

  • I tried using a different SD card but the result is same.
  • I tried using a different pi (I have 4 raspberry pi, I tried them all one by one).
  • I tried different power adapters and hdmi cables. I even removed all the power-hungry parts like keyboard fan etc from the pi.
  • I tried different operating systems (Ubuntu, raspi and other manjaro distributions) I had no problems with them. I can use Manjaro xcfe without any problems, but setting up my own rice/setup on it is quite troublesome.
  • I tried different flashing tools (balena & raspberry official flasher)

What could be the cause of the problem? I’m a computer engineering student and I have very little time before school starts, I have to get this job done as soon as possible. Thanks to everyone who has helped so far.

Please give this a try: System cannot boot anymore, after connecting to wifi - #6 by sora

1 Like

yes this solved my problem, i’m asking because i’m curious. That line in the config file was still there before the update, what changed after the update and deleting that line solved the problem?

In addition, what is the name of the bar above on sway? I want to remove it and replace it with polybar. Thanks a lot for your help.

update : Bluetooth, software installer and many applications are not working in the system. I reinstalled and updated my eeprom (sudo rpi-eeprom-update -a) and got the same error. Could the problem be related to the new eeprom updated with -Syu?

No problems here with the latest eeprom upgrade on xfce.

yes i didn’t have a problem with xcfe, but i have a problem with sway. i am used to using window manager instead of desktop manager. I had a problem installing bpswm in xcfe. So I thought of using sway.