Random hard freezes on KDE Plasma

Hello there,
I have been daily driving my Manjaro KDE Plasma for almost half a year.
I have experienced several hard freezes on my system for the last two months.
The freezes made my PC completely unresponsive.
My keyboard and mouse were unresponsive, and unless I hard reset my system, I couldn’t get out of the freeze (REISUB/REISUO didn’t work because of that). Furthermore, whenever I tried to reconnect the USB of my keyboard, the light of the RGB did not come back.
Another freeze happened to me when I watched a YouTube video, and the video’s audio just kept looping.
I’m using Manjaro mainly for gaming (League of Legends etc.), web development, general programming, and browsing.
I’m running X11, kernel 6.1 LTS with KDE 5.27.4.
Here are the system information thank you @cscs for pointing me to that :smiley:

  Kernel: 6.1.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=872e7e02-40b2-4774-bdd7-a968669be84f rw quiet
    resume=UUID=01c70591-250b-487a-8c89-232c9cb21e2e udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: B450 AORUS ELITE v: x.x
    serial: <superuser required> UEFI: American Megatrends LLC. v: F62c
    date: 05/10/2021
  Message: No system battery data found. Is one present?
  RAM: total: 23.41 GiB used: 4.24 GiB (18.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 32 MiB
    desc: 2x16 MiB
  Speed (MHz): avg: 2656 high: 4466 min/max: 2200/4559 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3803 2: 1985
    3: 2015 4: 2200 5: 4466 6: 2200 7: 2551 8: 2200 9: 4071 10: 2200 11: 2041
    12: 2016 13: 4192 14: 2027 15: 2557 16: 1985 bogomips: 124615
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2
    sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext
    tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: Gigabyte
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none off: HDMI-A-1
    empty: DP-1,DP-2,HDMI-A-2 bus-ID: 07:00.0 chip-ID: 10de:2504 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 93 s-size: 524x292mm (20.63x11.50")
    s-diag: 600mm (23.62")
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: Philips PHL 243V5
    serial: <filter> built: 2017 res: 1920x1080 hz: 60 dpi: 94 gamma: 1.2
    size: 521x293mm (20.51x11.54") diag: 598mm (23.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
    3060/PCIe/SSE2 direct-render: Yes
  Device-1: NVIDIA GA106 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 1-3:2 chip-ID: 1038:12b3 pcie: gen: 3
    class-ID: 0300 speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 07:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: SteelSeries ApS Arctis 1 Wireless type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  API: ALSA v: k6.1.25-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.70 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 3.62 TiB used: 463.21 GiB (12.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP510
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: ECFM22.6 temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EFRX-68FYTN0
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0A82 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM008-2FR102
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Toshiba model: DT01ACA050
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: A750 scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 93.29 GiB size: 91.27 GiB (97.83%) used: 52.05 GiB (57.0%)
    fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8 label: N/A
    uuid: 872e7e02-40b2-4774-bdd7-a968669be84f
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7
    label: NO_LABEL uuid: 89A4-BEA0
  ID-3: /home raw-size: 913.57 GiB size: 898.16 GiB (98.31%)
    used: 411.16 GiB (45.8%) fs: ext4 dev: /dev/sdb6 maj-min: 8:22 label: N/A
    uuid: a631decb-30d9-4e0b-b11c-a99f497db1c7
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 15.63 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdb5 maj-min: 8:21 label: N/A
    uuid: 01c70591-250b-487a-8c89-232c9cb21e2e
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 100 MiB fs: vfat label: N/A
    uuid: 2E7F-A6A3
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 351.06 GiB fs: ntfs label: N/A
    uuid: 56E2A44CE2A431E3
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 509 MiB fs: ntfs label: N/A
    uuid: DAAEB31CAEB2EFDD
  ID-5: /dev/nvme0n1p5 maj-min: 259:5 size: 512 MiB fs: vfat label: NO_LABEL
    uuid: D724-4036
  ID-6: /dev/nvme0n1p6 maj-min: 259:6 size: 1.16 GiB fs: vfat label: N/A
    uuid: 15B0-C849
  ID-7: /dev/sda1 maj-min: 8:1 size: 931.51 GiB fs: ntfs
    label: \xd7\x9b\xd7\x95\xd7\xa0\xd7\x9f \xd7\xa7\xd7\xa9\xd7\x99\xd7\x97
    uuid: DECE1B73CE1B42E7
  ID-8: /dev/sdb1 maj-min: 8:17 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-9: /dev/sdb2 maj-min: 8:18 size: 600 MiB fs: vfat label: N/A
    uuid: ADB8-0557
  ID-10: /dev/sdb3 maj-min: 8:19 size: 1024 MiB fs: ext4 label: N/A
    uuid: dd80abbb-d05a-4ada-bfbc-dee2ad84db64
  ID-11: /dev/sdb4 maj-min: 8:20 size: 932.22 GiB fs: ntfs label: N/A
    uuid: 8E40B70A40B6F7D3
  ID-12: /dev/sdc1 maj-min: 8:33 size: 465.76 GiB fs: ntfs label: N/A
    uuid: A69CF9199CF8E4A9
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: SteelSeries ApS Arctis 1 Wireless type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 1038:12b3 class-ID: 0300
  Device-2: 1-8:3 info: Cooler Master AMD SR4 lamplight Control
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 2516:0051 class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Logitech G502 SE HERO Gaming Mouse type: Mouse,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 300mA
    chip-ID: 046d:c08b class-ID: 0300 serial: <filter>
  Device-2: 3-4:3 info: SteelSeries ApS Apex 150 Gaming Keyboard
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s power: 400mA chip-ID: 1038:1616 class-ID: 0300
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 316 Uptime: 32m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1718
  pm: pacman pkgs: 1694 libs: 482 tools: pamac,yay pm: flatpak pkgs: 24
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26

Here’s a demonstration video I uploaded. Click here
If anyone can come to the rescue, I would appreciate it!


I added a video about the problem.

You need to check out various logs (after reset) to see what was the problem.

Start with:

journalctl -b-1 -p3 --no-pager

Xorg log at /var/log/Xorg.xxx.log or ~/.local/share/xorg/Xorg.xxx.log .

Kernel logs : journalctl -k

/var/log/daemon.log - messages generated by daemons
/var/log/kernel.log - messages generated by the kernel

SDDM logs:

journalctl -u sddm.service

P.S. Video doesn’t provide any details, so it’s useless.

Strange - I suspect a hardware issue - espcially as you further state

Kernel appears to have lost connection to the USB hub

You could try Wayland instead of X11 simply select wayland from the login screen (you may need to install plasma-wayland-session).

And you could experiment with either kernel 6.2 or 5.15LTS.

If you are using a custom theme - I suggest reverting to the default Manjaro or KDE theme.

Thank you for pointing me to the logs.
Here are my findings.
From: journalctl -b-1 -p3 --no-pager

Apr 25 10:57:48 ram-pc kernel: kvm: support for 'kvm_amd' disabled by bios
Apr 25 10:57:49 ram-pc kernel: 
Apr 25 10:57:59 ram-pc pipewire[928]: spa.v4l2: '/dev/video0' VIDIOC_QUERYCTRL: Input/output error
Apr 25 10:57:59 ram-pc kernel: usb 3-3: Failed to query (GET_DEF) UVC control 2 on unit 1: -32 (exp. 1).
Apr 25 11:59:01 ram-pc pulseaudio[1254]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)

From: /var/log/Xorg.1.log
I found some sort of a fatal server error(?) at the end of the log not sure what to make out of it because I don’t understand which of the lines is the error.

[ 25548.260] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 25548.260] (II) Platform probe for /sys/devices/pci0000:00/0000:00:03.1/0000:07:00.0/drm/card0
[ 25548.261] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[ 25548.261] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[ 25548.262] (--) PCI:*(7@0:0:0) 10de:2504:1458:4074 rev 161, Mem @ 0xfb000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[ 25548.262] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 25548.262] (II) LoadModule: "glx"
[ 25548.262] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 25548.263] (II) Module glx: vendor="X.Org Foundation"
[ 25548.263] 	compiled for, module version = 1.0.0
[ 25548.263] 	ABI class: X.Org Server Extension, version 10.0
[ 25548.263] (II) LoadModule: "nvidia"
[ 25548.263] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 25548.263] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 25548.263] 	compiled for, module version = 1.0.0
[ 25548.263] 	Module class: X.Org Video Driver
[ 25548.263] (II) NVIDIA dlloader X Driver  525.89.02  Wed Feb  1 23:14:37 UTC 2023
[ 25548.263] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 25548.263] (II) Loading sub module "fb"
[ 25548.263] (II) LoadModule: "fb"
[ 25548.263] (II) Module "fb" already built-in
[ 25548.263] (II) Loading sub module "wfb"
[ 25548.263] (II) LoadModule: "wfb"
[ 25548.263] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 25548.264] (II) Module wfb: vendor="X.Org Foundation"
[ 25548.264] 	compiled for, module version = 1.0.0
[ 25548.264] 	ABI class: X.Org ANSI C Emulation, version 0.4
[ 25548.264] (II) Loading sub module "ramdac"
[ 25548.264] (II) LoadModule: "ramdac"
[ 25548.264] (II) Module "ramdac" already built-in
[ 25548.264] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 25548.264] (==) NVIDIA(0): RGB weight 888
[ 25548.264] (==) NVIDIA(0): Default visual is TrueColor
[ 25548.264] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 25548.264] (**) Option "AllowNVIDIAGpuScreens"
[ 25548.264] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[ 25548.264] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[ 25548.264] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[ 25548.264] (**) NVIDIA(0): Enabling 2D acceleration
[ 25548.264] (II) Loading sub module "glxserver_nvidia"
[ 25548.264] (II) LoadModule: "glxserver_nvidia"
[ 25548.264] (II) Loading /usr/lib/nvidia/xorg/libglxserver_nvidia.so
[ 25548.268] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[ 25548.268] 	compiled for, module version = 1.0.0
[ 25548.268] 	Module class: X.Org Server Extension
[ 25548.268] (II) NVIDIA GLX Module  525.89.02  Wed Feb  1 23:13:01 UTC 2023
[ 25548.268] (II) NVIDIA: The X server supports PRIME Render Offload.
[ 25548.268] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:7:0:0
[ 25548.268] (--) NVIDIA(0):     DFP-0 (boot)
[ 25548.268] (--) NVIDIA(0):     DFP-1
[ 25548.268] (--) NVIDIA(0):     DFP-2
[ 25548.268] (--) NVIDIA(0):     DFP-3
[ 25548.268] (--) NVIDIA(0):     DFP-4
[ 25548.268] (--) NVIDIA(0):     DFP-5
[ 25548.269] (II) NVIDIA(0): NVIDIA GPU NVIDIA GeForce RTX 3060 (GA106-A) at PCI:7:0:0
[ 25548.269] (II) NVIDIA(0):     (GPU-0)
[ 25548.269] (--) NVIDIA(0): Memory: 12582912 kBytes
[ 25548.269] (--) NVIDIA(0): VideoBIOS:
[ 25548.269] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 25548.269] (EE) NVIDIA(GPU-0): Failed to acquire modesetting permission.
[ 25548.269] (EE) NVIDIA(0): Failing initialization of X screen
[ 25548.270] (II) UnloadModule: "nvidia"
[ 25548.270] (II) UnloadSubModule: "glxserver_nvidia"
[ 25548.270] (II) Unloading glxserver_nvidia
[ 25548.270] (II) UnloadSubModule: "wfb"
[ 25548.270] (EE) Screen(s) found, but none have a usable configuration.
[ 25548.270] (EE) 
Fatal server error:
[ 25548.270] (EE) no screens found(EE) 
[ 25548.270] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[ 25548.270] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[ 25548.270] (EE) 
[ 25548.270] (EE) Server terminated with error (1). Closing log file. 

From /var/log/daemon.log no logs I could find.
From /var/log/kernel.log no logs I could find.

From journalctl -k:
kvm: support for 'kvm_amd' disabled by bios
This was the only line in red. After a quick Google, I could find that it’s related to “Intel Virtual Technology” or some sort of that which, in my suspicion, isn’t relatable to my issue.

And last: journalctl -u sddm.service
Didn’t find anything useful.

You are quite correct. The video doesn’t help, but if someone didn’t understand what I meant by “keyboard not responding and screen freezes” they got a visual video to demonstrate that.

Right now, I have tried running Wayland. I got some problems with flickering, and it seems like the support of Wayland in NVIDIA is perhaps, still lacking and I may want to stay on X11 until I will hear better news from NVIDIA.

I know I can just check myself but, will be any performance hits on games? packages won’t complain because of an older kernel?

From my knowledge, I don’t use any custom theme other than Breath dark, I don’t care about the look however I do like the freedom of Linux and how efficient it can be during development.

And you should - I am not a gamer, so I’ll pass on guessing. I am however a developer with high performance requirements and 6.2 performs very well on my systems.

But judgning from a quick search - these nvidia gpu’s are not easy to configue on Linux - check the search linked to below

As for you xorg log - I would check if the best driver is loaded - possible module inclusion in mkinitcpio.conf and/or possible kernel arguments.

archlinux nvidia rtx 3060 - sx.nix.dk

I may misinterpret your intentions.
I checked with the command nvidia-smi, and it pointed out that I’m running the driver version 530.41.03, which is the latest driver from NVIDIA.
In the Xorg log, did you mean that from the log, NVIDIA GLX Module 525.89.02 is being loaded?
I read about that mkinitcpio.conf I didn’t touch it, and it seems to be correct.
On the kernel side, I see that it is using nvidia-drm.modeset=1, which from my understanding uses the proprietary NVIDIA drivers.

My intention is entirely to provide you with some ideas.

From experience most issues are caused by local configuration and with random issues it is next to impossible to provide a clear solution.

While I recognize you have an issue you cannot root out - troubleshooting a complicated issue like this - and at random - is very difficult.

So perhaps I am asking dumb questions … that is unintentional …

You have noted this - right?

So pointing you to your configuration seemed to be the right direction …


I’m very appreciate the efforts. Thank you!

I didn’t pay attention to the date of the Xorg log file, which was the 16th of April. I’m pretty sure I did not experience any freezes on that date besides, Googling it and feeding this error into ChatGPT didn’t lead me to anything because the description of what other users were trying to do or the symptoms did not match mine.
I’m frustrated with that problem… and from looking in the logs, I did not find anything that can point me to the problem, but at least I know better where to look when I face the same problem.
For now, I will leave it and won’t dig any further until the next freeze and take your advices, changing kernel versions and using Wayland.
Thank you for your help :slight_smile: .

1 Like