Random Freezing/Not responding

After changing and installing kernel 5.4 i still experienced the freeze. Will try kernel 5.12 and see what will happen.

1 Like
  • If upgrading the kernel to 5.12 wouldn’t help neither, please try to create a new user and log in there and see if you have the issue there as well. (E.G. couch2)
  • if the above doesn’t help neither, please:
    • Post the output of an

      inxi --admin --verbosity=7 --filter --no-host --width
    • Run the following in a terminal (and keep that terminal open, minimized is fine):

      watch --interval=3 'free --human > /var/tmp/myfree.txt'
    • when the problem arrives:

      • note the exact time

      • REISUB

      • Post the output of:

        journalctl --system --boot=-1 --since "YYYY-MM-DD HH:MM:SS" --until "YYYY-MM-DD HH:MM:SS"

      where YYYY-MM-DD is obviously the date and HH:MM:SS is 3 seconds before and after the freeze issue.

      • Obviously, provide the contents of /var/tmp/myfree.txt too


1 Like

the last step might be impossible to do since when the freeze happens it continues until i have to do a cold reboot…

Are you saying that you’ve followed the tutorial and activated sysrq_always_enabled=1 but once you get a freeze, REISUB doesn’t work???


Created a new user and haven’t experienced any freeze so far. Is there any reason as to why the freeze is happening on the original account and not on the second one?

1 Like
  • It happens that user profiles get corrupted especially if you experiment with multiple DEs (or a bunch of old unmaintained themes) with a single user… :sob:

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups couch
    groups couch2

    (Where obviously, couch is your old user and couch2 is your new one.)
    E.G. if couch is a member of operator and couch2 isn’t, execute:

    usermod --append --groups operator couch2
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=time-stamps /home/couch/Documents/* /home/couch2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/couch/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/

    After everything has been copied over, disable the old user so you cannot accidentally log on:

    usermod --lock couch

    If you would have theming going on, don’t do everything in one day but do this at the rate of 1 application / theme / whatever per day and if the same issue crops up again, roll back your last change

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:

Fabby, the funny thing is that this was a new installation. Practically new, nothing saved in all those directories and no special programs installed, so migrating to this new account will be easy. Below is the outcome of groups command

wheel lp sys network power kevin
[mbugua@Datanav ~]$ groups mbugua
audio lp optical video sys network scanner power mbugua
[mbugua@Datanav ~]$ 

kevin is the old user and it seems he had far much less rights than the new account. Tried issuing the wheel rights to the new account but was met with an access denied error or do i need to switch to the old account and issue the rights from there?

To protect people from themselves by reading and applying random posts on the internet, I never include sudo in any of my commands, so:


Did not get the joke at all… :man_shrugging:

1 Like

Being extremely clear now:


sudo usermod --append --groups wheel mbugua


I can humbly confirm that the system is fine now with no freezes at all! Creating a new user and upgrading the kernel to version 5.12.1-2 solved the issue. Thank you fabby!

1 Like

Well it froze again, completely unusable until a hard reboot had to be done.
The freeze started by inter changing the mouse button functions, then went completely ice, even the backlight keyboard lights would not go off. They stayed on until the reboot. Then even after rebooting the same thing happened all over again!

  Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=28eb9023-ea6d-4dc6-91eb-e41f64b8dd69 ro quiet apparmor=1 
  security=apparmor resume=UUID=e8bade99-7070-4a59-bb67-adad67c1e659 
  Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Hewlett-Packard product: HP EliteBook Folio 9480m 
  v: A3009DD10303 serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Hewlett-Packard model: 22DA v: KBC Version 92.17 serial: <filter> 
  BIOS: Hewlett-Packard v: M85 Ver. 01.50 date: 02/24/2020 
  ID-1: BAT0 charge: 21.1 Wh (100.0%) condition: 21.1/21.1 Wh (100.0%) 
  volts: 16.4 min: 14.8 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Full 
  RAM: total: 15.06 GiB used: 1.88 GiB (12.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i7-4600U bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 26 cache: 
  L2: 4 MiB bogomips: 21556 
  Speed: 1099 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 1099 2: 843 
  3: 959 4: 2096 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good 
  sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave 
  xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300 
  Device-2: Cheng Uei Precision Industry (Foxlink) HP EliteBook integrated HD 
  type: USB driver: uvcvideo bus-ID: 2-7:5 chip-ID: 05c8:0374 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 21.0.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c 
  class-ID: 0403 
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: yes 
  Device-1: Intel Ethernet I218-LM vendor: Hewlett-Packard driver: e1000e 
  v: kernel port: 5080 bus-ID: 00:19.0 chip-ID: 8086:155a class-ID: 0200 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: ef80 
  bus-ID: 08:00.0 chip-ID: 8086:08b1 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 2-4:3 chip-ID: 8087:07dc class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 238.47 GiB used: 20.24 GiB (8.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZ7PD256HCGM-000H7 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 6H6Q scheme: MBR 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 94.73 GiB size: 92.74 GiB (97.90%) used: 20.24 GiB (21.8%) 
  fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: 28eb9023-ea6d-4dc6-91eb-e41f64b8dd69 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 5.86 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: e8bade99-7070-4a59-bb67-adad67c1e659 
  ID-1: /dev/sda1 maj-min: 8:1 size: 549 MiB fs: ntfs label: System Reserved 
  uuid: 3BB43BDF5A6D727C 
  ID-2: /dev/sda2 maj-min: 8:2 size: 136.68 GiB fs: ntfs label: N/A 
  uuid: B8D09D6CD09D321C 
  ID-3: /dev/sda3 maj-min: 8:3 size: 685 MiB fs: ntfs label: N/A 
  uuid: BA4C23DE4C2393E3 
  ID-4: /dev/sda4 maj-min: 8:4 size: 1 KiB fs: <superuser required> label: N/A 
  uuid: N/A 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 9 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-3:2 info: Microchip (formerly SMSC) Hub ports: 3 rev: 2.1 
  speed: 480 Mb/s chip-ID: 0424:2134 class-ID: 0900 
  Device-1: 2-3.2:4 info: Logitech Unifying Receiver type: Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c52f class-ID: 0300 
  Device-2: 2-4:3 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:07dc class-ID: e001 
  Device-3: 2-7:5 info: Cheng Uei Precision Industry (Foxlink) HP EliteBook 
  integrated HD Webcam 
  type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
  power: 500mA chip-ID: 05c8:0374 class-ID: 0e02 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-6: 3-3:2 info: Microchip (formerly SMSC) Hub ports: 3 rev: 3.0 
  speed: 5 Gb/s chip-ID: 0424:5534 class-ID: 0900 
  System Temperatures: cpu: 55.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 193 Uptime: 7m wakeups: 1 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 Packages: pacman: 1272 lib: 382 flatpak: 0 
  Shell: Bash v: 5.1.4 running-in: yakuake inxi: 3.3.04 

Didn’t note the time for a journalctl.

I hope you did a REISUB??? If not; that is a sure way of messing up your system partition and getting all kinds of trouble!

After the above REISUB, please?

While I’m looking into that, please also:

  • Try another mouse
  • have a look if there is a BIOS / UEFI firmware upgrade for your machine…



Failed to parse timestamp: “2021-05-21
[kevinm@DataNav ~]$ journalctl --system --boot=-1 --since “2021-05-21 14:19:01” --until “2021-05-21 14:20:01”
Failed to parse timestamp: “2021-05-21

Oh wow. there is a bug in journalctl. it used to be able to do that just a few days ago… :sob:

So do it manually: redirect to a text file and cut the superfluous information.

How about:


Its was the internal touchpad and not an external mouse. And nop i dont have any new Bios update for my PC…also been trying to do a REISUB but nop it does not work either. If i hold ALT key and press the buttons, it just highlights the usual ALT shortcuts on the browser. Also noticed with the current form of freeze, i can restart the PC by pressing the power button and choosing “restart”. Apparently only the DE(plus the apps already opened) is freezing. And it has happened thrice in 5 minutes so far. Would it be due to the updates that were pushed early on this week?
Also i have no clue how to export the journal data to a text file(novice human being here)

OK, I can’t help you any further then… My apologies, solution removed to attract other experts.


Meeeen!! this random freezes are killing me!! Totally killing! Anyone, kindly assist. About to give up on the whole Manjaro Journey.

@Fabby is there anyone from the Manjaro team that you can direct them this way concerning my issue? Have just experienced 2 consecutive freezes and its really killing my productivity and work flow!

Please read this:

But read the last section first and If you’re still interested, read the other sections as well.