Quite old config in my /home directory

I have a quite old config of KDE in my /home directory.
Some settings do not apply.

How can I reset the settings to default?

I think of using the settings of another user, which I have setup lately.
I there another way to reset to default ?

Copy the contents of /etc/skel/ to your home directory. I have never done this and would recommend backing up beforehand.

The directory of /etc/skel is empty.

It’s not, they are hidden. Press CTRL+H (assuming you are viewing in Dolphin).

most probably it is not empty - but these are all just hidden files and directories (starting with a dot)

ls -hl /etc/skel

if you really want to reset it
you’d have to “clean” out the configuration files in your $HOME before you then replace them with the ones in /etc/skel

Else you have some of the default settings and some of what was there already, all mixed up.

I’d recommend:

  • log out of the session - because the running session may and likely will not let you remove all the files
  • go to a TTY
  • remove ~/.cacherm -rf ~/.cache
  • remove ~/.config → mv ~/.config ~/.config.backup
  • copy the contents of /etc/skel to ~/
    probably this is overkill - it’s sufficient to just copy everything in /etc/skel/.config
    cp -r /etc/skel/.config ~/
1 Like

You missed an ‘a’, it should be ls -lah /etc/skel

ls -lah /etc/skel
total 56K
drwxr-xr-x   3 root root 4.0K Jan 25 10:49 .
drwxr-xr-x 108 root root  12K Mar  1 09:17 ..
-rw-r--r--   1 root root   21 Jan  9  2022 .bash_logout
-rw-r--r--   1 root root   57 Jan  9  2022 .bash_profile
-rw-r--r--   1 root root 3.8K Jan 14  2022 .bashrc
drwxr-xr-x   4 root root 4.0K Dec 19 09:37 .config
-rw-r--r--   1 root root 4.8K Oct 29  2017 .dir_colors
-rw-r--r--   1 root root   53 Jun  3  2022 .nanorc
-rwxr-xr-x   1 root root  100 Oct 29  2017 .Xclients
-rwxr-xr-x   1 root root 1.6K Dec 14 17:46 .xinitrc
-rw-r--r--   1 root root  293 Jan 24 19:43 .zshrc

1 Like

Correct! Thank you! My bad.

I mixed up ls -hl and ls -al because I wanted the output as -h …

1 Like

I have copied /etc/skel to my home directory.
But the main problem persits: the old config of KDE.

1 Like

Of course it still exists - and likely gets in the way of your goal.
That’s why I recommended to remove it first.
… from the “outside” - from a TTY, while the session is not running

How is that “old” config a problem, btw?

A console file manager like mc will greatly help you when you need to work in a TTY and are not well used to the command line.

The settings of KDE do not apply to the recent version of KDE.
I have moved the old .kde4 folder to .kde4Backup and now the desktop does not boot correctly.

Personally: I do not even have such a folder.
Never even had. :man_shrugging:
So: not having it is clearly not the reason for your problem.

… if you want to reset to defaults - do it thoroughly
not just piece by piece, one file at a time …

I have done resetting the config this way:
Copied the personal files to USB stick.
Deleted the user.
Created the user.
Copied the files back.

… sozusagen: von hinten mit der Faust durchs Auge …
oder: warum einfach wenn es auch umständlich geht? :slightly_smiling_face:

What I described - removing the contents of ~/.config and replacing it with what is in /etc/skel/… is essentially the same thing.
When a new user is created, the contents of /etc/skel get copied to the account.
The effect is the same - just the required effort to achieve it was a bit more with your approach.

But hey - if it works, it works. :grinning: :+1:

The files of .kde4 was the main problem, not .config.

Old files or old configuration options within specific files?

How did you identify them as being old?

Any specific examples?

Just want to highlight that 99% of applications use .config, not just kde applications or plasma desktop. It is the XDG standard.

I would either selectively look for older files with find (i.e., find $HOME/.config -type f -ctime +700) and selectively remove, or I’d create a new user and diff $HOME. An indiscriminate removal seems like it could cause a host of problems.

I have 2 aliases for list directory contents shown below. The find command shows files that have been modified within the last minute. It comes in handy when you install something, execute an application, or change a setting, and want to quickly find out where that data was stored.

alias l='ls -l --group-directories-first'
alias ll='ls -alF --group-directories-first'

alias f1='find -newermt "1 minute ago"'

Some of the settings of the KDE config do not apply to the latest KDE version.

I understand that you already solved your problem (by deleting the user account, and then re-creating it …).
What I still don’t understand is the significance of what you said here for the second time:

What is that difference?
There is no ~/.kde4 folder/directory in my installation (which is recent).

If you want to reset to (current) defaults - this directory is definitively not a part of it.

If I open the system settings, then there settings highlightend.
I could not correct them.

E.g.: number of desktops.

I have no idea what that might mean
or how it relates to removing ~/.config and ~/.cache and starting over with default values from /etc/skel

… and only with those - nothing “old” left behind …

Moot point, however, since whatever you did did seems to have worked for you.

Everything in the best order.