Qt5-base package: QMovie: "Unable to read image data"

EDIT:

This issue also occurs by using nomacs from official repo (also nomacs is an image viewer which relies on qt5-base package), so is not an AUR problem: I remove the AUR tag: if @Aragorn disagree, can set again such tag.

Since the stable update of 2020-10-01 [Stable Update] 2020-10-01 - Kernels, Mesa, KDE-Framework, Deepin, Systemd, Pamac, Xorg-Server, Qt

I am no longer able to play gif images on applications which relies on qt5-base package, which, in facts, provides /usr/include/qt/QtGui/QMovie
An example: on my system I’m using qimgv as image viewer, which is qt5 based application; since the update of qt5-base package to 5.15.1-1 when I launch it from a terminal window by feeding it with any gif image, I got the error reported as title: [Error] QMovie: "Unable to read image data".

All is fine with image viewers which doesn’t rely on qt5.

There could be some workaround, as delete some config files of qt?

That’s an AUR package, have you tried rebuilding it?

1 Like

Sure: is the firts thing that I do every time when its dependencies are updated.

It was not a tag. I put the thread in the #support:aur category, but you’ve moved it to #support now, which is an umbrella for other categories and is not intended for direct support requests or problem reports ─ notwithstanding that everyone simply drops off their stuff in there.

I have now moved the thread to the #support:applications category.

Well, today’s update [Stable Update] 2020-11-27 - Kernels, Browsers, Maui-Apps, Pamac 10.0-Beta, Gnome, Mesa, Qt which contains 5.15.2-1 has solved this problem.