QT apps don't touch the taskbar when maximised

How many more months will I be looking at either my wallpaper, or my gtk apps in between my task bar and maximized window? I know Niccolo fixed this is the KDE theme some months back. Do you guys ever plan on fixing it?

Are you referring to Manjaro’s breath theme?

Yes, breath dark specifically.

Not on Breath Light or normal Breath?

Interestingly, I am unable to replicate. How long as your system been installed? I don’t fully know how this works, but it’s possible that the default themes are never updated after installation. In which case, you would have to grab the latest version from gitlab.

Can you link the Niccolo video/commits in question?

I don’t use breath light or normal. I really hate changing themes, so I am not checking them.

I am however trying to find the video. He doesn’t title his videos well, so it’s tough. I will keep looking.
IIRC , he added a pixel or two to the border.

Give me a little more time and I will find the video.

I spent a good half hour looking for the video and can’t find it. So I resorted to other tactics, I found this merge request that seems like a better fix. So, it’s possible that he removed the video.

If you look how we do Breath, for the Panel in /usr/share/plasma/desktoptheme/breath/ you will know that what we tweak are a few custom icons and one widget. Everything else is taken from default aka Breeze. And for light and dark there is the colors file for each. There is nothing closer to upstream than that.

Clean the ~/.cache folder. You can simply apply Breeze in Plasma Style settings, log out then back in, check if the issue is still there, switch back to Breath or Breath Dark. It takes two minutes, and i can’t replicate either.

1 Like

I tried that, and it didn’t work. Since I already took the plunge, I also tried breeze dark. The problem doesn’t exist on Breeze dark. Are you guys up to date with your implementation of breeze? I don’t remember seeing an update in a while, but I can’t say I remember every package of every update either.

See screenshots.

Breeze is taken from upstream.

Also, regardless from where i change the Theme, from Quick Settings, From Appearance > Global theme or just via the Plasma Style, there is no gap with Breath Dark …

1 Like

This can also happen if compositing is off/broken … please check that as well.

1 Like


I know what you mean, I have seen that. My compositor is on.

So, I have a dark wallpaper, and it’s barely noticeable. Is yours dark?

I pulled up something yellow on chromium, and that shines through.

Went trough all the Panel options and

all work as expected.

I chose the Safe Landing wallpaper, is quite bright and should pass trough if there was a gap there. Switched between Breath (that uses the color-scheme) and Breath Dark and still no gap

1 Like

I didn’t mention, but I am on the stable branch, maybe you are on something newer than I am? Other than that, I am out of ideas for now. I have been having this problem for a long time. Probably 6 months or more. On a laptop, and this desktop that I built a few months ago. I might as well use Breeze, it doesn’t really look much different anyway.

Anyhow, I appreciate the effort.

Alright. Things are pretty strange now.

So these are my “steps”

Apply a theme, In this case breeze dark.
The gap goes away, in the theme menu.

The problem still exists on dolphin

Log out, and the problem now exists in the global theme menu again.

Apply a different theme, in this case, breath dark again. The problem goes away in the theme menu again.

rinse and repeat

So it really is not a matter of just using a breeze after all. And on this note, I am going to call it a night.

I still think is a ~/.cache issue on your end.
Just to be sure for you, we all have the same packages now, regardless the branch



See more on https://packages.manjaro.org

Try using new user profile, might be some config problem. Doesn’t happen for me on both Breath & Breeze.


I deleted the entire .cache directory more than once.

What about the .config (no dont delete the whole thing) directory?
Please see the link.