qBittorrent Alpha launches unprivileged Dolphin session and no audio playback?

The bash script is run by Linux Manjaro 5.11.22-2 user crontab.
it launch the symbolic link which is linking to /usr/local/bin/qbittorrent
so app is launched by that cronjob, its details:
$ /usr/local/bin/qbittorrent -v
qBittorrent v4.4.0alpha1

Inside app click some complete torrent, click Files tab, doubleclick some video file, it opens MPV player, but the sound is not played, in VLC it played (when i set it as default instead of MPV). VLC is using alsa.id = “ALC222 Analog” device. As said already in the past, when i open .mp3 from qbittorrent (it was earlier version 4.3.1-1 community), then the Audacity said:
ALSA error: snd_pcm_open failed: Device or resource busy.
UPDATE: this was fixed by switching audio device in Audacious settings to ALSA, though when i tried to switch to PulseAudio, player says “pa_context_connect() Failed: Connection refused” and then “snd_mixer_find_selem failed.”

Audio is not the only problem, when qbittorrent opens an file explorer (by clicking some payload folder to explore it), then it does no open new tab in already open Dolphin file manager, but opens new Dolphin file manager window with different styling than the Dolphin i already have opened (even the version of both is the same), but this weird Doplhin (or Thunar…) window which cause that SOME video files launched form it does not play audio (when tried in Normal dolphin session launched from XFCE 4.16, audio was played).

This is not a recent issue, happens for months and across various qbittorrent releases, may not be qbt issue, i do not know. What to do to find the cause please?

pulseaudio details here

in qbittorrent, right click some torrent and “Open destination folder”, browse to some media file and play it.

If you want to use Alpha software, expect bugs. I would report the issue upstream.

thanks, i know, though i have mentioned that it also happened for v. “4.3.1-1 community” so i would welcome if people there (ideally with a XFCE) would try to reproduce

Linux fails again, VLC player opened via qBittorrent or via Dolphin file manager that is opened via qBittorrent, says:

Audio output failed:
The audio device “sysdefault:CARD=Generic_1” could not be used:
Device or resource busy.

but when opened via normal Dolphin file manager, VLC plays OK.

So how to fix this?

Still issue. Most of the Linux media players launched via qBittorrent does not play audio, VLC plays (yet VLC has an unfixed issue - cause high temperature on Manjaro) so not a good player atm, so i have tried gnome-mplayer and that works after i set it as system default app for video and customize audio device in its Settings, set “HD-Audio-Generic (ALCxxx Analog) (alsa)” then qBittorrent launch this player and it plays audio. Bad is that audio plays only if this player has only one instance.

Why with Cron? Did you probably run it as the root user?