Pulseaudio busy and systemctl restart ineffective

That’s normal behavior for a live USB session. It’s not really anyone’s personal system, thus no need for passphrase protection.

1 Like

Will do when I get there, trying to follow the GRUB/restore the GRUB guide. This time
manjaro-chroot -a
gave the output

grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
==> Mounting (ManjaroLinux) [/dev/nvme0n1p7]
 --> mount: [/mnt]
mount: /mnt: /dev/nvme0n1p7 already mounted on /mnt.
 --> mount: [/mnt/boot/efi]
mount: /mnt/boot/efi: /dev/nvme0n1p2 already mounted on /mnt/boot/efi.

and so I went to check my /etc/fstab and it looks like that file somehow was overwritten in the Windows update? At least it doesn’t list all the partitions it should. Here is what I see:

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=2ACF-93D6                            /boot/efi      vfat    umask=0077 0 2
UUID=88ec38db-9f99-4ff1-8f7a-41b7f1ec6589 /              ext4    defaults,noatime 0 1
UUID=d1447f1e-654f-435c-9153-0b6e4472eb4e /home ext4 defaults,noatime 0 2
UUID=afd121e3-cca8-40fd-8535-3e241d39435c none swap defaults 0 0

should I continue with the grub re-install?

Also, dumb question, but once this is done what is the command to unmount all before rebooting? Or can I just reboot and see if I get to GRUB?

:point_up: :+1:

1 Like

Either way I try to run pacman -Syu grub as per the guide it seems to fail:

[manjaro /]# pacman -Syu grub
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace jack with extra/jack2? [Y/n] Y
:: Replace lib32-jack with multilib/lib32-jack2? [Y/n] Y
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] Y
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] Y
:: Replace pamac-common with extra/libpamac? [Y/n] Y
:: Replace pamac-flatpak-plugin with extra/libpamac-flatpak-plugin? [Y/n] Y
:: Replace pamac-snap-plugin with extra/libpamac-snap-plugin? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-5) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-5) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer
[manjaro /]# pacman -Syu grub
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace jack with extra/jack2? [Y/n] n
:: Replace lib32-jack with multilib/lib32-jack2? [Y/n] n
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] n
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] n
:: Replace pamac-common with extra/libpamac? [Y/n] n
:: Replace pamac-flatpak-plugin with extra/libpamac-flatpak-plugin? [Y/n] n
:: Replace pamac-snap-plugin with extra/libpamac-snap-plugin? [Y/n] n
resolving dependencies...
looking for conflicting packages...
:: libpamac and pamac-common are in conflict. Remove pamac-common? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libpamac and pamac-common are in conflict

This is what gives me the most pause, however.


Shouldn’t I be getting those PTTYPE, PARTTYPE, etc fields populated with something?

You have a really sick puppy there, so I’m going to call in our resident UEFI expert @stephane



gives the above errors


1 Like

first you boot on USB iso manjaro live
open a terminal and return

inxi -Mxa
test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v
sudo parted -l 
sudo lsblk -fs 

Here’s the output of the commands asked for, I appreciate the help. I’m curious what went wrong because I want to learn from this so I put some questions/my understanding at the end – feel free to ignore

[manjaro@manjaro Desktop]$ inxi -Mxa
  Type: Desktop Mobo: Micro-Star model: B450 GAMING PRO CARBON AC (MS-7B85) 
  v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.F4 
  date: 04/22/2021 
[manjaro@manjaro Desktop]$ test -d /sys/firmware/efi && echo efi || echo bios
[manjaro@manjaro Desktop]$ sudo efibootmgr -v
BootCurrent: 0007
Timeout: 1 seconds
BootOrder: 0000,0004,0002,0007,0006,0001,0005
Boot0000* Windows Boot Manager	HD(2,GPT,4b35f749-00e9-4788-87a8-5e6c03abd4c1,0x109000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...9................
Boot0001  Hard Drive	BBS(HD,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0200)..GO..NO..........S.a.m.s.u.n.g. .S.S.D. .9.7.0. .E.V.O. .5.0.0.G.B...................\.,.@.r.d.=.X..........A...........................%8T.B~}.....4..Gd-.;.A..MQ..L.S.5.H.7.N.J.0.N.
Boot0002* manjaro	HD(2,GPT,4b35f749-00e9-4788-87a8-5e6c03abd4c1,0x109000,0x32000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0004* UEFI OS	HD(5,GPT,a54c3b62-5111-f040-b0c4-ff899245d586,0x19df2000,0x100000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Boot0005  USB HDD	BBS(HD,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0900)..GO..NO..........K.i.n.g.s.t.o.n.D.a.t.a.T.r.a.v.e.l.e.r. .3...0.P.M.A.P...................\.,.@.r.d.=.X..........A.............................F..Gd-.;.A..MQ..L.6.0.A.4.4.C.4.1.3.D.F.8.E.
Boot0006* UEFI: KingstonDataTraveler 3.0PMAP	PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(2,0)/CDROM(1,0x4d88ac,0x8000)..BO
Boot0007* UEFI: KingstonDataTraveler 3.0PMAP, Partition 2	PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(2,0)/HD(2,MBR,0x0,0x4d88ac,0x2000)..BO
[manjaro@manjaro Desktop]$ sudo parted -l
Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sda: 62.1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2602MB  2606MB  4194kB  primary               esp

Model: Samsung SSD 970 EVO 500GB (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  556MB  555MB   ntfs            Basic data partition          hidden, diag
 2      556MB   661MB  105MB   fat32           EFI system partition          boot, esp
 3      661MB   677MB  16.8MB                  Microsoft reserved partition  msftres
 4      677MB   222GB  222GB   ntfs            Basic data partition          msftdata
 5      222GB   223GB  537MB   fat32                                         msftdata
 6      223GB   225GB  2147MB  linux-swap(v1)                                swap
 7      225GB   246GB  21.5GB  ext4
 8      246GB   500GB  254GB   ext4

[manjaro@manjaro Desktop]$ sudo lsblk -fs
NAME      FSTYPE   FSVER            LABEL             UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0     squashfs 4.0                                                                           0   100% /run/miso/sfs/livefs
loop1     squashfs 4.0                                                                           0   100% /run/miso/sfs/mhwdfs
loop2     squashfs 4.0                                                                           0   100% /run/miso/sfs/desktopfs
loop3     squashfs 4.0                                                                           0   100% /run/miso/sfs/rootfs
sda1      iso9660  Joliet Extension MANJARO_XFCE_2106 2021-06-07-19-55-50-00                              
└─sda     iso9660  Joliet Extension MANJARO_XFCE_2106 2021-06-07-19-55-50-00                     0   100% /run/miso/bootmnt
sda2      vfat     FAT12            MISO_EFI          4A03-D73C                                           
└─sda     iso9660  Joliet Extension MANJARO_XFCE_2106 2021-06-07-19-55-50-00                     0   100% /run/miso/bootmnt
nvme0n1p1 ntfs                      Recovery          34DECF54DECF0CD4                                    
nvme0n1p2 vfat     FAT32                              2ACF-93D6                                           
nvme0n1p4 ntfs                                        9C0CD0A00CD076AC                                    
nvme0n1p5 vfat     FAT32                              1EB7-C94B                                           
nvme0n1p6 swap     1                                  afd121e3-cca8-40fd-8535-3e241d39435c                
nvme0n1p7 ext4     1.0                                88ec38db-9f99-4ff1-8f7a-41b7f1ec6589                
nvme0n1p8 ext4     1.0                                d1447f1e-654f-435c-9153-0b6e4472eb4e                

This all started when I update mobo drivers on Windows (I did the guide by aarhus found here which has Windows first, so all my drivers were windows side).

It looks like this somehow overwrote my GRUB and windows MBR is the default, correct? I suspect my /etc/fstab might be slightly off as well because it doesn’t have entries for all the partitions I remember, but it seems weird that a Windows update would be able to edit that?

This is your default, based on your output:

Boot0000* Windows Boot Manager

You can temporarily override this during the boot sequence by pressing and holding down (or repeatedly pressing!) ESC, F9, F10, or whichever key is assigned to Boot Override for your particular computer.

You can use efibootmgr to re-arrange the order of boot priority, and place manjaro as the first entry:

efibootmgr -o 0002,0000,0004,0007,0006,0001,0005

0002 is manjaro
0000 is Windows Boot Manager
The rest are “whatever”.

However, this is all possible to do within your BIOS setup screen when you first boot up. Once again, you need to know the correct key to press to access it (DEL, ESC, F10, etc)

@stephane interject if I’m mistaken about anything. I replied once I saw their output (from the supplied commands) in case they have a time constraint and need to try something as soon as possible.


I truly appreciate that. I would like to get back to a point that GRUB is frist so that I can set the grub window time and have 3-5 seconds to choose which OS to boot to since I restart frequently.

I’m in MDT (UTC -7:00) and I have the rest of the day tomorrow to trouble shoot, but hopefully it won’t take that :sweat_smile:

there are 2 partitions /boot/efi ,only the one with option flag boot& esp works
p2 contains windows boot
p5 contains manjaro boot

you CANT have 2 /boot/efi on same disk , only one with flag boot&esp will works


What Stéphane is trying to tell you is:

  1. You have a very sick puppy
  2. Better euthanise it
  3. Get a new puppy:
    • back up all of your data, (Cold System Backup will be enough, use an external USB stick with CloneZilla Live
    • wipe all your Manjaro partitions (Keep all the Windows ones!)
    • install again using one single ESP (EFI System Partition)
    • Restore your data

It’s not impossible to merge 2 ESPs, but looking at all the other problems you have, a reinstall will definitely be easier. Therefore, please read this first:

(All of it: I’ll be adding an UEFI / BIOS section later)

Then go back to point 3 above.

Stéphane: I’ll ping you over there to verify anything I’ve written as you’re the EIF Guru here… :grin:

1 Like

Have read through both, thank you. I have a brand new external HDD I was going to use for backups, so now is the opportune time for that I guess. Will it need formatting first?

Just to check: I’ll be booting to my Manjaro OS to make the backup using CLoneZilla live, correct? Or should it be done from the Manjaro live media on my USB?



You didn’t read the CloneZilla link yet, did you??? :stuck_out_tongue_winking_eye:

Something else:

  • You should “burn” the CloneZilla Live .iso to a USB stick
  • You should burn another USB stick with the Manjaro .iso
  • Boot and make the backup with the CloneZilla USB using Disk-to-Image.
  • Reinstall using the Manjaro USB stick
  • If you mess up, you boot the bootable CloneZilla USB stick and restore. (Don’t overwrite it with but keep it handy! 2 USB sticks needed!)


1 Like

"You didn’t read the CloneZilla link yet, did you??? "

I did, but it begins by saying to download the CloneZilla Live but considering my situation I wasn’t sure if this should be done via the Manjaro ISO or booting into my Manjaro OS, sorry

1 Like

No apologies needed: I was unclear…


1 Like

Anyway, as you’re re-formatting your system with your new-found wisdom, Stéphane’s answer was the best you got as he found the root cause of your issue, therefore, I’ve marked his answer as the solution to your question.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

Appreciate all the help. I’m not trying to be truant in marking what worked well for me I just haven’t gotten around to doing the full repair on my system yet. In the middle of a cross-country move and still feeling quite scattered.

Hoping to have it all solved and restored to normal this weekend


Open a new post for each individual issue you (would) run into, please.

Success with the move!


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.