Pulseaudio busy and systemctl restart ineffective

I have been having persistent issues for a couple months now that used to happen 1/3 of boots but now seems to occur about 4/5 boots. Whenever I log into my Manjaro distro I get no audio inputs, pulseaudio shows busy, and when I try to systemctl --user restart pulseaudio I get an error:

systemctl --user restart pulseaudio
Failed to restart pulseaudio.service: Process org.freedesktop.systemd1 exited with status 1
See user logs and 'systemctl --user status pulseaudio.service' for details.
[foo@bar Desktop]$ systemctl --user status pulseaudio.service
Failed to get properties: Process org.freedesktop.systemd1 exited with status 1
[foo@bar Desktop]$ 

It’s getting to the point where I just play bootup roulette and restart 6 times until I finally have audio

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU, GPU or Kernel you have without typing it every time

1 Like

Here is the result:

inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.10.36-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=88ec38db-9f99-4ff1-8f7a-41b7f1ec6589 ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel, plank wm: xfwm4 
  vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Micro-Star product: MS-7B85 v: 1.0 serial: <filter> 
  Mobo: Micro-Star model: B450 GAMING PRO CARBON AC (MS-7B85) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.B0 date: 11/08/2019 
  RAM: total: 15.64 GiB used: 2.6 GiB (16.6%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: 0 microcode: 8701013 cache: 
  L2: 3 MiB bogomips: 86434 
  Speed: 2800 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 2800 2: 1866 3: 2201 4: 2192 5: 1865 6: 2201 7: 2200 8: 2196 9: 2796 
  10: 1857 11: 1865 12: 2197 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs irperf lahf_lm lbrv lm 
  mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc 
  nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq 
  pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse 
  pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev sev_es sha_ni 
  skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp 
  succor svm svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload 
  vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr 
  xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Micro-Star MSI 
  driver: nouveau v: kernel bus-ID: 26:00.0 chip-ID: 10de:1f06 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nouveau 
  alternate: fbdev,nv,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0") 
  s-diag: 1245mm (49") 
  Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  Monitor-2: DP-3 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2") 
  diag: 685mm (27") 
  OpenGL: renderer: NV166 v: 4.3 Mesa 21.0.3 direct render: Yes 
  Device-1: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 26:00.1 chip-ID: 10de:10f9 
  class-ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 28:00.4 chip-ID: 1022:1487 
  class-ID: 0403 
  Device-3: Blue Microphones Yeti Stereo Microphone type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:2 chip-ID: b58e:9e84 
  class-ID: 0300 serial: <filter> 
  Sound Server-1: ALSA v: k5.10.36-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.28 running: no 
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus-ID: 21:00.0 
  chip-ID: 8086:2526 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb 
  v: kernel port: f000 bus-ID: 22:00.0 chip-ID: 8086:1539 class-ID: 0200 
  IF: enp34s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  v: 0.8 bus-ID: 5-4:4 chip-ID: 8087:0025 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 465.76 GiB used: 109.06 GiB (23.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: 2B2QEXE7 temp: 29.9 C 
  scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 20 GiB size: 19.56 GiB (97.81%) used: 18.33 GiB (93.7%) 
  fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A 
  uuid: 88ec38db-9f99-4ff1-8f7a-41b7f1ec6589 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.2 MiB (26.2%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 2ACF-93D6 
  ID-3: /home raw-size: 236.29 GiB size: 231.58 GiB (98.01%) 
  used: 90.71 GiB (39.2%) fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8 
  label: N/A uuid: d1447f1e-654f-435c-9153-0b6e4472eb4e 
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p6 maj-min: 259:6 label: N/A 
  uuid: afd121e3-cca8-40fd-8535-3e241d39435c 
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 529 MiB fs: ntfs label: Recovery 
  uuid: 34DECF54DECF0CD4 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 206.34 GiB fs: ntfs label: N/A 
  uuid: 9C0CD0A00CD076AC 
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 512 MiB fs: vfat label: N/A 
  uuid: 1EB7-C94B 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Blue Microphones Yeti Stereo Microphone 
  type: Audio,HID driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 
  rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: b58e:9e84 class-ID: 0300 
  serial: <filter> 
  Device-2: 1-4:3 info: Holtek Keyboard type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  power: 100mA chip-ID: 04d9:2323 class-ID: 0301 
  Device-3: 1-8:4 info: Logitech G9x Laser Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 98mA 
  chip-ID: 046d:c066 class-ID: 0300 serial: <filter> 
  Device-4: 1-9:5 info: LazyDesigners THE50 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  power: 500mA chip-ID: feed:0050 class-ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 5-2:2 info: Wacom PTH-660 [Intuos Pro (M)] type: HID 
  driver: usbhid,wacom interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 500mA 
  chip-ID: 056a:0357 class-ID: 0300 serial: <filter> 
  Device-2: 5-3:3 info: Micro Star PRO CARBON type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  power: 500mA chip-ID: 1462:7b85 class-ID: 0300 serial: <filter> 
  Device-3: 5-4:4 info: Intel Wireless-AC 9260 Bluetooth Adapter 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 8087:0025 class-ID: e001 
  Hub-6: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 46.9 C mobo: 0 C gpu: nouveau temp: 25.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 887 
  Processes: 302 Uptime: 2d 20h 18m wakeups: 4 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 Packages: pacman: 1264 lib: 413 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.04 

You’ve got 2 audio sources and nVidia seems to be #1 .

Can you:

pamac install alsa-tools

and tell us what pins are connected to what in both nVidia and AMD?


Did that above and here’s a screenshot of the resulting hdaretask window:

That’s the realtek only. Can you change the Select a coded drop-down in the upper left corner to nVidia and give me that one too, please?


You should consider updating motherboard BIOS as it mentions a fix is included for audio
that might help resolve the intermittent problem on your system

Version - 7B85v1C
Release Date - 2020-06-15

  • Updated AMD AGESA ComboAm4PI
  • Fix HDMI audio lost issue when use AMD RX570 vga card.

If system is dual-boot with a Windows OS, audio devices might be affected by Fast Startup

Intermittent problem - sometimes no sound after boot

Most of the time I boot up and sound works fine, but less often when I boot into the system there is no sound and I have to reboot

  1. Are you dual-booting with Windows?
  2. Is the audio device missing after selecting ‘Restart’ from other OS, then booting to Manjaro?
  3. If ‘Shutdown’ is used to close other OS instead of ‘Restart’, is the audio device detected OK ?

If the answer to all 3 of those questions is yes, the problem is in Windows not Linux
the solution is to Turn Off Fast Startup in Windows 10


Here’s the Nvidia screenshot.

I do have dual boot but I do not have fast start enabled, iirc that was supposed to be disabled to get the system clocks to synchronize correctly so it’s never been enabled for me.

updating the mobo drivers is something I should do in the Windows side too right?

You have an UEFI system, so should just upgrade the firmware once: your choice Windows or Manjaro.

Try that first and then report back if that automagically solves your issue.

If it doesn’t check of the two screenshots you’ve posted are still the same and provide the textual output of the dropdown box of hdajackretask and please confirm you don’t get any input or output or both. (Original only mentions input)


I’ve updated the BIOS on my motherboard and now GRUB is bypassed and my system only boots into windows without the option to select Manjaro…that feels bad

I suppose I need to check my boot priorities but I can’t remember what the boot option is for GRUB

I tried to run CMD as admin and then input

bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi

it said operation completed successfully yet when I reboot it still goes straight to Windows. When I open the boot options in BIOS it only lists Windows boot manager as an option and I don’t see an option for GRUB

Urgh! Boot a Manjaro live USB and execute:

grub-install /dev/XdY

Where X and Y denominate your boot drive under Manjaro.


P.S. Never try a Windows solution on a Linux system (though the reverse may be true) :grin:

I guess it’s been too long since I’ve done something like this, I’m running into issues :sweat_smile:

I run lsblk and get

loop0         7:0    0  84.7M  1 loop /run/miso/sfs/livefs
loop1         7:1    0 395.7M  1 loop /run/miso/sfs/mhwdfs
loop2         7:2    0   1.2G  1 loop /run/miso/sfs/desktopfs
loop3         7:3    0 692.2M  1 loop /run/miso/sfs/rootfs
sda           8:0    1  57.8G  0 disk /run/miso/bootmnt
├─sda1        8:1    1   2.4G  0 part 
└─sda2        8:2    1     4M  0 part 
nvme0n1     259:0    0 465.8G  0 disk 
├─nvme0n1p1 259:1    0   529M  0 part 
├─nvme0n1p2 259:2    0   100M  0 part 
├─nvme0n1p3 259:3    0    16M  0 part 
├─nvme0n1p4 259:4    0 206.3G  0 part 
├─nvme0n1p5 259:5    0   512M  0 part 
├─nvme0n1p6 259:6    0     2G  0 part 
├─nvme0n1p7 259:7    0    20G  0 part 
└─nvme0n1p8 259:8    0 236.3G  0 part 

512 is the right size for my boot partition, so I tried grub-install /dev/nvme0n1p5 but that gives an error:

Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

The correct way is: grub-install device not grub-install partition so execute:

grub-install /dev/nvme0n1


I get the same error with that:

[manjaro@manjaro Desktop]$ grub-install /dev/nvme0n1
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.


Try this:


when I get to the step of
manjaro-chroot -a
I get
bash: manjaro-chroot: command not found

another curious thing I just realized is that when I entered super user there was no username/password check

[manjaro@manjaro Desktop]$ su
[manjaro Desktop]#

Once you get back into a working system, try this:

  1. Stop pulseaudio service with,

systemctl --user stop pulseaudio.service

  1. Remove everything under ~/.config/pulse/

  2. Edit /etc/pulse/client.conf and change it to,

autospawn = yes

  1. Start pulseaudio service with,

systemctl --user start pulseaudio.service

  1. (Optionally) Reboot your computer

That’s normal behavior for a live USB session. It’s not really anyone’s personal system, thus no need for passphrase protection.

1 Like

Will do when I get there, trying to follow the GRUB/restore the GRUB guide. This time
manjaro-chroot -a
gave the output

grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
==> Mounting (ManjaroLinux) [/dev/nvme0n1p7]
 --> mount: [/mnt]
mount: /mnt: /dev/nvme0n1p7 already mounted on /mnt.
 --> mount: [/mnt/boot/efi]
mount: /mnt/boot/efi: /dev/nvme0n1p2 already mounted on /mnt/boot/efi.

and so I went to check my /etc/fstab and it looks like that file somehow was overwritten in the Windows update? At least it doesn’t list all the partitions it should. Here is what I see:

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=2ACF-93D6                            /boot/efi      vfat    umask=0077 0 2
UUID=88ec38db-9f99-4ff1-8f7a-41b7f1ec6589 /              ext4    defaults,noatime 0 1
UUID=d1447f1e-654f-435c-9153-0b6e4472eb4e /home ext4 defaults,noatime 0 2
UUID=afd121e3-cca8-40fd-8535-3e241d39435c none swap defaults 0 0

should I continue with the grub re-install?

Also, dumb question, but once this is done what is the command to unmount all before rebooting? Or can I just reboot and see if I get to GRUB?