Protonvpn not working

I was on Gnome few months ago. Now on Plasma, installed Protonvpn when I log in it says network error. Same thing when I launch it on Terminal. Tried restarting/reinstalling didn’t work and the software itself isn’t down because it’s working on other devices. Idk if it was a Plasma problem or not. I need this vpn. Any help is appreciated.

I am using protonvpn - I have no issues.

  Host: tiger Kernel: 6.3.4-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.5 Distro: Manjaro Linux

Then why is it not working for me? My kernel is the default lts 6.1 don’t know if it matters

I have no idea … did you build the right package?

pamac build protonvpn

Yes it’s the right package

 $ protonvpn-cli c nl-free#158001
Setting up Proton VPN.
Connecting to Proton VPN on NL-FREE#158001 with UDP.

Successfully connected to Proton VPN.

I can’t even login to try to connect. Network error pops up after i press login

Syncing your system without restarting - may cause such issues.

Would please explain?


Tried that Same issue

Impossible to say …

Damn… What to do then?

If it’s just connection problem you can try to change your kill switch status.

It’s me again. If you experience problem with ProtonVPN since next update, I’ a procedure to resolve python break.
Requirements: use Python3 and pip
Try :slight_smile: pacman -Qmq $(pacman -Qoq /usr/lib/python3.${OLD}/site-packages) > AUR_pkgs_to_reinstall.txt
open the file AUR_pkgs_to_reinstall.txt with pluma or an other editor
Open a terminal
fror every line in the text file, run “yay -i line in text file”
When yay ask whish number, choose 1 [ENTER]
Line concerning protonVPN and some importants others are:

That’s it

1 Like

Hello thanks for trying to help but I’ve sadly returned to Windows, and protonvpn works there smoothly. I wish I can go back to Manjaro but currently with all the files I have it’s nearly impossible to backup and try your solution but I appreciate your help.

Hello, I’m having a similar problem and tried this. Everything went through fine but then I tried to open protonvpn up again I’m greeted with

Traceback (most recent call last):
  File "/usr/lib/python3.11/site-packages/protonvpn_gui/", line 262, in do_activate
    if not protonvpn.check_session_exists():
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/", line 356, in check_session_exists
    return self._env.api_session.is_valid
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/", line 56, in api_session
    self.__api_session = APISession()
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/session/", line 252, in __init__
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/session/", line 273, in __session_create
    self.__proton_api = Session(
TypeError: Session.__init__() got an unexpected keyword argument 'log_dir_path'

If you cannot make protonVPN work it is caused by some system incompatibility or a system not properly updated.

ProtonVPN is installed using AUR and AUR is unsupported using Manjaro as well as Arch.

The issue may be caused as AUR buildscripts expects Arch package level - which is NOT possible using Manjaro stable branch.

pacman-mirrors -G

If you get stable then uninstall protonvpn

sudo pacman -Rns protonvpn

And switch to unstable and run a full system sync.

sudo pacman-mirrors -aS unstable && sudo pacman -Syyu

Then build protonvpn

pamac build protonvpn

Finally you can connect using the command line

 $ protonvpn-cli c nl-free#142056
Setting up Proton VPN.
Connecting to Proton VPN on NL-FREE#142056 with UDP.

Successfully connected to Proton VPN.

Or you can launch the GUI from your system’s app launcher panel


But the thing is even if AUR was unsupported, it used to work flawlessly few months ago. What happened now?

And it still do …

I don’t know - I have never had issues with protonvpn - used them for years - I have an account with ProtonVPN you cannot subscribe to anymore - Visionary - they called it - I host my mail, drive and use their VPN with no issues.

But as mentioned - it is likely a discrepancy between Manjaro stable and Arch causing it.

Packages build from AUR are likely to get issues on Manjaro updates - this is quite normal for AUR packages - there is no guarantee they work with precisely your system and if they work - there is no guarantee the will continue to do so.

Mainteance of custom packages is the reponsibility of the owner.

The availablility of AUR, Flatpak and Snap does not imply Manjaro Linux distribution is reponsible when they cease to function or errors out.

I’ve tried live Pop OS from USB and the same problem happens. I want to have Manjaro so badly. But ProtonVPN is a deal breaker. It used to work few months ago. Idk what happened. Now it’s only working on Windows. It’s the very same internet connection that I’ve always had