Protonvpn not working

You see the problem - right?

I am using Manjaro Plasma on unstable branch - and ProtonVPN works - as can be seen from above comments - it worked at the time of your original topic and it works now.

Without hands-on it is impossible for me to know - especially when it works on my Manjaro systems and then only general recommendations can be provided.

Your internet connection has nothing to do with your issue.

No matter how I test this issue - I simply cannot reproduce it.

This is from a fully updated as of 2023-06-10T14:45:00Z default Manjaro installation running in a VirtualBox VM - and it proves without a shadow of doubt that whatever issue you have it is local.

 $ pacman-mirrors -G
$ inxi -S
  Host: lxqt Kernel: 6.1.31-2-MANJARO arch: x86_64 bits: 64 Desktop: LXQt
    v: 1.3.0 Distro: Manjaro Linux
 $ pamac build protonvpn
Cloning protonvpn build files...
Generating protonvpn information...
Building protonvpn...
==> Making package: protonvpn 1.0.0-3 (lør 10 jun 2023 16:45:19 CEST)
==> Finished making: protonvpn 1.0.0-3 (lør 10 jun 2023 16:45:20 CEST)
==> Cleaning up...

Checking keyring...                                                   [1/1]
Checking integrity...                                                 [1/1]
Loading packages files...                                             [1/1]
Checking file conflicts...                                            [1/1]
Checking available disk space...                                      [1/1]
Installing protonvpn (1.0.0-3)...                                     [1/1]
Transaction successfully finished.
 $ protonvpn-cli login yourusername
Enter your Proton VPN password: 

Successful login.
 $ protonvpn-cli c nl-free#142056
Setting up Proton VPN.
Connecting to Proton VPN on NL-FREE#142056 with UDP.

Successfully connected to Proton VPN.

How the hell can I fix this? I don’t want to stay on Windows, it’s not very bad but Manjaro is just… better!

You do understand that I cannot possibly guess what your issue is - right?

There is nothing to fix … it works!

I have proven to you threes times - it works - last time using stable branch.

We have

  • documentation that ProtonVPN is not at fault
  • documentaton that Manjaro stable branch is not at fault

We also have these very vague sentences

What we do not have

  • evidence other than your word
  • relevant logs
  • network configuration information when the error surface
    • cat /etc/resolv.conf
  • a backdoor so the system can be inspected remotely

What we have left

  • ???

I understand that. I’m just a bit frustrated and I appreciate the help.

Protonvpn is heavily python dependent. If your system is more than a month old, chances are you installed/built proton on python 3.10. And then the upgrade to 3.11 happened and all aur python packages have to be rebuild. As suggested in the post of @tuxdata and in different topics in the announcements and wiki.

p.s. proton works on my system. New install with python 3.11 and xfce.

Відповідь для тих кому просто потрібний стабільний VPN, а не додаток.

В мене була схожа проблема. Я не зрозумів в чому річ. Жодної помилки. А з’єднання або не встановлювалось, або було нестабільним.

Тому я просто зайшов на сайт ProtonVPN і завантажив їх конфігураційний файл для OpenVPN. Там також є конфігурація для WireGuard (але я її не перевіряв). Цей метод працює стабільно.

У випадку з OpenVPN необхідно просто завантажити конфігураційний файл і імпортувати його за допомогою NetworkManager.

Thank you very much. Neat idea, but unfortunately does not work - both at cli and gui version it tells wrong password (i am inserting the long special password as per instructions here - How to manually configure OpenVPN in Linux - Proton VPN Support )

Hello Teo, I also use kde plasma and protonvpn and everything works fine for me. Maybe this will help you. My system is up to date

The dependency tree for protonvpn looks like this
  • protonvpn
    • protnvpn-cli
      • python-protonvpn-nm-lib
        • python-pythondialog
        • python-proton-client
        • networkmanager
        • networkmanager-openvpn
        • openvpn libnm
        • dbus
        • libsecret
        • python-pyxdg
        • python-keyring
        • python-jinja
        • python-distro
        • python-dbus
        • python-systemd
        • xdg-utils
        • python-gobject
    • protonvpn-gui
      • python-protonvpn-nm-lib
      • python-gobject
      • python-psutil
      • gtk3
      • python-cairo
      • webkit2gtk

I thinking out load here - just writing my thoughts down.

I cannot reproduce - so the question I am asking myself:

What sets my system apart from yours

My systems do not throw the message - network error - which leads us to investigate your network.

Please use this [root tip] [How To] Basic network know-how and troubleshooting to investigate your network.

That proves my previous point - that is has nothing to do with Manjaro as operating system.

But if the same hardware - a laptop? - with different operating system exhitibs the same symptoms - then it has to be something hardware related - probably your wifi card.

So please provide some system information - the textual output (no screenshots, no photos, thank you) but the link provided by the following command - inxi is creating some sysinfo and curl sends the output to to which is a pastebin service

inxi -F | curl -F 'f:1=<-'

This actually fixed my issue so thanks!

1 Like

I am pleased you were able to fix your issue :+1: