Programs not showing in taskbar after update

Symptoms summary:
After a recent(ish) update, I’m experiencing some weird issues with my KDE taskbar. So far, the problems I’ve identified are:

  1. Open programs/windows are not showing
  2. Pinned applications/shortcuts are not present
  3. The widget for switching virtual desktops is missing.
  4. While it’s unrelated to the topic, I noticed while writing this post that spectacle is no longer working. I can’t take a screenshot, because the app opens but doesn’t display or capture any desktop image.

This started after updates I installed this past weekend. Unfortunately, I’ve been lazy and hadn’t installed updates for a couple months, so I’m not sure exactly which batch of updates were responsible. That said, I definitely experienced issues with the DBus transition. Immediately after the update, I was unable to log in to my computer after a reboot, because after entering my password, KDE would try to start, then hit a black screen and return me to the login prompt. I solved this by removing dbus-broker-units and reinstalling dbus-daemon-units. I also noticed some severe lag during system startup after resolving that, however it seems to have resolved itself after I did my best to ensure broker-related stuff was cleaned up.

Things I’ve tried:

  • I’ve removed .config, by renaming it to .config.bak.
  • I’ve reset the global theme back to default using the “Defaults” button under Appearance > Global Theme.
  • I’ve run kbuildsycoca5 --noincremental
  • I’ve created a new user and logged in to see if the issue is present there: It IS PRESENT for the new user, too.

Additional info:

~ > uname -r     
~ > kded5 --version 
kded5 5.115.0
~ > plasmashell --version
plasmashell 5.27.11