Problems with wine

Wine open exe files, but when i try to make any installation, it doesn’t work, for example, i tried the Photoshop installation, it opens but when come to the final part of loading the installation, nothing happens, i downloaded a game for example and opened the .exe file and i could play with no problems, it really is a problem only when comes to install something.

Everything or just Photoshop?

Also I do not recommend to install Windows executable directly by double clicking them, use a tool like Lutris to manage each application in its own WINE prefix, this way you can make required customization for each application without creating issues for other applications.

Lutris has some installation script for various Adobe product, and if there is none for the application you want to install then you can still install the application through Lutris anyway. Also Lutris provides modified WINE with lot of improvements.

This problem is happening with everything, so, suddenly now the installations are working but, not properly. For example the photoshop when comes to 99% gives an error and the report is this:

 Exit Code: 7
Please see specific errors below for troubleshooting. For example,  ERROR: DF016 ...
-------------------------------------- Summary --------------------------------------
 - 0 fatal error(s), 3 error(s) 
----------- Payload: Adobe Preview CC {A3B6E381-F2E8-47CD-87B4-96B1E3FF61D3} -----------
ERROR: DF016: Cannot create directory at 'Z:\adobeTemp\{A3B6E381-F2E8-47CD-87B4-96B1E3FF61D3}' for asset extraction. Error: 5. Try setting correct permissions to the specified file/folder or parent folder, so that admin has rights to modify it.
----------- Payload: Export Assets 2 (64 bit) {27375F7C-0789-4FEA-889E-41BF12AC3140} -----------
ERROR: DF016: Cannot create directory at 'Z:\adobeTemp\{27375F7C-0789-4FEA-889E-41BF12AC3140}' for asset extraction. Error: 5. Try setting correct permissions to the specified file/folder or parent folder, so that admin has rights to modify it.
----------- Payload: Adobe Photoshop CC 2015 Core {793C2BF7-A4FE-4608-91C9-9282C5801C21} -----------
ERROR: DF016: Cannot create directory at 'Z:\adobeTemp\{793C2BF7-A4FE-4608-91C9-9282C5801C21}' for asset extraction. Error: 5. Try setting correct permissions to the >specified file/folder or parent folder, so that admin has rights to modify it.

And i tried another program LDPlayer and occurs the same situation, when comes to the final part of installation, error, and this is the message:

Unhandled exception: 0xc0000417 in 32-bit code (0x7b010f96).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:7b010f96 ESP:0033b3b4 EBP:0033b428 EFLAGS:00000246(   - --  I  Z- -P- )
 EAX:0033b3c0 EBX:00000001 ECX:0033b440 EDX:00000000
 ESI:c0000417 EDI:00000000
Stack dump:
0x0033b3b4:  002b002b 00000084 00000018 c0000417
0x0033b3c4:  00000001 00000000 7b010f96 00000000
0x0033b3d4:  00000000 00000000 00000000 00000000
0x0033b3e4:  00000000 0033b410 00000020 00008000
0x0033b3f4:  0089428c 0033b428 6737417f 00424f18
0x0033b404:  00190cd0 0033b428 67374189 00190cd0
=>0 0x7b010f96 EntryPoint+0xffffffff() in kernelbase (0x0033b428)
  1 0x6735c52e $I10_OUTPUT+0x14ab() in msvcr120 (0x0033b498)
  2 0x673a7be4 $I10_OUTPUT+0x4cb61() in msvcr120 (0x00894870)
  3 0x00090020 (0x00200020)
0x7b010f96 EntryPoint+0xffffffff in kernelbase: subl	$4,%esp
Module	Address			Debug info	Name (28 modules)
PE	  400000-  438000	Deferred        bugreport
PE	61740000-61782000	Deferred        advapi32
PE	61940000-619cc000	Deferred        wininet
PE	62fc0000-6304f000	Deferred        rpcrt4
PE	63480000-6348c000	Deferred        version
PE	63bc0000-63bd9000	Deferred        shcore
PE	64640000-646b1000	Deferred        msvcp120
PE	64a40000-64a95000	Deferred        shlwapi
PE	64ec0000-64fec000	Deferred        oleaut32
PE	67340000-6742e000	Export          msvcr120
PE	67840000-6784a000	Deferred        psapi
PE	68500000-6855a000	Deferred        combase
PE	68700000-6872e000	Deferred        uxtheme
PE	6a400000-6a531000	Deferred        ole32
PE	6bc00000-6bc2b000	Deferred        sechost
PE	6bcc0000-6bd3e000	Deferred        setupapi
PE	6c9c0000-6cb1e000	Deferred        gdi32
PE	6cc40000-6cda8000	Deferred        comctl32
PE	6ed00000-6ef1b000	Deferred        user32
PE	70940000-70960000	Deferred        mpr
PE	70b40000-70c12000	Deferred        ucrtbase
PE	71200000-7121b000	Deferred        imm32
PE	7b000000-7b0e7000	Dwarf           kernelbase
PE	7b600000-7b81a000	Deferred        kernel32
PE	7bc00000-7bca0000	Deferred        ntdll
PE	7d990000-7d994000	Deferred        winex11
PE	7df90000-7df94000	Deferred        ws2_32
PE	7dfe0000-7e8b7000	Deferred        shell32
process  tid      prio (all id:s are in hex)
00000038 services.exe
	0000003c    0
	00000040    0
	0000004c    0
	00000070    0
	00000088    0
	00000094    0
	000000b4    0
	000000d4    0
00000044 winedevice.exe
	00000048    0
	00000054    0
	00000058    0
	0000005c    0
00000060 plugplay.exe
	00000064    0
	00000074    0
	00000078    0
	0000007c    0
	0000009c    0
00000068 explorer.exe
	0000006c    0
	000000c0    0
	000000c4    0
00000080 winedevice.exe
	00000084    0
	0000008c    0
	00000090    0
	00000098    0
	000000a4    0
	000000a8    0
000000ac svchost.exe
	000000b0    0
	000000b8    0
	000000bc    0
000000cc rpcss.exe
	000000d0    0
	000000dc    0
	000000e0    0
	000000e4    0
	000000e8    0
	000000ec    0
0000033c AdobeIPCBroker.exe
	00000340    0
	00000344    0
	00000348    0
00000378 BlueStacks-Installer_4.280.0.1022_amd64_native.exe
	0000037c    0
00000388 Bootstrapper.exe
	0000038c    0
	00000390    0
	00000394    0
00000398 BlueStacksInstaller.exe
	0000039c    0
	000003a0    0
	000003a4    0
	000003a8    0
	000003ac    0
	000003b4    0
	000003b8    0
	000003bc    0
	000003c0    0
	000003c8    0
	000003cc    0
	000003d0    0
	000003d4    0
00000408 LDPlayer4_ens_3020_ld.exe
	0000040c    0
	00000410    0
	00000414    0
	00000418    0
	0000041c    0
	00000424    0
	00000428    0
	00000464    0
	00000468    0
000004ac LDPlayer.exe
	000004b0    0
	000004b4    0
	000004b8    0
	000004bc    0
	000004c0    0
	000005d4    0
	000005e8    0
	000005ec    0
00000600 dnrepairer.exe
	00000604    0
	00000608    0
0000060c (D) Z:\home\jibbu\LDPlayer\LDPlayer4.0\bugreport.exe
	00000610    0 <==
	0000061c    0
System information:
    Wine build: wine-6.4
    Platform: i386 (WOW64)
    Version: Windows 7
    Host system: Linux
    Host version: 5.10.23-1-MANJARO

Stable Update is expected to drop today. Wine will be updated to 6.5-2. Maybe that will fix your issue.
That being said, I had an issue with Wine 6.5x here where I could not launch small program (Quickpar) from Thunar, though it worked in terminal. The solution was copying start.exe from the command folder from ~/.wine/drive_c/windows/command
to ~/.wine/drive_c/windows/
in your .wine config folder.

cp -a ~/.wine/drive_c/windows/command/start.exe ~/.wine/drive_c/windows/

Please format your message output properly with the </> button, or with three backticks ` above and below it!

1 Like

My wine is 6.5.2 now, and the .exe’s aren’t opening anymore

6.6-1 was released to Unstable today. Did you try as I outlined above? They claim it is fixed in 6.6

With 6.6-1 i can open .exes again but installations still having problems.
I did:

cp -a ~/.wine/drive_c/windows/command/start.exe ~/.wine/drive_c/windows/

this ?

Nothing seems to work in WINE!
Opening from menu where they used to work or from command line both show wine processes in System Activity but no windows appear.
Work around in this post Problems with wine - #4 by jrichard326 also doesn’t help.
Hope it gets fixed soon.

Suddenly all started working, so i’m gonna finish this theard

Hi all,
I could successfully run the programs installed under wine 6.5 but no other executable programs so I followed @jrichard326 guidelines and now I can load executable windos programs.
cp -a ~/.wine/drive_c/windows/command/start.exe ~/.wine/drive_c/windows/
Thank you :grinning:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.