Problems with Pipewire

Hi there ! first of all thaks for your wonderful work, i have been using manjaro for 3 years now without any big trouble.

But now i am very confuserd !!! Pipewire was a big unbeaten challenge that broke my ability to reccord live streamings from zoom (distance learning courses i applied to) that i used to get in audacity through pavucontrol reccording tabs’s “monitor of pluse…”

Then, this new so called “satble release” broke all the sound functions of the OS !! sound icon don’t even appear in the notification / monitor bar, neither any sound line is displayed in the gnome parameter settings.

More : i tried a full reinstall with live usb key : most of time, manjaro is not able to log in user’s session (locked in grey screen with mousse arrow alone). Tried several tmes, it worked one, but then blocked again on reboot !!!

I’m using Dell G3 computer.

Fortunately, i have installled 3 parallel manjaro systems on the samme boot so i can manage troubles, but not just one left for working, trying new (04.16) update, i’ll try a reboot.

Please i have a next course in one week, so i’d like to get sound working well.
Thanks and take good care of yourself.

1 Like

Hello :slightly_smiling_face:!
Recent Pipewire Updates in Arch Linux have been causing trouble by requireing a new configuration.
However, pacman tends to not update that config by itself, whereby it completely breaks PipeWire…

Note for Maintainers: Not overwriting config files by default is indeed a good strategy in theory - but in this case, it has lead to breakage in practice. Using .pacsave instead of .pacnew would have been a far better solution here.

Essentially, what you need to do is to check for any .pacnew config files in the folders /etc/pipewire/ and /etc/pipewire/media-session.d/. If you find any, rename the original versions of the affected config files to e.g. .old files and remove the .pacnew extension from the .pacnew files.

Additionally, run the following command as user to make sure all necessary PipeWire services are enabled for your user:

systemctl --user enable pipewire pipewire-pulse pipewire-media-session

After this, make sure to reboot your system. If the problem persists, feel free to reply.


Or you could enable and start the services in one go and there’s no need to reboot. :wink:

systemctl --user enable --now pipewire pipewire-pulse pipewire-media-session
1 Like

I was having the same problem with no audio and no input or output devices showing up since the last update. Renaming the .conf files seems to have fixed it for me. Time will tell, lol.

1 Like

Thanks for your answers… i’ll try this on the damaged main system.

Now i was reinstalling from scratch on a parallel system with latest .2 manjaro version and… AUR was blocked ans i cannot install printers to manage my business. So much bad luck with manjaro theses days, and my phone bricked suddenly also. Need a break with computers ??? :slight_smile:

Sure you can. If pamac isn’t working just use another AUR helper or go and install manually.

1 Like