Problems with new Manjaro update and nvidia

Like some other users I have problems with nvidia drivers and the new Manjaro update.
I was so lucky that I can boot the system as always, mhwd don´t show any nvidia drivers installed, but I can use my previously installed drivers 430xx which for some reason are installed from AUR repositories by Manjaro Kernel Manager.
So the situation right now is: I have aparently no drivers installed, but I have nvidia utils installed from AUR and I can see that I´m using nvidia drivers 430xx right now, but some applications don´t detect it (I need opencl in some apps and they show me a “no gpu acceleration available”) warning.
I currently have this packages installed related to nvidia:

What should I do? I tried the instructions here [Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1
And tried
sudo mhwd -a pci nonfree 0300
but it says
:: nvidia-utils and nvidia-430xx-utils are in conflict
so I tried to uninstall nvidia-430xx-utils from TTY and it says this:

So apparently I have to delete all the linux-nvidia packages, which are the kernels and so I have to delete all the kernels to update the nvidia drivers which has no sense at all. I am using kernel 5.4 right now, and I tried booting 5.10 and it says that it can´t start a graphical session.
What should I do? help me please.


I just, as in not 10 minutes ago, had this exact same thing. The installation and packages for nvidia have changed, quite onviously.

In my case, and I’d suspect your case something similar would be necessary, I had to remove the conflicting packages so that the nvidia utils packages can be removed, and then replaced by nvidia-utils:

sudo pacman -R nvidia-455xx-utils
sudo pacman -R lib32-nvidia-utils
sudo pacman -R linux54-nvidia-455xx
sudo pacman -S nvidia-utils
sudo pacman -S linux510-nvidia
sudo reboot

After which, I reinstalled the driver with mhwd:

sudo mhwd -l
sudo mhwd -i video-nvidia

Or so I think.

Anyway, that’s the gist of it, if not the exact steps.

I hope this helps.


But as I said I can´t remove any nvidia-utils packages without uninstalling linux-nvidia packages, which are the kernels and would leave me with no system I think.

1 Like

I had that worry myself.
But I took a chance and it seems as long as you don’t reboot between removing and installing packages, I was OK, so you should be as well. At least in theory.

Yes as long as you don’t reboot in-between removing and installing the new drivers your fine

And why

and not
sudo mhwd -a pci nonfree 0300
or is it the same?

Oh nevermind, it worked. I could not use

sudo mhwd -i video-nvidia
so I used
sudo mhwd -a pci nonfree 0300
and it installed me nvidia-prime, which I don´t need because I´m not using a laptop but it´s ok, it works.
Thank you so much.

My mistake, apologies.

It should have been:

sudo mhwd -i pci video-nvidia

But I’m glad you managed!

1 Like

Here is my journey and how i fixed it: My switch to the 5.10 kernel with update 2020-12-30

did you also updated your kernel that you chose


in my case i have linux59-nvidia but there is what appears to be a new 59 in the repos.

Now that you mention it, it does seem familiar. I can’t remember specifically, but it DOES look very familiar…

Sorry that’s all I can give with honesty.

also,why didn’t you install the


after uninstalling it?

Because it conflicted with the nvidia-utils package. I’m guessing that’s the new ‘name’ for the package. Or something.

1 Like

Looks like a huge hassle… :worried: not sure I will update my laptop with hybrid nvidia for a while.

Edits: everything with more than two steps I consider a huge hassle :joy:

I had the same issue and black screen.

I posted solution already in main message:

Hello Phil,

I had issues with my Ti1080 Nvidia drivers. Got black screen.
sudo mhwd -r pci video-nvidia

and after just following your normal installation:
sudo pacman -S linux-latest

Happy New Year


1 Like

That seems like a very odd ‘solution’.

You removed nvidia and installed the umbrella ‘latest kernel’ package …
So … uhm … you didnt have a good working kernel?
And you dont need or want nvidia?

Seems more to me that you took a chainsaw to your situation and it happens to boot … likely by using generic fallback drivers.

(which honestly is surprising on a 1080 … I didnt think nouveau worked … maybe more likely is you have an optimus or dual-gpu setup ? - meaning the nvidia-only driver should not have been used, but now that its gone you are relying on the [intel?] iGPU)

yes, I think it is a simple fallback solution. But it does work.
Next steps are straightforward: remove old (if any) conflicted nvidia driver. In my case (Ti1080):

:: nvidia-utils and nvidia-455xx-utils are in conflict (nvidia-libgl). Remove nvidia-455xx-utils? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

sudo pacman -R nvidia-455xx-utils
sudo mhwd -a pci nonfree 0300

looking for conflicting packages…

Packages (3) lib32-nvidia-utils-455.45.01-3 linux510-nvidia-455.45.01-8 nvidia-utils-455.45.01-2

Total Download Size: 132,18 MiB
Total Installed Size: 452,94 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages…
downloading nvidia-utils-455.45.01-2-x86_64.pkg.tar.zst…
downloading linux510-nvidia-455.45.01-8-x86_64.pkg.tar.zst…
checking keyring…
checking package integrity…

(6/6) Updating the desktop file MIME type cache…
nvidia-utils: install reason has been set to ‘explicitly installed’
lib32-nvidia-utils: install reason has been set to ‘explicitly installed’
linux510-nvidia: install reason has been set to ‘explicitly installed’
xorg configuration file: ‘/etc/X11/mhwd.d/nvidia.conf’

Successfully installed video-nvidia

So, summarizing:

  1. solution for black screen (CTRL+ALT+F2):
    sudo mhwd -r pci video-nvidia
    sudo pacman -S linux-latest
    sudo pacman -Syyu

  2. Login in the GUI and resolve the other issues:
    sudo pacman -R nvidia-455xx-utils
    sudo mhwd -a pci nonfree 0300

Nouveau works but “no acceleration” :wink:

Sorry, saw it just now.
Yes, I decided to upgrade my kernel while I was at it.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.