Problems with dbus and xdg-desktop-portal

Hello !

Journalctl tells me xdg-desktop-portal has problem to launch itself.

systemctl status xdg-destop-portal says that xdg-desktop-portal.service doesn’t exist, but this file is in /usr/lib/systemd/user/.

When I try to launch xdg-desktop-portal manualy I have an error :

error: No session bus: Erreur lors de la génération de la ligne de commande « dbus-launch --autolaunch=8806d4a418894779becc56479dc0b204 --binary-syntax --close-stderr » : Le processus fils s’est terminé avec le code 1

So I asked systemctl for the status of dbus and everything seems to be ok. When I launch d-feet there’s no session bus.

So I tried to restart dbus and it seems that it was not a good idea: the system crashed…

I have searched the web for hints with no success. Do you have an idea of what append ?

really? searched and found nothing?

1 Like

It’s seems not to be a backend problem since xdg-desktop-portal doesn’t succeed to launch itself at boot time. And as far as I understand, xdg-desktop-portal-gtk needs xdg-desktop-portal.

I do think there is a problem with dbus session…

systemctl --user status xdg-desktop-portal.service

It may not provide much more information than you have already received from journalctl.

There is two kinds of systemd services

  • system service
  • user services

The first requires administrative privileges to handle - the second is handled by user - and located in the user subtree of systemd.

Depending on your environment - you should ensure the correct package is installed as per @Lila-Kuh comment.

systemctl --user status xdg-desktop-portal.service

Here’s the result:

# systemctl --user status xdg-desktop-portal.service
Failed to connect to bus: Aucun médium trouvé

I’ve found a tip on at the Pipewire page:

Note: xdg-desktop-portal 1.10.0 fixed a mismatch between specification and implementation of its D-Bus interface. [2] Hence, some clients may not work with xdg-desktop-portal 1.10.0 or newer.

So I downgraded xdg-desktop-portal to the 1.8 version. But there’s still the same problem at boot:

Can’t find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?

I also notice that when I run d-feet as a a simple user I have no session bus, only a system bus.

What does journalctl --user-unit dbus.service -e say?

It says nothing: No entries

Ok, I think I’ve understood what happened.

I used to work on my Manjaro via SSH since the laptop is behind the TV…

I have found a tip on another forum : set the UsePAM in sshd_config variable to yes… and now I have a dbus session. I also can restart xdg-desktop-portal while in user mode.

After a reboot, I don’t have a xdg-desktop-portal error in the journalctl and the system seems to be a little more reactive.

Tanks for helping!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.