Problems printing with HP Printers and possible solution

Since the updates at 2023-12-10 my HP Laserjet Professional 1102w stopped working.
The printer can be connected through USB or wireless.
I had it twice installed, once for printing over USB, once for wireless printing over network.

At properties - statuswindow cffilter completed without no errors, just the Printer did nothing.
Sometimes the diagnosis window from cups showed up, but after the steps until you can pick the printer did not much more happen, as that i had to close the window at x. Not very helpful too.

Now found that post from 2020, where it says to activate AUR and build hplip-plugin.

So i did activate AUR, did a
pamac build hplip-plugin
but still no success, that one printer will work.

then deleted the USB Printer, but kept the Wireless, just to see what happens.

Now a hp-setup -i or hp-setup -u
did choose here “install printer over USB”, it did run through, and then asked my to install the Hp-plugin from her site. I choose yes, it downloaded it at the second attempt from HP-Devs, it did get installed,
and i did for safety another
systemctl restart cups.service
now i had my USB Printer and it also worked via wireless.

Not sure, why that is, that i have first to install the plugin from AUR, then again the one what HP offers.
And seems, its the combination of both, what makes it work.