Problem with Thunar accessing Samba shares

Hello everyone!

I have an issue that’s been busting my head for three days now. I see it’s not uncommon but none of the solutions for similar problems worked for me. At least not anymore, because it was working like charm, until it didn’t anymore (I have no idea how what I did to break it). I even tried clean reinstall but never was able to make it work again.

Anyway, I have NTFS formatted USB HD connected to my RT-AC87U Wi-Fi router that I use as network storage. I cannot access it from my Thunar’s network tab for the life of it. I see the list of shares, get authentication window when I try accessing one, but when I enter details, it just shows the window again (as if the authentication details are wrong).

Since the router only supports SMBv1, I did change client min protocol to NT1. Here is my smb.conf (except client min protocol and client use spnego I didn’t touch anything that got created after installing thunar-shares-plugin-gtk3 package), since seems all boils down to it:

   workgroup = WORKGROUP
   dns proxy = no
   log file = /var/log/samba/%m.log
   max log size = 1000
   client min protocol = NT1
   client use spnego = no
   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
   pam password change = yes
   map to guest = Bad Password
   usershare allow guests = yes
   name resolve order = lmhosts bcast host wins
   security = user
   guest account = nobody
   usershare path = /var/lib/samba/usershare
   usershare max shares = 100
   usershare owner only = yes
   force create mode = 0070
   force directory mode = 0070

   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0700
   directory mask = 0700
   valid users = %S

   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

I can access everything with smbclient and cifs just fine, btw.

Thank you in advance for taking a look at it, if you need some additional info I’ll be happy to provide it as soon as I can!

The thunar-shares-* plugin is for sharing a folder on your local system - not for accessing shares on remote system.

Issues with accessing shares are often caused when using system auto login. With autologin - your keyring is not unlocked and applications may fail silently when they cannot access the keyring.

What happens if you specify the SMB protocol in Thunar address line?


Thanks a lot for taking your time to try helping!

I did try without thunar-shares-* too…

What can I do about it? :slight_smile: Or what could I have done to screw it up, because it was working fine?

Same thing, once I enter smb://router-ip/sharename and hit enter, I get authentication window that behaves the same…

If you are using auto login - disable and try again.

I have to ask some strange questions - but …
Strange - but not immediately reproducable - have you updated your system without restarting? That is another common source of network related issues.

If you have not need for running a samba share on the workstation you are using - I suggest you try removing the thunar-share package.

Then remove or edit the /etc/samba/smb.conf - to only contain

   workgroup = WORKGROUP
   client min protocol = NT1

Just to be sure, though i am not sure about it, isn’t it mandatory to “enable volume management” within Thunar ? (Edit → Preferences → Advanced)

I haven’t thought of that - try both states - see what happens.

There is something with relation to this the network browse feature - but I simply can’t remember what it is.

Could you check if you have gvfs-smb installed. You should have it if it was working before but…
Also, you could install seahorse to check your keyring if you do not want to do it with CLI (as me :slight_smile: )

   comment = Home Directories
   browseable = no

And if you change browseable to yes ?

If you are talking about system auto login after boot, I don’t use it, never have. I doubt it’s related, but my Chrome browser always asks another password confirmation, says it’s keyring is not unlocked or something like that.

Please do ask anything, but expect some strange answers too, because I’m quite new to Linux and even more new to Manjaro :slight_smile:

I don’t remember updating system without restarting, specially when updating asked for restart afterwards…

Tried it, the problem persists…

Thanks for trying to help! It was enabled. Same thing when I disable it too…

What do you have in your keyring ?
Is it enable at startup ?

Mine is disable

I installed Seahorse, but I have no idea what I’m supposed to be looking, unfortunately…
Under Login tab I only have Chrome Safe Storage and Chrome Safe Storage Control…

But this did ring a bell, one thing that I did similar to this is enabling SSH for GitHub, and I was starting this SSH agent, because the tutorial said I’m supposed too.

How do I access options from your ss?

EDIT: Found the options, they are same as yours.

Sorry, what does “ss” mean ? :slight_smile:

If you do not see anything related to your samba share in seahorse, then, here is the issue.
You should have your samba credentials there.
Check if it’s enable at startup : Settings → Session and Startup : check anything related to “Gnome Keyring”.
Then reboot

So you have to check the boxes related to gnome keyring, reboot

ss = screenshot, sorry about that.

I did check those three options before the last, but after reboot nothing is changed, still doesn’t accept entered authentication. Seahorse still doesn’t show anything samba related though…

I found this in the arch wiki :


Passwords are not remembered

If you get a password prompt every time you login, and you find that passwords are not saved, you might need to create/set a default keyring.

Ensure that the seahorse package is installed, open it (“Passwords and Keys” in system settings) and select View > By Keyring. If there is no keyring in the left column (it will be marked with a lock icon), go to File > New > Password Keyring and give it a name. You will be asked to enter a password. If you do not give the keyring a password it will be unlocked automatically, even when using autologin, but passwords will not be stored securely. Finally, right-click on the keyring you just created and select “Set as default”.

What do you have in your folder /home/$HOME/.config/autostart/ ?
Do you have something beginning by gnome-keyring…?

gvfs and gvfs-smb are well installed in your system ?

Please - one question to remain - are you using password protected access to the share connected to the router?

I have one more :slight_smile:
What are the permissions of your /home/$HOME/.local/share/keyrings folder ?

Yes, I do have those three entries I checked (gnome-keyring-pkcs11.desktop, gnome-keyring-secrets.desktop and gnome-keyring-ssh.desktop).

I will check the link from Wiki you shared, but I my problem is not I have to enter the password every time, it’s I can’t access share at all (via Thunar’s network tab, with smbclient and with cifs mounting I can). I think I have to read a bit on this concept of keyrings…

Yes, those are the credentials Thunar asks when I try to access it and that it doesn’t accept anymore for some reason, sorry if this is important and I wasn’t clear :’(

rwx------ myuser myuser

@linux-aarhus : From Manjaro as a client, is it OK if the server is on SMBv1 ?

@MrTanguero : Maybe you could try and older version of samba client to see if it changes something

@yannssolo I successfully can access shares using smbclient, you think this version might not play well with Thunar? Or what you’re proposing has nothing to do with smbclient command?