Problem with the package or Pamac?

In the past three days, I had problems with updating AutoKey (autokey-common and autokey-gtk), but I am not sure the problem is with the updated packages or Pamac.

When the update icon warns me there are updates, I click on it, Pamac shows its window and I notice there are updates for AutoKey. I click on Apply, the update starts, it updates the packages, but when it’s done, the same packages are shown again. Sometimes, the “arrow down” icon changes to an icon similar to the one shown on the Updates tab. If I click on Apply, the update process starts again. The icon telling me there are updates is still on its place (on the bottom right, for me who is using Xfce). It happens also when I close and re-open Pamac. After four or five times I keep updating the same two packages, Pamac shows the Your system is up to date message.

AutoKey is installed, but I wonder if this is a problem with Pamac that isn’t able to write some files on my computer.
I had the same problem on a laptop and on a virtual machine. On the laptop, I got an error message about the database non being synchronized; I resolved that issue with the help of GUI Package Manager "unable to lock database Failed to synchronize databases Failed to synchronize AUR database", no lock file found and Pamac stopped asking me to update AutoKey. On the virtual machine, I didn’t have that problem; I am not sure what made Pamac decide my system was up to date, all in a sudden.

I opened Pamac now just to verify it would still tell me AutoKey needs to be updated, but it still says Your system is up to date. I even clicked on Refresh; Pamac stalled for some seconds on 67%, but at the end it didn’t say there were updates for AutoKey.

Your system might be up to date
but autokey-… is an AUR package
and you might need to adjust some setting in pamac
so it will also update these packages.

Update might not be the right word here - the version might be the same but it still needs to be rebuilt after the underlying system changed (due to an system update).

Can’t assist further since I do not use pamac or the GUI tool for it.

1 Like

I do experience the same problem.


  • autokey-common 0.96.0-2 → 0.96.0-4
  • autokey-gtk 0.96.0-2 → 0.96.0-4

When accepting to update the update process starts.
In most cases (10/12) it immediately says “cannot lock db”.
However the update procedes in the backend and finishes successfully.

When the page is reloaded, both packages are marked as ignored to update.
The next refresh of possible updates resets those marks and I start again.

The db.lock file definitely does not exist in between updates and other AUR packages can update during the process.

Is there some way to at least ignore these specific autokey versions from popping up all the time?

Thank you

I am not on Manjaro right now, to tell you where to find that setting. Pamac has an option to ignore packages, to avoid it shows updates for them.

I didn’t get system updates, when I was updating those packages. From your reply, should I take is merely a problem with the packages?

I’ve found ignoring updates for specific packages. (Options > Advanced > Ignored Upgrades).
This stops pacman from removing the “Do not update” flag.

However the tray icon still signals that updates are available and it seems that specific versions can’t be targeted.

Could it be that the package of version 0.96.0-4 falsely reports it’s 0.96.0-2 and therefore thinks it didn’t succeed?

Is there a way to manually adjust the version?

Have you tried reinstalling both via the CLI?

pamac build autokey-common autokey-gtk

I thought too that, once the packages got installed, Manjaro was still seeing the old release installed. That would not explain why it stopped to say they were updates, after I re-updated them four or five times.

When Pamac starts to update, it gives the possibility to edit the build files. That could help to avoid Pamac keeps repeating there are updates, if the issue is what you described, and knowing what to touch.

Not from looking at the PKGBUILD

@NGr @kiamlaluno Thanks for your help. I really appriciate the fast response.

I don’t really know what to say, after I believe 20 tries with the exact behaviour I wanted to copy the output of pamac to this forum to give more context.

However this time, although I got the same error popups, it worked and the packages are now updated.

pamacs history shows as follows:

[2022-07-18T14:55:31+0200] [ALPM] upgraded autokey-gtk (0.96.0-2 -> 0.96.0-4)
[2022-07-18T14:55:31+0200] [ALPM] upgraded autokey-common (0.96.0-2 -> 0.96.0-4)
[2022-07-18T13:20:39+0200] [ALPM] reinstalled autokey-gtk (0.96.0-2)
[2022-07-18T13:20:39+0200] [ALPM] reinstalled autokey-common (0.96.0-2)
[2022-07-18T09:49:33+0200] [ALPM] upgraded ddev-bin (1.19.4-1 -> 1.19.5-1)
[2022-07-18T09:49:33+0200] [ALPM] reinstalled autokey-gtk (0.96.0-2)
[2022-07-18T09:49:33+0200] [ALPM] reinstalled autokey-common (0.96.0-2)

so somehow it reinstalled instead of updating the package. I don’t know what happened there.
Never experienced something like that before.