Problem with the mouse cursor

Just installed 5.11 and everything worked fine as far as I could tell, except the cursor. I tried changing how it appeared in Tweaks, but it didn’t do anything. It basically looked like a strange looking ladder. It worked but looked strange.

The kernel is not related to the appearance of the mouse cursor. What cursor theme are you using?

The default theme, I hadn’t changed anything. But I did try to change the theme while the problem was occuring but it didn’t make a difference. Once I went back to 5.10 the problem disappeared.

The defaut GNOME theme is Adwaita and the default Manjaro theme is Xcursor-breeze. Which one? Did you try both / others?

the standard is xcursor-breeze, I tried xcursor=breeze-snow

Sorry, but i can’t imagine how it looks. Could you please kindly give me (or us) a screenshot?

1 Like

Sorry no. I don’t want to reinstall the kernel. Linux’s GUI is extremely sensitive and will refuse to boot for the slightest thing. I’m considering myself fortunate and am moving on.

Well, sorry. We can’t help you if you can’t help us help you.

Linux is a kernel. It doesn’t have a GUI. :wink:


The mouse cursor looks like a ladder when using 5.11.

Still no joy. The cursor looks like a ladder in 5.11.

Your entire video looks like a ladder. Try recording your screen instead of using your phone.

I too have this problem. I am running Gnome (Testing) under Wayland. I have a low cost Nvidia card and use the open source driver. If I use kernel 5.11.1 or 5.11.2 then the cursor is deformed into a skeletal affair (quite ladder-ish), narrow, vertical and about twice the normal height, which changes shape as the cursor changes shape (arrow, hand etc) or when I try a different theme.

If I log into Gnome under Xorg, the problem is immediately resolved. Since Wayland is one of my motivations for using Gnome, this is not my preferred solution! So far I revert to using 5.10.

Sadly a screenshot does not help. The screenshot program substitutes a correct cursor.

Hope this helps.

Look at it in full screen not in a small window, the resolution issues will disappear.

I don’t really understand what bkarlan is saying. The pointer issue persists regardless of window boundaries. Screenshot corrects the pointer in a full screen shot, with or without windows present.

I don’t really think wishful thinking will cure this problem. There is a hiccup somewhere in the 5.11/Wayland/Nouveau environment. It does not exist under 5.10 nor under Xorg.

Just to confirm: Kernel 5.11.5-1 still has this anomaly.

It might be worth mentioning that the ladde-rish cursor is virtually unusable. This is not just a cosmetic problem.

This is more than just a Manjaro/Gnome/Wayland problem. It is present on openSUSE Tumbleweed/KDE/PlasmaX11 also. It isn’t window manager specific, same results with KDE, IceWM and TWM. The other thing I have in common with @bobwad is an Nvidia graphics adapter - mine is a Quadro K1100M.

The messed up cursor is present at the login screen before the desktop is loaded and as @bobwad said it’s way more than a cosmetic issue. Changing the cursor theme and/or size makes no difference nor does changing the theme.

Is it maybe an issue with nouveau and kernel support? With libdrm_nouveau2 v.2.4.104-3 the cursor is messed up when booting with kernel 5.11.xx, displays correctly with any previous 5.10.xx or older version.

I would attach images of what an arrow, hand, and text cursor look like but it says I can’t embed media items in the post. I’d make them links but it says I can’t do that either :frowning:

If you’re not yet allowed to post links, wrap the link in single backticks. Like


will render as

Hope this helps!



1 Like

Thanks for the help @Mirdarthos.

arrow cursor:

hand cursor:

text cursor:

Yes, that’s it.

I just tried 5.11 under Onara and it’s still the same ladder.