Problem with dual booting mint and manjaro

In my case i install Manjaro (not easy) , then install Linux Mint on separate partition and now Manjaro can’t load from Grub menu (kernel panic) Mint is working as always (

And that is a problem. Mint’s grub cannot boot Manjaro’s modified grub. If it is a EFI Installation, then choose Manjaro at the BIOS/UEFI. Manjaro’s grub can boot Mint’s grub well, since backwards compatibility.

So in short: Mint’s grub cannot boot Manjaro’s grub, because it is 1. modfied and 2. has a higher version.

Still can’t boot, it’s a giant problem for me, someone to help. Linux mint just kill manjaro but Mint working (((

It is not uefi, im sure

this is from Linux Mint (sda is my laptop ssd disk, sdb is external ssd disk - here i install Manjaro sdb2and then Linux Mint sdb3 - choose to write grub on this external disk im sure)

abc@abc:~$ sudo lsblk -f
NAME   FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
├─sda1 ntfs         983438713438550A                                    
└─sda2 ntfs   Data  841AFE221AFE10C2                                    
├─sdb1 swap         a561733a-d23a-47a5-b711-9638ed6cdb93                [SWAP]
├─sdb2 ext4         fc0523ce-7f69-4736-a5a4-fc158a08538d   45,9G    15% /media/abc/fc0523ce-7f69-4736
└─sdb3 ext4         0a4523ac-2f12-4ba2-854e-1662af33d9dc   43,4G    16% /
abc@abc:~$ ^C

Mint grub can’t boot manjaro but manjaro grub can boot mint. You can use a live USB with manjaro and chroot to install /update grub to manjaro grub

That happens because initramfs (initrd) entry is for some reason missing from mint’s grub…probably. (It might work if you go to Advanced options fo manjaro and boot something from there. At least it did last time I was testing this weird thing.)
There are few similar topics around, try searching for them. There was one just a week ago. Either reinstall grub from manjaro or add custom entry with initrd /path/to/*-ucode.img /path/to/initramfs*.img. At least I think this last thing works. :stuck_out_tongue:

In case you have not done something weird during installation you need to

  • boot into a Manjaro live ISO
  • restore the bootloader
  • modify your /etc/default/grub if needed so it contains
  • and then boot the PC again into Manjaro and run
    sudo update-grub
    This should create the entry for mint.