Printer Help - Brother DCP-8110DN

I have been digging through this for over a week now and am at the point of needing help.

When I attempted to add my network printer in Gnome’s Add Printer dialog, it appears, then when I click Add I get an error Failed to Add Printer. When I was running Ubuntu before this was all I had to do and it just worked.

I started digging into this a bit…

  • The drivers on the Brother website are for *.deb and *.rpm only (hence why it probably doesn’t ‘just work’ anymore - sigh)
  • The AUR has a generic driver which specifically lists my printer (OK)

At this point I have tried using a tool to extract specific drivers from the *.deb file which got me nowhere then, after finding the generic driver ( AUR (en) - brother-brgenml1 ) and installing that nothing changed. (It is installed properly and appears in the Software app but adding the printer still fails).

I then found this article on here…

And ran this…

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

The first 3 lines failed but the last three went through fine which the discussion above indicated should be OK.

I then went to CUPS Admin here: http://localhost:631/admin

I set up my printer using the first option for Model (Brother BrGenML1 for CUPS) which seems to be the generic driver.

I can now see a printer in the printers list but if I try to print anything then nothing happens, it just sits in the queue.

I cleared the printer attempts from CUPS admin at this point and went to the Manjaro Wiki Printing pages here: Printing - Manjaro

And tried this, which seemed to be missing…
pacman -Syu system-config-printer

The Add Printer GUI tool now allows me to add my printer but any attempt to print still just stops at Processing and nothing prints.

I reviewed what had been set up and it was using a generic driver rather than the Brother driver so I went in to Choose from Database and selected the Generic Brother driver that I was using when trying with CUPS above. Still nothing prints and it sticks on processing.

When I try to print a second document the print dialog now says Unable to find printer BRN001BA9EDD704

I am all out of ideas as to where to go from here now.

I managed to do this eventually.

The key was the IP address. When adding the printer through the Add Printer dialog I entered the IP address for the printer (which I had to get via installing an app on my phone of all things) and then that revealed an option to install both LPD and JetDirect links to the printer - both of which then worked without any complications whatsoever using the generic driver from the AUR, listed above.

2 sided printing worked off the bat, as did printing directly from the command line.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.