Printer Canon iP-1980 isn't working

I have Linux Manjaro xfce with 5.4.169-1 version. I tried to use my Canon iP-1980 printer. I’ve installed manjaro printer packages. Everything is okay, manjaro printer software could detect my printer.
But, when I tried to test it, my printer couldn’t work.
It says processing, but my printer hasn’t done any work. I tried to change the driver from printer database, but when I searched it, I couldn’t find any drivers that matches with my printer version
Can anybody help me? I need to print some documents

If you need help, say so in your title :wink:

Increase your chances of solving your issue:

Provide Information:

Hi. It seems that your printer needs Canon IJ Printer Driver Ver. 3.00 for Linux (see Canon driver download page Support - PIXMA iP1980 - Canon South & Southeast Asia). The driver comes in two parts: cnijfilter-common_3.00-1 and cnijfilter-ip1900series-3.00-1. Unfortunately, Canon provides only rpm and deb packages that don’t fit Manjaro.
There is cnijfilter-common package version 4.10 in the AUR (AUR (en) - cnijfilter-common) so you can try to install it and see if the printer works with it.