Prevent taskbar from flashing and popping up when application launches new window

Hello,

I started using the Unity3D IDE on my machine just the other day and I am running into a strange issue. When I hover over something in the UI so as to have a tool-tip pop up, it seems the way Unity creates/manifests the tooltip is as something that is a window in some way or another. If you reference the attached image you will see the Unity icon in my taskbar is illuminated (and actually flashes, but I can’t show that in a still image).

This is a bit annoying not only due to the flashing, but because I also like to have my taskbar hidden. With this behavior every time I produce a tool-tip, either on purpose or unintentionally, the taskbar pops up and gets in my way.

What I would like to know if there is some way I can:

  1. Configure Plasma such tha the taskbar popup nor flash when the new “window” (i.e., the tool-tip) pops up… OR
  2. Configure Plasma such that the taskbar does not popup and flash for any windows/applications.

System:
plasmashell 5.19.5
DISTRIB_RELEASE=20.1.1

imgur DOT com/a/lApB80r

1 Like

It seems as a new users I can’t upload/embed media in new posts, nor paste links. How can I share a screenshot of the described behavior?

For your image/link/blah see this:

For your issue … how did you install Unity3D?

1 Like

Thanks for the information about the trust level. It seems my account from the previous forums did not make its way over.

I installed the aur/unityhub package using yay and then I installed Unity through that. This is the recommended approach (from the Unity team) for any of the big three operating systems.

Can you please use the link provided above to post a pic because imgur is a piece of %"’(§$ doesn’t work if you block all cookies and I used to run Unity until 9 months ago and don’t understand what you’re talking about…

(Looks like filing a bug with the Unity team is the way to go from my current understanding)

Don’t seem to be able to modify my original post. Here is the image:

image

The Unity icon is in the bottom-left corner. When I hover over something that produces a tooltip (like the icon the mouse is over), an additional “window” of sorts is created which causes the taskbar to pop up. I say “window” like thing because when I press alt+tab there are two items for Unity displayed. Of course, the second item (which is associated with the tooltip) disappears from the list rather quickly as the tooltip disappears once the main Unity window looses focus.

This is very specific to Unity, so if I were you, I would take that up in the Unity3D forums instead of here… (Still smells like a bug to me)

:sob:

I’ll look into filing a bug with them :slight_smile:

In the mean time, is there no way to configure my task bar to not flash/pop-up when a new window opens? I don’t mean specifically for Unity, but just across the board for any and all apps.

I’m on KDE Plasma (aka “The desktop for the tinkerers”) instead of Unity nowadays and my (hidden) task bar does pop up as well if one of my applications has a notification and I can’t turn that off:

2020-10-10_22-59

as there is no option Never visible until I decide to click it! so i suppose that’s going to be a feature request…

:wink: :grin: