Prevent screen brightness reduction while watching a video on youtube

Hi. I use manjaro linux with xfce 4.16 desktop environment. In power manager i have brightness reduction on inactivity option. How can i watch videos without turning off this option? When i watch video on Youtube this option reduces brightness level every 2 minutes so i have to touch buttons or mouse to bring the normal brightness back. I find some ways to fix it using scripts that move mouse automatically or suggestions to disable display power options every time i watch a video but these ways look stupid so i wanted to figure out if there is a normal way to fix it.

Do you watch them in full screen?

Yes, i do.

normally, watching youtube or any other multimedia doesn’t usually count in inactivity. which browser are you using? this doesn’t happen with firefox

i use pre-installed firefox right now , going to switch to ungoogled-chromium after my another issue((( (with building packages ) will be solved

Xfce power management has a Presentation Mode to disable suspend settings
xfce4-power-manager:4.16:panel-plugin Xfce Docs

forum.manjaro.org/sound-source-changes-after-screensaver-becomes-active

Left click the Power Manager icon in the panel and turn on Presentation Mode
PresentationModeOn

The Presentation Mode orange indicator icon might need to be turned on in the Power Manager plugin settings

2 Likes

Thank you for your reply but this solution is like turning display power options every time i watch a video, i’ll use this now but it don’t look like a right solution. I mean i came from Windows and in Windows i don’t have to change any options just to watch the video. I guess it shouldn’t work that way as it does. As @ishaan2479 wrote it’s not normal behavior and it usually shouldn’t count as inactivity…

I finally built ungoogled-chromium for myself and i want to add that if i use ungoogled-chromium and press the battery button i get incription /usr/lib/chromium/chromium is currently inhibiting power managent and i can watch videos even not in fullscreen (@maycne.sonahoz) so i guess i need to change config files somewhere to turn on this function in firefox. But i don’t know where.

This seems relevant.