Popping up whisker-menu with super key

Hi there. In recent days, I’ve been working on defining key shortcuts. But in the midway, I realized that super button no longer pops up whisker menu. I tried to manually assign Super button for running the following command


But that caused problems for running other shortcuts that include Super button, such as Super + D that I’ve defined for showing desktop.

Does anybody have an idea how to tackle this problem?

I would have thought it is already handled, since AFAIK default shortcuts include Super for Whisker and Super + something for some others…
Check if you haven’t set the same shortcut twice.

Something similar is happening to me on my laptop and on the Xubuntu machines I use at work: replicating the Super + E shortcut I use to open the file manager on my KDE desktop (no issues there), the menu opens, followed by the file manager.
It’s an XFCE issue, not a Manjaro one. Quite annoying, though.

Show Desktop should have shortcut Ctrl+Alt+D

Super L shortcut for whisker menu is included on Manjaro Xfce but can be removed if keyboard shortcuts are reset to Xfce defaults

To add it back:go to xfce4-keyboard-settings Application Shortcuts tab
xfce:xfce4-settings:keyboard [Xfce Docs]

Click +Add button and use this command for whisker menu:


Press Super key when requested to assign key for command

There are 3 other default Xfce shortcuts using Super key

  • xfce4-display-settings --minimal Super+P
  • xfce4-appfinder -h Super+D
  • thunar Super+E

The first two work ok – whisker menu appears but is then minimised
But for Thunar, Super key has to be pressed again to toggle whisker menu off

On Manjaro Xfce there are 2 default shortcuts for Thunar: Super+E and Ctrl+Alt+F
The Reset to Defaults button might restore those shortcuts on Xubuntu

===> xfconf-query -c xfce4-keyboard-shortcuts -l -v | grep -i whisker
/commands/custom/<Alt>F1                   xfce4-popup-whiskermenu
===> cat .config/autostart/xcape.desktop | grep -i exec
Exec=xcape -e "Super_L=Alt_L|F1"
===> ps -p $(pgrep -f  'xcape')  -F
# xcape process running
1 Like

would you please tell me where I should enter these codes?

I’d simply start over instead of trying to fix it.

Copy the original file from /etc/skel to the same place in your $HOME directory, thereby overwriting it.

cp /etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml ~/.config/xfce4/xfconf/xfce-perchannel-xml/

This should probably best be done from a TTY with your session closed (you being logged out)
but it might work from inside the session (the easier way) as well.

Log out and back in to see whether it worked.

I’m not sure I understand, but if by “codes” you mean “commands” see @maycne.sonahoz response. In short, I see you are using the XFCE desktop. Click on the Terminal to enter.

The commands I listed above aren’t going to solve anything, but they will show you the status of some configuration options that create the super key behavior.

There is a little information about the terminal at xfce.org.

imho, the best location to learn about commands and the shell are at https://linuxcommand.org/.

Is the answer yes for all questions below? If not what did you see?

  1. Alt-F1 brings up the Whisker menu.
  2. xcape is running
  3. xcape desktop file EXEC line contains “Super_L=Alt_L|F1”
  4. xfconf-query command returns similar output as the above.

Jumping ahead, how (or where) were you “defining key shortcuts”? Were you just using XFCE Settings > Window Manager > Keyboard and XFCE Settings > Keyboard > Application Shortcuts?

A side note, you can list XFCE shortcuts with:

xfconf-query -c xfce4-keyboard-shortcuts -l -v 

There’s a little help on xfconf-query at xfce, plus the command supports -h|--help options.