Plymouth works in an unexpected way

System info: Intel i5-6300U, Intel HD Graphics 520, Manjaro KDE (X11), LightDM

I’ve followed the Arch Wiki guide to installing Plymouth as well as this video, and it works well with the plymouth --show-splash command, but for some reason the splash is shown during shutdown instead of after booting. In the latter case, an ugly grey screen with three off-center white dots is shown. I can’t for the life of me figure out why.

Here’s the relevant part of /etc/mkinitcpio.conf:

## NOTE: If you have /usr on a separate partition, you MUST include the
# usr, fsck and shutdown hooks.
HOOKS="base udev plymouth autodetect modconf block keyboard keymap consolefont filesystems fsck"

Here’s the relevant part of /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor splash rd.udev.log_priority=3 vt.global_cursor_default=0"

Here’s my full /etc/plymouth/plymouthd.conf file:

# Set your plymouth configuration here.

I have enabled the plymouth version of LightDM using systemctl.
I am also not dual booting with any other OS.

Anything I missed? Thanks in advance

You are using Intel GPU.

Edit /etc/mkinitcpio.conf to add i915 in MODULES

Then sudo mkinitcpio -P


Thank you so much! That worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.