PlayOnLinux stuck on virtual disk creating

Hi I am trying to create virtual disk in playOnLinux but getting contemporary loading and it is not finishing!!! Any idea? Here is some info.

inxi -Fxz
System: Host: just-r Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5
Distro: Manjaro Linux
Machine: Type: Laptop System: ASUSTeK product: ROG Strix G531GT_G531GT v: 1.0 serial:
Mobo: ASUSTeK model: G531GT v: 1.0 serial: UEFI: American Megatrends v: G531GT.306
date: 03/11/2020
Battery: ID-1: BAT0 charge: 42.3 Wh condition: 42.3/50.5 Wh (84%) model: ASUSTeK ASUS Battery status: Not charging
CPU: Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A
L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431
Speed: 801 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 801 6: 800 7: 800
8: 800 9: 800 10: 800 11: 800 12: 800
Graphics: Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 440.82
bus ID: 01:00.0
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: intel,nouveau tty: N/A
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes
Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k5.6.15-1-MANJARO
Network: Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3
IF: wlo1 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel
port: 3000 bus ID: 03:00.0
IF: eno2 state: down mac:
Drives: Local Storage: total: 1.38 TiB used: 60.67 GiB (4.3%)
ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB
Partition: ID-1: / size: 23.97 GiB used: 16.24 GiB (67.7%) fs: ext4 dev: /dev/nvme0n1p5
ID-2: /home size: 211.44 GiB used: 44.38 GiB (21.0%) fs: ext4 dev: /dev/nvme0n1p8
ID-3: swap-1 size: 1.95 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p6
Sensors: System Temperatures: cpu: 48.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2900
Info: Processes: 300 Uptime: 5h 07m Memory: 15.49 GiB used: 2.81 GiB (18.1%) Init: systemd Compilers:
gcc: 10.1.0 clang: 10.0.0 Shell: bash v: 5.0.17 inxi: 3.0.37

wine --version

That is an EOL kernel = end of life
I would suggest 5.7

How do you create the wineprefix?

Agree with @bogdancovaciu 5.7 or 5.8, and check your updates cause if you’re keeping the system up to date you should be on 5.15 for Wine not 5.9.

apart from the hint to use an maintained kernel: PlayOnLinux is rather dead, they claim to work on version 5 for years now, but apparently they make no progress and the current version didn’t get an update in quite some time now.

You should try Lutris instead, its much better maintained and offers basically everything that PoL offers, plus more.

Actually PlayOnLinux works just fine. I update Wine if it needs it, then install WinTricks and PlayOnLinux.

A post was split to a new topic: GRUB missing Manjaro entry

I updated wine into 5.14 and manjaro into 5.7, but playOnLinux still stuck while virtual disk creating

Hi, dunno if it’s related but I found this on the old forum :

There are other threads like this on Google, maybe one will relate to your case. I remember having some issues with POL and wine some months ago, I was back then on Linux Mint or Ubuntu Budgie. There was one tinkering in .playonlinux directory, there was also a manual install of my executable, rather than letting POL do the install - and get stuck while creating the virtual disk.

I removed this files. Now I have a little change, when virtual disk starts being created wineconfig small and unresizable window being opened, but virtual disk creating still forever. I want to mention, I am creating new disk instead the old disk by erasing it, and also I am creating 64bit disk.

Old memories, I don’t know if this will help. Do you manually specify a 64-bit version of Wine or does POL chooses it for you?

I chose 64bit before creating

I tried to use 32bit and that works. Now Wine is able to create 32bit virtual disk, but programm that I want Adobe Photoshop CC 2018 is for 64bit, so I got error.

You can start to check the logs in the Playonlinux debugger

And maybe you will find some wisdom in here, check the different test results:

You may also search if there is such an entry for this application in Playonlinux website. I know that it’s the case for Lutris.

I tried one more time and wine threw the message that it needs wine-mono and wine-gecko packages, I installed them and all worked great for me. However I dissapointed about photoshop CC 2018 version, so ugly and uncomfortable and it requires additional hard work to make it stable, in short I think I will not use it.

Yeah I don’t get exactly how it works but if you directly try to install an exe with Wine, it will tell you to install Mono and Gecko. You do the same in POL or Lutris, Mono & Gecko again.
As if they shipped their own Wine.

Sometimes the Gecko/Mono pop-up appears directly, sometimes as you saw, it is stuck…

1 Like

I noticed strange thing. When I delete virutal disk mono and gecko packages are being deleted with him.

Just a guess, I’m too lazy to wiki-search, but perhaps a Gecko/Mono install by application.
I know that in POL/Lutris, you can install by example 3 WIndows exe with each a different version of Wine, in 32 or in 64bit.

I don’t want you to search something for me)))) just talking for interest.

1 Like

Don’t worry :slight_smile: I’m interested too by how it works.

1 Like