Plasmashell(?) memory Leak - newbie looking for help


#1

Hi! Since the last update (yesterday) I’m experiencing memory problems.

System:    Host: fenris Kernel: 4.14.101-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Console: tty 2 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: GA-MA790X-DS4 v: x.x serial: <filter> BIOS: Award v: F5e date: 07/22/2008 
CPU:       Topology: Dual Core model: AMD Athlon 64 X2 6000+ bits: 64 type: MCP arch: K8 rev.F+ rev: 3 L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 svm bogomips: 4020 
           Speed: 1000 MHz min/max: 1000/3000 MHz Core speeds (MHz): 1: 1000 2: 1000 
Graphics:  Device-1: NVIDIA G92 [GeForce GTS 250] vendor: Micro-Star MSI driver: nouveau v: kernel bus ID: 01:00.0 
           Display: tty server: X.org 1.20.3 driver: nouveau unloaded: modesetting tty: 240x67 
           Message: Advanced graphics data unavailable in console. Try -G --display 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Sound Server: ALSA v: k4.14.101-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8168 v: 8.045.08-NAPI 
           port: ee00 bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 1-5.1:5 
           IF: enp0s19f5u5u1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 838.37 GiB used: 106.03 GiB (12.6%) 
           ID-1: /dev/sda vendor: Samsung model: HD403LJ size: 372.61 GiB 
           ID-2: /dev/sdb vendor: Samsung model: HD502IJ size: 465.76 GiB 
Partition: ID-1: / size: 357.40 GiB used: 99.84 GiB (27.9%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 4.10 GiB used: 4.10 GiB (100.0%) fs: swap dev: /dev/sdb2 
           ID-3: swap-2 size: 8.48 GiB used: 2.09 GiB (24.6%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A gpu: nouveau temp: 56 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 151 Uptime: 1h 12m Memory: 3.86 GiB used: 3.33 GiB (86.3%) Init: systemd Compilers: gcc: 8.2.1 
           clang: 7.0.1 Shell: bash v: 5.0.0 inxi: 3.0.30 

Almost all of it is used by plasmashell it seems using the htop command. I can’t even start the console from the GUI.
When I trying to start anything from the virtual console (e.g. plasmashell -v) I’m getting an error message I’m not sure how to interpret:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the QT platform plugin "xcb" in "" even though it was found.
This application failed to start because no QT platform could be initialized. Reinstalling the application may fix this problem. 

I’ve tried to use this command to get it to work sudo pacman -S libxcb, but to no avail.

Any help is appreciated.
Best,
Edward


After 2019-02-23 Update plasma Fails to Load
#2

Seems like you aren’t the only one. Are you using Oxygene theme? I would change that for the time being.


#3

Yes, as far as I’m aware I’m using oxygen. How do I drop the theme without access over the GUI? I’m trying to start the appropriate app, but it instantly closes.
Never did this using the CLI I’m afraid. A web search didn’t bring any viable results :weary:


#4

Try either this:

https://userbase.kde.org/KDE_Connect/Tutorials/Useful_commands#Change_look_and_feel

Change look and feel

Breeze (Light) theme:

lookandfeeltool -a 'org.kde.breeze.desktop'

Breeze (Dark) theme:

lookandfeeltool -a 'org.kde.breezedark.desktop'

or if that doesn’t make the trick, this:
kwriteconfig5 --file=plasmarc --group=Theme --key=name Default

alternative:

kwriteconfig5 --file ~/.config/plasmarc --group Theme --key name breeze

Good luck.


#5

No need to do this in CLI, use krunner to launch system settings.

As has been said, change to breeze theme and all should be right, the issue is a Qt 5.12.1 bug that effects the Oxygen theme.


#6

Hi, main problem is, that I can’t launch anything. If I try to do it from the desktop menu it instantly closes and if I try to launch an application from console (e.g. tty2) I’m getting the xcb error.


#7

tty2 won’t work, there is no graphical session.

Use krunner (Alt+Space), start typing app name (ie System Settings), and select it from the list, hit enter.

If you need a terminal use yakuake (F12).


#8

The lookandfeeltool won’t start and shows the same error as every other application when I’m trying to start it from tty2, as I can’t evoke the console from the desktop at all.

the kwriteconfig5 command is accepted but I don’t see any results. What am I missing? Do I need to restart the X server?


#9

You could restart plasmashell.

killall plasmashell && kstart5 plasmashell

#10

That did the trick, after setting everything to breeze using yakuake.

Many thanks to both of you!

PS: Manjaro handles a lot more different than my prior Ubuntu.