Bluetooth AX200 Reconnect bug, any updates?

So there has been a bluetooth bug with the AX200 going around now for a few months now (Manjaro Forum, Arch Forum), I am wondering whether there is already a fix available.

In the Manjaro thread, that has since been locked, it’s that that a patch had come out, although I am still experiencing the issue.
In both threads it has also been said that downgrading linux-firmare to 20201218.646f159-1 should fix it. I’m not too keen on downgrading packages though, so I was wondering whether there is any fix in sight.

2 Likes

The only known fix is what you typed.

That’s what I had to do.

I got my package from Arch Linux Archive

sudo pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20201218.646f159-1-any.pkg.tar.zst

You’ll also have to go into /etc/pacman.conf and put:

IgnorePkg = linux-firmware

so that it doesn’t keep updating that package. I’ve been keeping an eye on the forums (specifically the one you linked) to see if newer packages fixes it, but doesn’t seem like it yet. I do recommend to remove that IgnorePkg after we find out that a newer packages fixes the regression though.

3 Likes

hello, anyone else had tried the latest firmware? I’ve used my bluetooth mouse for a couple of days and so far, no problem with the ax200 device. Is it fixed? or just lucky that worked?