Plasma mobile on Pinetab - black screen after update


installed Plasma mobile latest build


After installation and boot on the SD card all runs proper and stable. The Discover announces an online update. Done this and afterwards the boot screen remains dark.

Any ideas for that?

There was a faulty kwin update recently, which should have been fixed. So try getting to a TTY and update again.

Done another full upgrade after a new flash. No way, tablet does not boot up, cannot be reached by ssh. Only thing I can see is somewhat like a underline-cursor in the left edge of the screen.
Cannot access via ssh. System is dead again

Can you get to a TTY with a USB keyboard?

Yes I can. But what to do then. WiFi is not connected in this state

You need to check why the GUI is not starting.

So you might want to check what journalctl -b says, or even dmesg.

If I detach the keyboard and put the tablet in portrait mode it shows a mousepointer !!
Maybe the update breaks here something for the landscape mode an/or attached a keyboard?

There seems to be problem with sddm login. I changed the autologin user from “kde” to “manjaro” in sddm config and I could login. Should there be a user “kde” as it seems to be in the pinephone plasma version?

The kde user is from the PinePhone Plasma Mobile CE we did.
The PineTab does not have a kde user and should have the manjaro user.

Did the sddm autologin change the kde user in an update?

Yes, I think so, since the image worked ok before update, but after it there was “kde” in the settings. By the way, should the auto-rotation work? I could not make it work either in the image nor after the update.

No. Auto rotate does not work, because the accelerometers are not in the kernel yet.

Strange. I arch it works just by adding iio-sensor-proxy package. Are you not using the same kernel?

Probably not.
We are using upstream mainline kernel.

Ok. Thanks for clearing that.

Not sure if related but I had a black screen with testing branch on the Pinephone with 20210224 and the latest 26 did the same on reboot too.
Screen brightness is set to a very low level and it is essentially black for my Pinephone - luckily I have wifi and ssh enabled so I could change the screen brightness:

I had to edit sddm autologin again from kde to manjaro. Luckily, rotation works now, after I deselected “Only in tablet mode” in settings.