Plasma mobile issues

I have PinePhone with Manjaro Plasma but there are some things I don’t know what to do about.
I know that everybody is busy and that Manjaro Plasma on PinePhone is better with every day, but there are some things, that are really annoying (at least for me)

  1. I can’t use data connection via my SIM (= no internet connection without wifi)
  2. System settings don’t allow me to do as much as on computer (also manjaro KDE) - for example network settings don’t allow me to make VPN connection as easily as on my desktop
  3. I can’t find a way to change ringtones
  4. The phone keeps locking when it isn’t charging
  5. When I open an app, I can open another one only by searching for it, not by usual scrolling down
  6. When I’m in the main screen, I can’t swipe/scroll sideways
  7. lots of apps (like firefox) that I’d expect to run on a phone are only desktop versions
  8. In the application menu are some apps twice

Could you, please, tell me how to fix it / fix it with new system updates?

This is a known issue, that the developer is looking into.

Well yeah. it’s a phone and the Settings app is still in heavy development. More and more stuff comes into it every month.

Not possible yet. :slight_smile:

Did you set the timeouts in the Screen section of the Settings app?
Because that had an issue in older images, where it would enforce those, even if the device was used.
Is atleast fixed in my testing off todays dev image.

Not sure what you mean here. You can’t open the App Drawer on the homescreen when you open an app and press the Home (KDE icon) on the panel?

Multiple homescreen was recently introduced in the dev builds. Check todays dev image to test it out. Works just like they do on Android phones.

Plasma Mobile does not work well with most GTK apps yet, which is why we don’t ship firefox on it.
But you can install mobile-config-firefox to get a more mobile friendly Firefox.

Give an example.
By default there should be no apps shown twice. But if you install some, they might have more than one .desktop file, so they both gets shown. Pamac is a good example of this. It has 2 icons, with same name.

1 Like

Thanks for answering,

I expected that a lot of these issues are only a matter of time :slight_smile:

The locking issue is pretty strange. I can use my PinePhone normally, when It is plugged in and charging and when it isn’t plugged in, it just locks automatically. I just tried to unplugg it and it locked - so I unlocked it and it immediatelly locked again…

Exactly. When there is an app opened, I can not open the App Drawer - It does the same as the “square button” (next to the Home button) - It just shows the opened app(s)
I can then open an app only if I use the “search” feature on my home screen

Thanks for this advice - deffinitely gonna try it! :slight_smile:

Yeah, pamac is one of them (I hate discover). Another one is sensor viewer, but If it is just about .desktop files, I guess I can delete one of these from my home folder (dolphin works surprisingly well, only except renaming files)

Yeah. That issue was fixed in the development images a little while ago.

I have not encountered this myself.
Can you try it with todays dev image and see if it’s still happening there for you.
What apps did you test this with?

Well, it’s not in the home folder. It’s in /usr/share/applications/ most likely.
And we don’t ship with Dolphin, so that’s an application you installed yourself.

So it means that if I wait, It will fix itself with an update? :slight_smile:

It happens with all apps I use, but I can still use the phone pretty well. I primarily wanted to know If it is abnormal or not

Thanks for the folder to look into (dolphin isn’t there twice, I only found it much more useful than Index :grin:)

Btw, Is there a page, where I can see a list of all known bugs, so I won’t bother you (or anyone else) with another questions that I could then answer by myself easily?


It is abnormal. I can’t reproduce it.

Yes. Check out our Gitlab.

1 Like

So i tried that dev kit (booted from my SD card) and I must say, that the “more homescreens like android” option works amazingly well!

I also tried opening more apps (in this case calculator, phonebook and index)

when I press the “home” button, it does nothing
if I swipe “from” the home button, It shows me opened apps like before (the same as the “square button” next to the home button does)
when I swipe from my home screen, it opens the App Drawer as it should
That means only one thing - success :blush:

Then I tried unplugging power cable and guess what happened…
Nothing! It didn’t lock itself and I could easily open a page in Angelfish.

Thank You for these advices (that mobile friendly version of firefox is great!) :wink:
I think I should even switch to the dev kit version (I’m not sure if it is a good idea since it isn’t stable - BUT the features tempts me a LOT). Or maybe first try the properly working stable. Just not sure :slight_smile:

I only don’t know, what is “clip” good for. It never launched and there are other aps like “mpv” and “Vvave” preinstalled. I had also issues with uninstalling Telegram (I don’t use it and discover didn’t want to do it due to an error - solved with pamac, which told me, that another app wants it as an voluntarily dependency but then let me to uninstall it)

Yeah, I recognize your doubts :slight_smile: To choose the more stable release that is lacking functionality, or the unstable releases that feature all the new cool stuff but could break any moment (and very often do) :smile:

Clip is a nice mobile video player by the way. MPV is a general purpose video player that can play lots of video formats, but is lacking a proper GUI as far as I know. VVave is a music player :slight_smile:

About package managers: yeah, Discover isn’t fully functionally yet but its getting better over time! Pamac is a good replacement in the mean time but I believe it’s not meant for mobile devices, while Discover is made to be suitable or it. Personally I just update/add/remove applications through the terminal though, it actually goes faster because there isn’t an entire GUI to load up and typing goes quite well on the virtual keyboard :slight_smile:

Yep. I tried Mobian and Manjaro Phosh and they both amazed me with fully working mobile data connection.
Lomiri didn’t even boot properly (but based on how old is the last image on github I’d expect that lomiri isn’t developed anymore)
And then I tried to uninstall an app in Manjaro Phosh - I didn’t use that app - and it unistalled phosh, too (dependency :laughing:)

Plasma mobile has much cooler look and I just like it. However, it crashes easily and the difference between dev and stable are that stable crashes like dev and dev crashes even more than a dev should (but has more features :slight_smile:)

That’s the problem. Clip is probably good bud when I want to try it, it doesn’t seem to work. (Doesn’t matter if it is on stable or dev kit system. It just doesn’t work)
With mpv and Vvave I meant that there’s no point of having preinstalled an app that doesn’t work, when there are some alternatives preinstalled, too (clip somehow doesn’t work for me and I don’t know what to do about it)

I didn’t mean functionality. I hate that discover shows me results of searching for an app only after I press enter, that it installs/uninstalls whatever when I click on the install/uninstall button etc.
Pamac shows me searching results as I type and has a nice feature - you first mark what you want to do and then you do it.

I also use pacman but when I don’t know the proper name of an app (there is probably a search command that I only don’t know), I just install it graphically.

Clip has an issue right now, because we ship with ffmpeg-pp which is ffmpeg 4.3 with v4l2-request patches on top. But if you switch it to the regular ffmpeg package, Clip works just fine.

Vvave should work. What alternatives to a music player do you have preinstalled on your system? I don’t have any.

Trying it right now but there are issues with dependencies

Sorry for my bad formulations. It was still about clip - when there are alternatives for clip like mpv and Vvave, I didn’t see the point of preinstalled clip
Vvave of course works fine :slight_smile:

So these problems didn’t allow me to do it with terminal but Discover did it :slight_smile:
looks working now :slight_smile:

Pamac 10.1 is designed for mobile devices

1 Like

I think pamac is great.
Only that mobile version sometimes doesn’t fit well on 5.95" screen

10.1.1 did massive improvements to this btw.

It works well, only some buttons are harder to touch, when they are only halfway on the display :laughing:

Did I notice right that you ship with ffmpeg now? (and not with ffmpeg-pp)

Yes. The latest images have the regular ffmpeg.

Btw, there is a type of menu, that pops up like a bubble - for example when you want to go to settings in pamac - which somehow doesn’t work in plasma mobile.
When I open it, the menu pops up as it should but I can’t tap on anything.
I have this issue in pamac and 2048 (game)

It’s a general (and known) issue with GTK apps in Plasma Mobile.