Plasma irregular theme after update

I upgraded to Plasma 6 today and I was greeted with a weird look.

  1. Floating panel is active but it doesn’t float.
  2. Boxy look.
  3. Takes awhile to log out.

My issue seems similar to this but I have already tried the proposed solution.

Screenshots:


System:
  Kernel: 6.1.90-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=ceffef7e-e60f-4e13-8bcc-fab6e0860e39 rw quiet splash
    udev.log_priority=3 resume=UUID=386684cd-e5fa-4a29-8800-015a86734107
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Aspire A515-43 v: V1.08
    serial: <superuser required>
  Mobo: PK model: Grumpy_PK v: V1.08 serial: <superuser required>
    part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 1.08
    date: 04/07/2020
Battery:
  ID-1: BAT1 charge: 26.6 Wh (99.3%) condition: 26.8/47.8 Wh (56.0%)
    volts: 12.1 min: 11.2 model: LGC AP18C8K type: Li-ion serial: <filter>
    status: discharging
CPU:
  Info: model: AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
    built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
    stepping: 1 microcode: 0x8108102
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1390 high: 1400 min/max: 1400/2600 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1400 2: 1393
    3: 1400 4: 1368 bogomips: 20769
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; STIBP:
    disabled; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Acer Incorporated ALI driver: amdgpu v: kernel arch: GCN-5
    code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 05:00.0
    chip-ID: 1002:15d8 class-ID: 0300 temp: 57.0 C
  Device-2: Chicony HD User Facing driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1:2 chip-ID: 04f2:b64f
    class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi
    wayland: drv: radeonsi x11: drv: radeonsi
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.6-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Vega 3 Graphics
    (radeonsi raven2 LLVM 17.0.6 DRM 3.49 6.1.90-1-MANJARO)
    device-ID: 1002:15d8 memory: 1.95 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: N/A device: 0 type: integrated-gpu name: AMD
    Radeon Vega 3 Graphics (RADV RAVEN2) driver: mesa radv
    v: 24.0.6-manjaro1.1 device-ID: 1002:15d8 surfaces: xcb,xlib,wayland
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 05:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: snd_pci_acp3x v: kernel
    alternate: snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
    snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir, snd_sof_amd_rembrandt
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.1.90-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.5 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 17.0 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Info: services: mld, NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:4 chip-ID: 8087:0a2a
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 3 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
  Local Storage: total: 1.03 TiB used: 825.82 GiB (78.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520
    SDAPNUW-128G-1014 size: 119.24 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 tech: SSD serial: <filter>
    fw-rev: 20110000 temp: 39.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 5J scheme: GPT
Partition:
  ID-1: / raw-size: 36.1 GiB size: 35.24 GiB (97.61%) used: 23.11 GiB (65.6%)
    fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 82.64 GiB size: 80.79 GiB (97.76%)
    used: 72.56 GiB (89.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 5.08 GiB used: 388 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 58.2 C mobo: N/A gpu: amdgpu temp: 58.0 C
  Fan Speeds (rpm): N/A
Repos:
  Packages: 1512 pm: pacman pkgs: 1498 libs: 428 tools: pamac,yay pm: flatpak
    pkgs: 14
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: https://mirrors2.manjaro.org/stable/$repo/$arch
    2: https://mirrors.manjaro.org/repo/stable/$repo/$arch
    3: https://mirrors.cicku.me/manjaro/stable/$repo/$arch
Info:
  Memory: total: 20 GiB note: est. available: 17.5 GiB used: 4.05 GiB (23.1%)
  Processes: 221 Power: uptime: 44m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.99 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34

Try deleting the ~/.cache directory:

rm -rf ~/.cache && systemctl reboot

Additionally, your previous themes/widgets may not be compatible with Plasma 6. I suggest using Breeze for the time being.

Cheers.

2 Likes

I don’t think I can do that. That folder is 18GB in size in a country like mine, that’s a big loss.

That’s what I am using. I didn’t install much custom stuffs on Plasma 5

Even my SDDM looks weird with kinda overlapping text (not shown here)

Well, I’ve given you the likely solution; there’s not much else I can do. You could of course create a new User account for comparison - this will not have any leftovers from the existing account, and should render as expected.

Good luck.

I didn’t think of this, only possible issues I can think of is my IDE’s and and a few others stuffs :weary:

Another option I’m thinking of is running parts of this script.

What do you think?

I’ve seen that suggested; and I’ve also seen reports that it had no affect at all. I’d try the new profile first, and confirm that it’s ok there; and then focus on cleaning your normal profile. Note that the .cache directory is usually recreated after the next reboot, if you delete it; only it will no longer contain remnants of old junk.

It didn’t work.
At this point, I might consider reinstalling everything.

It’'s a cache. There is nothing in there that cannot be recreated.


I really wish people would stop calling it that. The names “profile”, “start menu” and “taskbar” are Windows terms and do not accurately reflect the underlying principles in a UNIX operating system.

It’s called a user account. :stuck_out_tongue:

How did you update? From the looks from your desktop i guess, you probably didn’t log out and updated with tty?

You can also rename the cache folder and reboot.

If you have a snapshot to rollback your system, you may can update again… probably the right way?

1 Like

Both. I started from my desktop then it killed everything so I had to move to tty to continue

Will try that.
Edit: Didn’t work.

No snapshot

This begins to look like the better solution;
that is, if you want to avoid a complete reinstall:

Just you settle down; making judgements from behind your mac-look-alike desktop; such hypocrisy :scream_cat: :crazy_face: :smirk_cat:

I’ve now done the same, actually, minus the wallpaper. Finally I agree; the lack of Global Menu for Firefox really is noticeable.

1 Like

As seen here, I already tried with a new account/profile. Same issue exists.

Have you considered looking for a new Plasma 6-compatible GLOBAL theme? There are a few starting to appear.

At least macOS is a UNIX. Microsoft Windows is… not… :grin:

I’m still using the old and long-unsupported firefox-appmenu-bin here, because building an up-o-date one takes 5 hours at 100% CPU load. :frowning:

chromium does support the global menu, but being a Google product, it’s got other issues… :frowning_with_open_mouth:

I’ve changed my wallpapers now, to go with the new Plasma-6-suitable global theme I’ve installed. I’m using Material Design wallpapers now. Screenshots available via PM if so desired. :wink:

Na. I’d rather reinstall.

My wallpapers are always cycling; enough to last a few months at a time, I dare say. I have noticed a lack of overly useful native widgets though. This alone must be disappointing to those who had to dump any they had previously added.

I can’t argue with that logic, either. Sometimes it’s good to clean house. :wink:

1 Like

I’m using only two non-native ones, both from the AUR…

  • plasma6-applets-window-title (which should really have been included in the repo); and
  • plasma6-applets-separator-git (which replaces the one from Latte Dock I had installed earlier).

I have a Margins separator… is that the same? Ah, no, it’s not!

plasma6-applets-window-title seems much the same as the Window List widget, at first glance. Sure, let’s see those screenshots.

Now try creating a new user and verify your claim.

Next, I think some cleaning up will be the order of the day.

After a clean install, I still have theme issues. My panel and some some components remains on dark theme even after switching to other themes.