Pinebook Pro Update crashed

Unfortunately my Pinebook Pro crashed during upgrade.
First I will try to salvage the files as much as possible.

I have U-Boot 2021-07 and I tried to boot Manjaro 23.02, but it doesn’t boot from micro SD or USB after a cold boot.
I also tried Armbian and it boots, so it should be possible to salvage my files.
And restarting Armbian from USB, I can start Manjaro 23.02 from micro SD (remove USB immediately after restart).

What are my options to get Manjaro back on the eMMC, without taking the eMMC out?
Is it possible to fix the broken installation?
It tries to boot, but after a while I only get a blinking cursor.
Or is the only option to reinstall Manjaro 23.02 from micro SD?

I had the same blinking cursor, jiyong and I am still trying to recover, but it wasn’t during an upgrade. It just happened after a normal reboot.

Personally, U-Boot has always been a bit flakey on my machine from the day of its first boot, so I recently installed Tow-Boot to SPI.

I think Armbian is still U-boot oriented, though Tow-Boot should work too. Manjaro seems to be the opposite now. From what I recall of the Manjaro PBP installation howto, it says Manjaro tests with Tow-Boot.

My root (/) partition was on my NVMe SSD and I had the /boot partition on eMMC, because it has been more reliable than boot on NVMe over the last two years. Now I’m trying to get my NVMe root system up and booting again.

I removed my eMMC and used an adapter to install a fresh copy of Manjaro and it’s booting fine with Tow-Boot, but you can also image or repair a system by booting an SD card (Armbian, if it works) and mounting eMMC or NVMe from there. I’ve done it many times with dd but now download and install Balena Etcher, though I had trouble getting Etcher to run on my PBP at one time and actually just copied it over from another arm64 architecture system. However, if you need to do a chroot to your old Manjaro system, I suspect that a chroot from Armbian might be problematic, but even those problems should be solvable.

So here is where I’m at now. You are not exactly in the same boat (boot ;)) as I, but Tow-Boot might solve your problem, if you install it. My problem now is I accidentally deleted all my /boot files for my NVMe system.

I’ll let you know if I develop any insights. Again, we both should be able to recover, but might needs some help. So far, no response from my post on these Manjaro forums so I made a plea for help on the Pine64 forum today too:

Good luck!