PiHole - FTLDNS

Hi everyone !

I tried to install Pi-hole Server on my computer following this tutorial :
https://wiki.archlinux.org/title/Pi-hole

There is no any information about editing the config file /etc/pihole/pihole-FTL.conf, so I directly tried to start the service. It failed, so I tried both tricks explained at :
https://wiki.archlinux.org/title/Pi-hole#Failed_to_start_Pi-hole_FTLDNS_engine

Even if port 53 was free, because systemd-resolved.service was stopped and disabled, I edited the /etc/systemd/resolved.conf file as described. Then I tried again to start pihole-FTL.service, but it failed. I canceled modifications in resolved.conf, tried the second trick by editing /etc/dnsmasq.conf file, but pihole-FTL.service still failed to start.

Here is the answer of systemctl status pihole-FTL :

# systemctl status pihole-FTL
× pihole-FTL.service - Pi-hole FTLDNS engine
     Loaded: loaded (/usr/lib/systemd/system/pihole-FTL.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Wed 2021-08-04 15:32:18 CEST; 4s ago
    Process: 16998 ExecStartPre=/bin/chown -R pihole:pihole /etc/pihole (code=exited, status=0/SUCCESS)
    Process: 16999 ExecStartPre=/bin/chown root:root /etc/pihole/logrotate (code=exited, status=0/SUCCESS)
    Process: 17000 ExecStart=/usr/bin/pihole-FTL no-daemon (code=exited, status=1/FAILURE)
   Main PID: 17000 (code=exited, status=1/FAILURE)
        CPU: 18ms

août 04 15:32:18 MSI-Manjaro systemd[1]: pihole-FTL.service: Failed with result 'exit-code'.
août 04 15:32:18 MSI-Manjaro systemd[1]: pihole-FTL.service: Scheduled restart job, restart counter is at 5.
août 04 15:32:18 MSI-Manjaro systemd[1]: Stopped Pi-hole FTLDNS engine.
août 04 15:32:18 MSI-Manjaro systemd[1]: pihole-FTL.service: Start request repeated too quickly.
août 04 15:32:18 MSI-Manjaro systemd[1]: pihole-FTL.service: Failed with result 'exit-code'.
août 04 15:32:18 MSI-Manjaro systemd[1]: Failed to start Pi-hole FTLDNS engine.

And here is my config file /etc/pihole/pihole-FTL.conf :

### This file contains parameters for FTL behavior.
### At install, all parameters are commented out. The user can select desired options.
### Options shown are the default configuration. No modification is needed for most
### installations.
### Visit https://docs.pi-hole.net/ftldns/configfile/ for more detailed parameter explanations

## Out of documentation
LOGFILE=/run/log/pihole-ftl/pihole-FTL.log
PIDFILE=/run/pihole-ftl/pihole-FTL.pid
PORTFILE=/run/pihole-ftl/pihole-FTL.port
SOCKETFILE=/run/pihole-ftl/FTL.sock

## Socket Listening
## Listen only for local socket connections or permit all connections
## Options: localonly, all
SOCKET_LISTENING=localonly

## Query Display
## Display all queries? Set to no to hide query display
## Options: yes, no
QUERY_DISPLAY=yes

## AAA Query Analysis
## Allow FTL to analyze AAAA queries from pihole.log?
## Options: yes, no
AAAA_QUERY_ANALYSIS=yes

## Resolve IPv6
## Should FTL try to resolve IPv6 addresses to host names?
## Options: yes, no
RESOLVE_IPV6=yes

## Resolve IPv4
## Should FTL try to resolve IPv4 addresses to host names?
## Options: yes, no
RESOLVE_IPV4=yes

## Max Database Days
## How long should queries be stored in the database -days-?
## Setting this to 0 disables the database
## See: https://docs.pi-hole.net/ftldns/database/
## Options: number of days
MAXDBDAYS=365

## Database Interval
## How often do we store queries in FTL's database -minutes-?
## See: https://docs.pi-hole.net/ftldns/database/
## Options: number of minutes
DBINTERVAL=1.0

## Database File
## Specify path and filename of FTL's SQLite3 long-term database.
## Setting this to DBFILE= disables the database altogether
## See: https://docs.pi-hole.net/ftldns/database/
## Option: path to db file
DBFILE=/etc/pihole/pihole-FTL.db

## Max Log Age
## Up to how many hours of queries should be imported from the database and logs -hours-?
## Maximum is 744 -31 days-
## Options: number of days
MAXLOGAGE=24.0

## FTL Port
## On which port should FTL be listening?
## Options: tcp port
FTLPORT=4711

## Privacy Level
## Which privacy level is used?
## See: https://docs.pi-hole.net/ftldns/privacylevels/
## Options: 0, 1, 2, 3
PRIVACYLEVEL=0

## Ignore Localhost
## Should FTL ignore queries coming from the local machine?
## Options: yes, no
IGNORE_LOCALHOST=no

## Blocking Mode
## How should FTL reply to blocked queries?
## See: https://docs.pi-hole.net/ftldns/blockingmode/
## Options: NULL, IP-NODATA-AAAA, IP, NXDOMAIN
BLOCKINGMODE=NULL

## Regex Debug Mode
## Controls if FTLDNS should print extended details about regex matching into pihole-FTL.log.
## See: https://docs.pi-hole.net/ftldns/regex/overview/
## Options: true, false
REGEX_DEBUGMODE=false

I then installed lighttpd with all php7 required packages, they all work well together, but pihole-FTL.service persists in not working.

Does anyone could help me to make this service work ? Thanks a lot for your help !

Do your part to keep the forums tidy. Posting in old threads, or “necrobumping” is generally discouraged in the technical issue subforums, since it can potentially create disjointed “zombie” information; outdated posts with data which is no longer relevant due to Manjaro’s rolling nature, combined with more recent posts reflecting more current circumstance. Furthermore, technical support threads should remain succinct, and multiple pages are to be avoided if possible.

Rules of thumb

  • If you have a question, start a new thread and link to the old if relevant.
  • If you have something to add and judge that your information is related, but more up-to-date, start a new thread and link to the old if desired, but avoid duplicating effort by posting information already contained in the Manjaro wiki.
  • If you have a version-agnostic or corresponding solution, necrobumping can be appropriate.

Thank you.

1 Like

My bad ! I hoped I could get a quick answer from @anon8629588, the creator of the previous thread. So I changed my answer for him with a description of the whole issue.

I feel so stupid, I just randomly restarted my computer, and it worked… :sweat_smile: Beginner mistake !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.