I need some help installing pihole or adguard

Hi All,
I need your help, I think I’m in a bit over my head.

I am posting this here because I found a thread in this section asking about pihole vs adguard.
If this is in the wrong spot, please let me know.

So I have xfce running off of an SD card at the moment on my old Android S912 box. I have literally spent all day trying different desktops (KDE and XFCE) and dozens of dtb’s to see if any of them would get my wifi working.
Sadly no luck with the wifi, but thankfully I do have Ethernet working.

I would like to install pihole or adguard and see how well it works before I attempt to install this xfce installation on the emmc of the Android box.

The issue
The installation of either pihole or adguard does not appear to be straightforward, or is it?

I’ve searched these forums for help installing either pihole or adguard, and here’s what I’ve learned.

Pihole isn’t supported on Linux, but you could follow these instructions from Arch:

(Pi-hole - ArchWiki)

However, these instructions seem a little convoluted to me.
Here is post from someone else who looks like he had a heck of a time getting it to work:

It appears that installing Adguard is simpler (famous last words?)

This Arch page AUR (en) - adguardhome has links to Github, which I’ll get to in a minute, but also has three files at the bottom.
Would I be wrong to assume that I could download the .gz file, extract it and install Adguard?

The Github page GitHub - AdguardTeam/AdGuardHome: Network-wide ads & trackers blocking DNS server lists several instructions at the bottom, including using curl:

curl -s -S -L https://raw.githubusercontent.com/AdguardTeam/AdGuardHome/master/scripts/install.sh | sh -s – -v

If I am not mistaken, you can use curl in Manjaro - correct?

And they also mention using the Snap Store.

I don’t know much about this Snap Store but read somewhere, a while ago, that it is frowned upon outside of Ubuntu.

So, what I am looking for is the easiest, foolproof way to install either pihole or adguard.
Right now my gut is telling me that adguard looks like it will be easier to install (and set up too).

I could use a little guidance here, and will gladly welcome and appreciate any help that you may provide.

Are you familiar with docker? In my opinion this is fastest, simplest and most foolproof way to install and using both.
Pihole: GitHub - pi-hole/docker-pi-hole: Pi-hole in a docker container – this don’t need any explanations, just set WEBPASSWORD variable and run provided compose
AdGuard: Docker · AdguardTeam/AdGuardHome Wiki · GitHub – there is no ready-to-use compose, but you can use this:

version: "3"
    image: adguard/adguardhome
    container_name: adguard_home
    restart: unless-stopped
      # high ram consumption fix, see https://github.com/AdguardTeam/AdGuardHome/issues/5606
      - GOGC=40
      - GOMEMLIMIT=100MiB
      - 53:53/tcp
      - 53:53/udp
      - 80:80/tcp
      - 443:443/tcp
      - 443:443/udp
      - 3000:3000/tcp # only for first setup
      - 853:853/tcp
      - 853:853/udp
      - 5443:5443/tcp
      - 5443:5443/udp
      - 67:67/udp # dhcp
      - 68:68/tcp # dhcp
      - 68:68/udp # dhcp
      - ./workdir:/opt/adguardhome/work
      - ./confdir:/opt/adguardhome/conf

I used both for some time, both are very good solutions, Adguard needs slightly more resources than Pihole. My final choice was Adguard – DNS over TLS is game changer for me and my phone :wink:

1 Like

Hi @Tomek, thank you for you post, I appreciate your help.

I am unfamiliar with Docker, how many resources does it take to run?
My old Android box only has 2Gb of Ram, 16Gb storage and an S912 chip, it’s not a very powerful machine.

Let me ask you a tangential question, how risky would it be to simply run pihole on Android 6.0 (it’s no longer supported and has it’s share of vulnerabilities). Pihole would be the only thing running on the Android box.

That should be more than enough. Pihole needs ~200MiB and Adguard needs ~300MiB. Both consume ~2x when refreshing lists (cpu doesn’t matter, with slower it take more time, on my server also not powerful it takes ~1min). It’s highly dependent on how many hosts you add to blocklist – I have ~1M ~ more you add more RAM will be eaten.

If you don’t expose it to public network it should be ok though I would recommend something supported :wink:

Almost nothing, services you run on it will eat all :wink:

1 Like

Huh, what?

Did you read his “solution” though?

Anyway, how will you learn if you won’t even try? Sometimes you just have to spend few hours (or days) before you manage to make something work for the first time. (Pihole install is pretty straightforward though.)

It won’t get any easier as with a wiki. So giving guidance in this case is usually giving you a link of some wiki. :stuck_out_tongue: And from your side it makes sense you first try making it work. And only after you did A, B and C and can’t do D, you open a thread where you write in detail what you did and where you’re stuck.

Thank you very much @Tomek, I really appreciate your help!

I will definitely look into Docker, it sounds like it will enable some very interesting applications. I can’t wait to get into it.

And thank you for answering my tangential question.
I had compared the energy consumption of the Android box, when it was running Pi-Hole on Android 6.0 it draws only 2W, however, when it was running xfce, just idling, not running Pi-Hole, it was drawing 3W. I don’t know if this is due to xfce using more resources than Android, or if it is a function of running the OS off of an SD card, or a combination of the two.

Since the Android box is rooted, I installed a Firewall and blocked absolutely everything that wasn’t necessary for Pi-Hole to run and am using it with Unbound to filter out ads.

Now, the 16+ hours that I spent running Manjaro ARM XFCE and KDE with 12 different dtbs has not been for nothing.
I actually have a second Android box, a T95K, that I also included in my efforts. The two boxes have different WiFi chips and was hoping that at least one of them would have working wifi but that unfortunately wasn’t the case.

However, now that I know about Docker, I think I will be able to do something very interesting with this second Android box.

So again, thank you for your help.
That’s what I like about this Manjaro community, there are so many great people who are willing to help.
Well, usually that’s true, however there are exceptions to the rule…



Huh, what?

It’s right there on the Archwiki page:

Note: Pi-hole on Arch Linux is not officially supported by the Pi-hole project.

Really, not willing to try? I literally said I spent all day working on this Android box (it was over 16 hours actually) and you tell me I am not willing try?

Take a look at all of my posts over the last month.
Tell me again how I’m not willing to try.

I’ll take the high road here and leave you with this:

If you ever come across someone who is asking for help, help them, don’t kick them when their down. Helping them is the decent thing to do.

I really do hope you have a wonderful day.

This is not the same as “Pihole isn’t supported on Linux”. Pihole is only supported on Linux - Pi OS, Ubuntu, Debian, Fedora and CentOS Stream.

Please go back and read your own first post. And now imagine you are some third person reading that. What kind of impression do you get out of it?
I can tell you from my perspective: Someone is asking if he can do something, because he thinks some wiki post seems too hard that it should be working at all.

There is absolutely no mention of what you tried, where yu’re stuck, etc.

Here is another example:

Do you really need an answer to that? Can’t you just type curl in terminal?

You haven’t even explained what the problem is. You basically asked if someone can rewrite wiki post for you. And where was I “kicking you down”? By telling you how to formulate your post better, so more people can answer you?

So now the only answer you got is “Do it in docker”, which to me is kind of half-answer. Sure, you can, but what if it works even better without any containers? I know it works fine on my RPi with ArchlinuxARM. (It was, however, a long time ago, when I installed it.)

1 Like

I would spend the few bucks required to aquire a raspberry pi starter kit.

Then Pi-hole is a piece of cake.

I don’t use pi-hole - instead I use bind for name resolution using Response Policy Zone populated with domains and ips which are banned. I update the zone when I remember it.

This setup has the added benefit of using root servers - thus bypassing ISP provided nameservers.

That runs of on 8G sd card on a very old rpi connected to my lan using ethernet.

1 Like

First of all let’s be clear, no one asked you or anyone else to rewrite a wiki.

I had posed several questions in my original post and asked for people’s opinion.
In your original response, you did not address any of these questions.

Let’s try this another way, because I would rather this be a positive exchange of ideas.

Since there is some confusion here, let me restate them so that hopefully you can provide some positive feedback.
After all I am seeking the input from experienced Linux users and you seem to be one, so hopefully you will be able to provide some insight. If you don’t want to share your thoughts on these questions, no worries, kindly ignore this post, but maybe by restating them someone else will be wiling to share their Linux knowledge with me.

The pihole wiki had several red flags, first it states that it is not supported by Arch or Manjaro.
Then it states that you have to install the pihole package from AUR, and there are plenty of warnings on this forum saying that using AUR packages can bork your system, especially when you run an update. The last thing I want to do is bork my OS because I installed a program from an AUR package.
They also listed a series of potential problems in section 6 and I did not know if they were specific to this, unsupported in Manjaro install, or to pihole in general.

All of this is why I thought it was a little convoluted (maybe a different choice of words would have been more clear).

However, in your follow up post you did provide some helpful information:

It’s good to know that it works for you, and has for a long time, even though it isn’t supported. You installed it on ArchlinuxARM so the question of whether or not installing this on Manjaro using the AUR package will cause a problem still remains.
However, you did alert me to the possiblity of trying ArchlinuxARM on my old Android box. I have spent days trying many different OS’s and dtb’s, looking for one that would have working WiFi on my Android box, but so far all of my efforts have been fruitless.

Here are my other questions, hopefully you can provide some insight into them:

I am unfamiliar with the curl command.
I know that the defaults program/command for installing new programs in Manjaro is pamac and pacman.
The people who created Manjaro chose these for a reason, I don’t know why but trust they had good reasons.
I know there are several other options to pamac and pacman, but don’t know if they are “supported” as in encouraged or discouraged.
I also don’t know if there are any caveats or warnings that should accompany using curl.
Is there any risk to using this command?
Again the last thing I want to do is bork my OS because I blindly used a command that maybe I should not have.

Should the Snap Store be avoided like the plague, or is it fine to use but just has a bad reputation?

Is my assumption correct, can you simply download the .gz file, extract it and install Adguard?

From what I can tell, it appears that installing Adguard would be a much simpler process, but that is based on a couple of assumptions. The first assumption being that you can simply use the one curl command and it will install Adguard.
The other assumption is that you could simply download the .gz file and after extracting, you could install Adguard.
Either of these seems much simpler when compared to following several steps of a wiki for a program that is unsupported in Manjaro and requires you to use an AUR package, a practice that is generally frowned upon.

Am I correct in my assertion here?

As for pihole vs adguard, the setup seems fairly similar although they say adguard has a slightly more intuitive interface and they both make use of the same adlists.

Wow, you never cease to amaze @linuz-aarhus!
You use BIND, that is impressive, from what I’ve read it is not for beginners or the faint of heart. You must be a network guru!

There are sold out everywhere around here.
They recently announced the Pi5 and there are people who ordered the Pi4 a year ago and are still waiting.
Not to mention the prices have skyrocketed in recent years.
The Zero Pi was $5 when it first came out, now it is around $25, and that is just for the bare board, no case, power supply, etc.

I have been keeping my eye on a barebones fanless mini pc running a J4125 on AliExpress, but they are around $150 with shipping.
If I got that, I would set up pfsense on it which I’m told you can also run pihole as a module.

Fanless mini pc for pfsense


Why don’t you use a supported OS then? Plenty (most?) programs that have some kind of Linux support don’t support an Arch-based distros, but probably Red Hat, Debian and the likes.
This doesn’t mean the program won’t run or work as intended, only that you shouldn’t expect any help from their forums.

User can bork their system if they don’t know what they are doing. And these warnings are for users that think they are too smart to read and learn before using it.

Plenty of archwiki has troubleshooting section. I don’t see how this is a deterrent. They are specific to whatever the article is about, don’t you think.

I have zero knowledge of your Android box, what arch it uses, what works on it. I’m sure anything you tried so far, is unsupported by said android box. :stuck_out_tongue:

Familiarize yourself then. There has to be literally thousand pages about curl, and yet after 2 days you are still saying you are unfamiliar.

Curl has nothing to do with installing programs. I guess you should be reading about pipes as well. Try “piping curl into bash or sh”.

As I can see it you don’t even have a working system yet and you are worried you’ll bork it?

It’s your system, you can use whatever you want. Again, there is plenty of info online so you have to decide for yourself. I can only tell you I’m not using it.

No idea what is in that archive and how it’s supposed to be run.

I can tell you you will bork your systems plenty of times. You are just too far behind in understanding what you want to do.

There is a reason why package managers exist. They account where every file of a package goes, etc. And you are saying running random scripts, manually opening archives and running stuff, etc. seems easier. Remember there won’t be any pacman -R or pamac remove (or whatever) when you want to remove whatever that script did, wherever it put all the files.

Anyway, this is a rushed answer, because I’m in a hurry. Seriously, start READING stuff. What is AUR, what is PKGBUILD, what is this, what that, what does X do,… Instead of spending time DOING things, spend 3 days just reading.

I don’t see my self as network guru - I am very aware of my limitations :slight_smile: - I have though - spent a couple of decades as freelance network admin for various companies.

At some point I had a few customers for which I created a hosted exchange service, for others I hosted their domain with mail and web services.

For that purpose I ran a public DNS service registered with the danish internet domain registrar https://punktum.dk so bind was a necessity.

bind is a pain to work with but at some point I got fed up with my queries ending in NXDOMAIN so I had to rework my home lan in a predicatble manner - using a subnet to a public domain - and bind was the only method that was viable when having multiple domains. I still want to run authoritative DNS for my LAN.

Several projects has surfaced since then - so I will have a look at pi-hole as I am thinking of switching my network to use encrypted dns lookup.

1 Like

Opinion:- A more than fair response.

1 Like

You are too modest!

Thank you.