Picom not opening properly

Sorry for bugging you guys , but the blur agent picom is not working

[ 18/12/21 19:39:33.452 wid_set_text_prop ERROR ] Failed to make text property: vgit-dac85.
[ 18/12/21 19:39:33.452 register_cm ERROR ] Failed to set COMPTON_VERSION.

this errors are coming

  Kernel: 5.15.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=815f2f32-74b8-4d03-b441-dc420f70dfcf rw quiet
  Desktop: i3 4.20.1 info: polybar vt: 7 dm: LightDM 1.30.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook 14_ASUS Laptop X407UAR v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X407UAR v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X407UAR.304 date: 06/05/2019
  ID-1: BAT0 charge: 24.8 Wh (99.2%) condition: 25.0/33.3 Wh (75.1%)
    volts: 11.1 min: 11.1 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: Not charging cycles: 32
  RAM: total: 11.58 GiB used: 2.11 GiB (18.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i3-7020U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xEA
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 700 min/max: 400/2300 scaling: driver: intel_pstate
    governor: powersave cores: 1: 700 2: 700 3: 700 4: 700 bogomips: 18406
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
    hwp_epp hwp_notify ibpb ibrs intel_pt invpcid invpcid_single lahf_lm lm
    mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti
    pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0
    chip-ID: 8086:5921 class-ID: 0300
  Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-6:2 chip-ID: 13d3:5a11 class-ID: 0e02
  Display: x11 server: X.Org driver: loaded: modesetting
    alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8")
    diag: 354mm (13.9")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.8-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: no
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: AzureWave driver: ath9k v: kernel modules: wl bus-ID: 02:00.0
    chip-ID: 168c:0036 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-8:5
    chip-ID: 13d3:3490 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: not found
    rfk-block: hardware: no software: no address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 931.51 GiB used: 43.95 GiB (4.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0J scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
    used: 43.95 GiB (4.8%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 815f2f32-74b8-4d03-b441-dc420f70dfcf
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 24F2-00E6
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-6:2 info: IMC Networks USB2.0 VGA UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:5a11 class-ID: 0e02
  Device-2: 1-8:5 info: IMC Networks type: Bluetooth driver: btusb
    interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 13d3:3490
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 44.0 C pch: 40.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 197 Uptime: 33m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 Packages: apt: 0 pacman: 1156 lib: 298 Shell: fish
  v: 3.3.1 running-in: alacritty inxi: 3.3.11

Instead of apologies, share the information about your system and the errors from terminal as formatted text. See here [HowTo] Provide System Information

I tried my best and gave a formatted version. thanks for the tip

See if by reinstalling this with
pamac install libx11 lib32-libx11
and rebooting the system, you still get the errors.

Also, you might have got into the same issue as described here

even tho, you should not … What version of picom/comton are you using?

I am using 8.2-1

Thats not a formatted version … thats some output like from screenfetch, and not the same as the command for information shown in the guide.

Thanks for the info. I think this is the info you like to have. I didn’t knew that bullet pointers open :sweat_smile:

I already have this libraries

This line should include compositor, such as mine:

Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: amdgpu 

So you seem to not have one right now.

I guess I would also mention

Seems odd to me.
Maybe it is legacy code … but Picom is the successor to Compton, which doesnt really exist any more.

ok i removed compton.conf which seemed to have fixed the error. Also do you have any guides for managing blur with picom , just running picom -b doesn’t seemed to do anything :sweat_smile:

man picom

is probably a good start … its also notable that most things from compton work in picom … just rebranded.
(for example, it should be picom.conf)

For more info see these:




nevermind it is coming back :frowning_face:

The same error? Why/how?
Do you have picom.conf and/or compton.conf? What is in it?
(also lets see on the far flung chance you actually have compton installed … pacman -Qs compton)

local/picom 8.2-1
    X compositor that may fix tearing issues

This is the output for that command

Great. just picom installed.
Now … what about the conf’s ?

I deleted the compton.conf earlier
this is my picon.conf

Please remove that and replace it with the one from /etc/xdg/picom.conf And edit that.
You can keep your previous one for reference if you like …

mv ~/.config/picom.conf ~/.config/picom.conf.bak
cp /etc/xdg/picom.conf ~/.config/

(IDK if your is in .config or .config/picom/ … augment above as necessary)

Still not working , but blur was working on kde , i really don’t understand what’s the problem here

What do you mean not working?
You have errors?
Or just that the effects (blur) are not working as you like?

Same errors coming , i even deleted the config reinstalled picom